LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   VirtualBox 3.1.6 kernel @ SlackBuild error - kernel include dir (http://www.linuxquestions.org/questions/slackware-14/virtualbox-3-1-6-kernel-%40-slackbuild-error-kernel-include-dir-811374/)

dc_eros 05-31-2010 08:02 PM

VirtualBox 3.1.6 kernel @ SlackBuild error - kernel include dir
 
Hi again slackers,

I tried to build the virtualbox 3.1.6 kernel using the files from slackbuilds.org and I got this error that says it cannot find the kernel include directory.

My current kernel is 2.6.33.2 (slack 13.1).

I tried SOME_VAR=/usr/include --> (I forgot the exact variable name, but I used the variable name I saw in the error message) just a guess :D, but it didn't work of course.

Is it at /usr/src/linux-2.6.33.2/include or something like that? Or is there anything wrong with the slackbuild script?

Thanks in advance

rmjohnso 05-31-2010 08:16 PM

The latest version of VirtualBox is 3.2.0. Try installing it and see if it will compile the kernel module against 2.6.33.2.

http://www.virtualbox.org/wiki/Linux_Downloads

Edit: By the way, the kernel on Slackware 13.1 is 2.6.33.4, not 2.6.33.2.

dc_eros 05-31-2010 08:33 PM

Quote:

Originally Posted by rmjohnso (Post 3988016)
The latest version of VirtualBox is 3.2.0. Try installing it and see if it will compile the kernel module against 2.6.33.2.

http://www.virtualbox.org/wiki/Linux_Downloads

Edit: By the way, the kernel on Slackware 13.1 is 2.6.33.4, not 2.6.33.2.

Regarding the kernel, the 2.6.33.4 does not work on my machine. I have posted a thread on that. Only the 2.6.33 until 2.6.33.2 works but using the 2.6.33 config.

I only want to use what is provided by slackbuilds. I'll also bring the 3.2.0 package so that if 3.1.6 won't work, I'll git it a try.

Thanks :D

rmjohnso 05-31-2010 09:33 PM

Quote:

Originally Posted by dc_eros (Post 3988025)
Regarding the kernel, the 2.6.33.4 does not work on my machine. I have posted a thread on that. Only the 2.6.33 until 2.6.33.2 works but using the 2.6.33 config.

I only want to use what is provided by slackbuilds. I'll also bring the 3.2.0 package so that if 3.1.6 won't work, I'll git it a try.

Thanks :D

Sorry, I didn't see your other post until now. What are your concerns about using package from Oracle for VirtualBox? Is it that it's closed source?

dc_eros 05-31-2010 11:24 PM

I've found out that the slackbuild script works on kernel 2.6.33.4. Got to try the 3.2.0


All times are GMT -5. The time now is 09:22 AM.