LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-24-2006, 05:54 AM   #1
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Rep: Reputation: 37
Cool virtual terminals and X


Hello!
I am running Slackware Linux 11 with kernel 2.6.18 and KDE 3.5.4.
I have the following newbie question:
What do I need to do, so that I start more that one X sessions on the same machine, for example under different users?
I read some literature on the problem, but probably I misunderstand something. They say that e.g. if I am in a X session with kde, and I need to login as a different user and start his X kde session without stopping my current session, I have to:
1. Ctr+Alt+F2
2. login as the other user
3. type startx -- :1 v8

However. this does not seem to work, something goes wrong. In addition then I cannot return to my X session, although I type Alt+F7. The screen just goes blank and nothing seems to work.

I would be thankful to any suggestions or any literature on the issue recommended

Regards,
Martin
 
Old 12-24-2006, 06:46 AM   #2
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
The KDE menu has a "Switch User" entry at the bottom. Right-clicking on the desktop also pops up a menu with that option. Is that what you're looking for?
 
Old 12-24-2006, 07:00 AM   #3
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
Question

I am running in runlevel 3, not in 4. so I do not have a switch user option. I wish those thing that I read there worked on my machine. Besides, once I am in kde up and running and I type Ctrl+Alt+F2, I can no more return to my kde session. typing Alt+F7 makes a blank screen and all I can do is ctr+alt+del Why?
 
Old 12-24-2006, 09:07 AM   #4
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Ok, I have put myself into the same config as you (Slack11, KDE, runlevel 3).

1- I login as user "pu" on tty1 and type "startx" -> X session :0 opens on tty7. You are right, you don't have a switch user option then.

2- I go to tty2 using CTRL-ALT-F2. I login as user "sy". "startx" complains about session :0 already being in use, so I type "startx -- :1" (no v8 suffix as in your first post). X opens session :1 on tty8.

3- At this point, I can switch to tty1 with CTRL-ALT-F1, to tty2 with CTRL-ALT-F2, to tty7 i.e. X session :0 i.e. user "pu" with CTRL-ALT-F7, and to tty8 i.e. X session :1 i.e. user "sy" with CTRL-ALT-F8.

So basically it works. I can advise you to always use the CTRL-ALT-Fx combination because it always works. Apart from that, you need to post more information - error messages, what do you do exactly, what happens.

Also, if your machine doesn't respond anymore, if you have another machine try connecting to the first one using ssh and look what's happening.
 
Old 12-24-2006, 10:28 AM   #5
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
Thank you very much for your responsiveness. The problem with startx has been the nolisten -tcp server argument that was passed by default to the startx script. I had long ago added that option to the startx script to mute some messages, but now I saw what it actually serves for . So I removed the "nolisten tcp" from startx, and now the command "startx -- :1" works. So I login as "marto" in tty1, issue "startx", kde loads ok, then I do ctrl+alt+f2, login as "user", issue "startx -- :1", kde starts successfully. So far so good. The next step is return to marto's kde by typing ctrl+alt+f7. Alas! Again the infamous blank screen . Typing neither alt+f3, or alt+"f"whatsoever works, nor ctrl+alt+f8, or ctrl+alt+"f"whatsoever. The only command that works in that blank screen is ctrl+alt+del. This is the only way to get rid of the blank screen. Do you have any idea?

The only modifications to the startx script after the fresh Slackware 11.0 installation I have made is the one I mentioned above-I added "nolisten tcp" to the serverargs option, and now I have deleted it. But why can I not switch between X sessions by means of ctrl+alt+fx?

Thank you very much for your attention.
Regards,
Martin
 
Old 12-24-2006, 10:43 AM   #6
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Which keyboard layout do you have?
Check which keyboard layout is specified in /etc/X11/xorg.conf: XkbModel, XkbLayout, XkbVariant. Maybe it doesn't match so your keyboard combinations are not properly interpreted by X.
 
Old 12-24-2006, 10:57 AM   #7
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
This is an excerpt from my xorg.conf:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
EndSection

hmmm. My locale is set to en_GB. The keyboard layout I use is also GB... Probably this is the problem? What do I have to do? I would like to preserve my keyboard layout and locale settings to GB, however. Will just replacing the "us" option above with "gb" work?

Regards,
Martin
 
Old 12-24-2006, 11:04 AM   #8
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Is this a laptop or a desktop, an international keyboard or not? The Model, i.e. pc101, 102, 104 or 105 matters.

From what I find through Google, try pc105 (for a desktop, international keyboard) and "gb". If it doesn't work, try other combinations.

The good news is - this is most probably the solution to your problem.
 
Old 12-24-2006, 11:29 AM   #9
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
It is a desktop PC, the keyboard is BENQ, but I do not know how many keys have to be specified. And will the key combinations be the same?
 
Old 12-24-2006, 11:32 AM   #10
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
It's either pc104 or pc105. Try those with layout "gb".
 
Old 12-24-2006, 01:44 PM   #11
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
So I tried everything I could figure out, but in vain. I changed all the locale settings back to en_US, set the keyboard layout to us, modified xorg.conf for pc101,pc104 and pc105, and xkblayout="us", but I always got the ubiquitous blank screen where the only working command is ctrl+alt+del.
I as well tried all these combinations with xkblayout="gb" in xorg.conf, and the locale in en_GB,and the kde keyboard layout in gb, but all the same. I really have no idea what to try further

However, I notice that when I start kde, it says:"initialising system services" even when the locale and the default keyboard layout is set to en_US. As I can remember it used to say "initializing system services" before I had for the first time moved to GB. Probably there is something else that has to be set to us? I am really at a loss now
 
Old 12-24-2006, 02:46 PM   #12
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
Is it possible that the keyboard kombinations are different on my machine for some reason or other? Does xorg.conf need some special settings to enable this feature? I have generated the xorg.conf with xorgsetup.
 
Old 12-25-2006, 09:15 AM   #13
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Don't mix locale and keyboard layout. Locale doesn't have anything to do with this, so just set it to what you want and don't touch it.

As for the keyboard layout, if it's gb, then why do you want to set it to anything else such as us?

Please set your config back to gb / pc105 and retest. If it doesn't work, please post your complete /etc/X11/xorg.conf.
 
Old 12-25-2006, 12:07 PM   #14
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Original Poster
Rep: Reputation: 37
No, it does not work. Once I am in kde and type ctrl+alt+f2, I get to tty2. Then typing crtl+alt+f7 gets me to a blank screen, where only ctrl+alt+del works. Here is my whole xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/share/fonts/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
# FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "xtrap"
Load "record"
Load "dbe"
Load "dri"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30-107
VertRefresh 48-120

Modeline "1024x768_100.00" 113.31 1024 1096 1208 1392 768 769 772 814 -HSync +Vsync
DisplaySize 260.1 195.1
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "i810"

Option "XVideo" "on"
Option "DevicePresence" "On"
VideoRam 65536
VendorName "Intel Corporation"
BoardName "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"

Mode 0666
EndSection

I hope this will help to solve the problem.
Thank you very much for your attention.
Regards,
Martin
 
Old 12-25-2006, 12:31 PM   #15
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Can you also post your /etc/inittab?
Also, another test would be to start in runlevel 4 and try the "Switch User" option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Terminals in C++ Anno Programming 2 06-20-2006 01:26 AM
Virtual terminals rnicholus Linux - Software 1 09-21-2005 01:30 PM
Virtual Terminals Kruncher Slackware 9 04-25-2005 06:19 AM
Virtual Terminals sadiboyz Linux - Newbie 1 04-23-2003 04:43 PM
Virtual Terminals moger Linux - General 2 09-29-2002 10:34 PM


All times are GMT -5. The time now is 02:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration