LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2005, 02:06 PM   #1
Kruncher
Member
 
Registered: Mar 2005
Distribution: Ubuntu
Posts: 61

Rep: Reputation: 15
Virtual Terminals


The problem:
Virtual terminals will not work at all when in X. Virtual terminals DO work while at the init 3 login prompt but NOT in init 4 login

What I've tried:
Editing /etc/inittab and changing:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

to

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

and

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

to

# These are the standard console login getties in multiuser mode:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

Doing xorgconfig 2 different ways:

setting my keyboard as

3 Generic 104-key PC

and

64 Logitech Internet Navigator Keyboard



I am not sure why none of this works since Virtual Terminals worked in Mandrake 10.1, Knoppix 3.4, Slax 4.2 and BeatrIX 2005.1.

My system is Slackware 10.1, Full install, running the bareacpi kernel (2.4.29).

Thank you in advance for your help.

P.S. My window manager is XFCE 4.2.0 and my Nvidia driver is 7174
 
Old 04-23-2005, 02:53 PM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
Re: Virtual Terminals

Quote:
Originally posted by Kruncher
The problem:
Virtual terminals will not work at all when in X. Virtual terminals DO work while at the init 3 login prompt but NOT in init 4 login
init 4 starts X straight to the GUI............kdm, gdm, xfce, etc.............
 
Old 04-23-2005, 02:59 PM   #3
Kruncher
Member
 
Registered: Mar 2005
Distribution: Ubuntu
Posts: 61

Original Poster
Rep: Reputation: 15
oh ok.

When I set the /etc/inittab default runlevel to 4 it will start up the gdm login manager, from there on virtual terminals do not work.
If I set the default runlevel to 3 the virtual terminals work untill I login AND run startx
 
Old 04-23-2005, 03:30 PM   #4
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 440

Rep: Reputation: 51
Quote:
When I set the /etc/inittab default runlevel to 4 it will start up the gdm login manager, from there on virtual terminals do not work.
What do you mean by "virtual terminals do not work" ? If you set in xorg.conf appropriate generic keyboard model, Ctrl+Alt+F7 key combination won't you bring to virt. terminal ? If you log in from gdm and start some X-terminal like xterm, gnome-terminal, konsole, aterm etc. and type
Code:
ps xa|grep agetty
do you recognize some instances of agetty login running ?
 
Old 04-23-2005, 04:01 PM   #5
Kruncher
Member
 
Registered: Mar 2005
Distribution: Ubuntu
Posts: 61

Original Poster
Rep: Reputation: 15
ps ax | grep agetty:
2611 tty1 Ss+ 0:00 /sbin/agetty 38400 tty1 linux
2612 tty2 Ss+ 0:00 /sbin/agetty 38400 tty2 linux
2613 tty3 Ss+ 0:00 /sbin/agetty 38400 tty3 linux
2614 tty4 Ss+ 0:00 /sbin/agetty 38400 tty4 linux
2615 tty5 Ss+ 0:00 /sbin/agetty 38400 tty5 linux
2616 tty6 Ss+ 0:00 /sbin/agetty 38400 tty6 linux

I mean when I hit Ctrl+Alt+F# in X my pc does nothing at all, it just stays on the current desktop, no flash of black, no console at all.
Normal consoles work fine (xterm, konsole, etc).
When the default runlevel is set at 3 Alt+F# works fine, I can switch to all my virtual consoles with no problem.
 
Old 04-23-2005, 06:12 PM   #6
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 440

Rep: Reputation: 51
Quote:
Originally posted by Kruncher
ps ax | grep agetty:
2611 tty1 Ss+ 0:00 /sbin/agetty 38400 tty1 linux
2612 tty2 Ss+ 0:00 /sbin/agetty 38400 tty2 linux
2613 tty3 Ss+ 0:00 /sbin/agetty 38400 tty3 linux
2614 tty4 Ss+ 0:00 /sbin/agetty 38400 tty4 linux
2615 tty5 Ss+ 0:00 /sbin/agetty 38400 tty5 linux
2616 tty6 Ss+ 0:00 /sbin/agetty 38400 tty6 linux
Agettys are running, so problem is likely caused by wrong keyboard configuration for X window - like Alt key as Meta key mapping. Try to change /usr/X11R6/lib/X11/xorg.conf in section for input device - keyboard. The most basic setting would look like following

Section "InputDevice"
Identifier "Keyboard"
Driver "kbd"
Option "XkbModel" "pc104" # set to your real kbd layout
EndSection


Just for curiosity you can make sure programaticaly that logins are running by calling chvt utility from X-terminal.
Code:
chvt 6
should switch you to terminal on /dev/tty6. Depending on permission settings in device tree, it has to be likely run under root login.
 
Old 04-23-2005, 06:46 PM   #7
Kruncher
Member
 
Registered: Mar 2005
Distribution: Ubuntu
Posts: 61

Original Poster
Rep: Reputation: 15
I ran chvt 6 as root and it switched to tty6, so what does that mean?

I tried editing /usr/X11R6/lib/X11/xorg.conf but the file does not exist.
My xorg.conf is located at /etc/X11/xorg.conf and this is the part that I belive your talking about:

Code:
Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"kbd"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option     "Protocol"      "Xqueue"

    Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#    Option	"Xleds"      "1 2 3"

#    Option "LeftAlt"     "Meta"
#    Option "RightAlt"    "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"    "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"   "de"
# or:
#    Option "XkbLayout"   "de"
#    Option "XkbVariant"  "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"

# These are the default XKB settings for Xorg
#    Option "XkbRules"    "xorg"
#    Option "XkbModel"    "pc101"
#    Option "XkbLayout"   "us"
#    Option "XkbVariant"  ""
#    Option "XkbOptions"  ""

#    Option "XkbDisable"

    Option "XkbRules"	"xorg"
    Option "XkbModel"	"pc104"
    Option "XkbLayout"	"us"
    Option "XkbVariant"	"us"

EndSection
Could this have anything to do with the part in xorgconfig where it asks you "Do you want to select additional XKB options (group switcher, group indicator, etc.)?" and I said No?
 
Old 04-24-2005, 10:56 AM   #8
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 440

Rep: Reputation: 51
Please just set minimal config for keyboard as I wrote in my previous post, ie. comment out with hash ('#') XkbRules, XkbLayout and XkbVariant lines and restart X server (ctrl+alt+backspace). Then try to switch again to some running virtual terminal (ctr+alt+f6) and let me know if it did help.
 
Old 04-24-2005, 10:56 PM   #9
Kruncher
Member
 
Registered: Mar 2005
Distribution: Ubuntu
Posts: 61

Original Poster
Rep: Reputation: 15
Yes, virtual terminals work now! Thank you dunric.

Could you explain why commenting out those 3 lines made virtual terminals work?

Again thank you.
 
Old 04-25-2005, 06:19 AM   #10
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 440

Rep: Reputation: 51
It seems the problem was in XkbVariant option, because "us" variant, at least in xorg 6.8.2 official package, doesn't exist. Existing variants are "basic" and "intl" for example, but if you don't wish special behaviour, you need not to use this option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual terminals rnicholus Linux - Software 1 09-21-2005 01:30 PM
How to get the virtual terminals onto my monitor? NRGizeR Linux - General 5 03-22-2005 04:22 AM
All virtual terminals have become corrupt Davidian1024 Linux - General 9 02-22-2005 11:19 AM
Virtual Terminals sadiboyz Linux - Newbie 1 04-23-2003 04:43 PM
Virtual Terminals moger Linux - General 2 09-29-2002 10:34 PM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration