LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-12-2009, 11:37 AM   #1
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Rep: Reputation: 32
Virtual Box in Slackware64 13. No sound.


Hello!
I've installed Virtualbox 3.06 in Slackware64 13.Everything is going fine except sound.

How can I make VirtualBox recognize and play sound? Sound works fine in Slackware. So the problem has to be with virtualbox. I've tried any of the virtualbox possibilities (alsa, oss, etc) but no results.

Thanks in advance,
 
Old 09-12-2009, 01:12 PM   #2
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Well, I will reply to myself.
Now sound works. I don't know why but after a couple of restarts, vbox recognizes OSS sound.
 
Old 10-04-2009, 07:36 PM   #3
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,233

Rep: Reputation: 176Reputation: 176
Same, same. No audio in VirtualBox.

I having the same problem with VirtualBox PUEL in Slackware64-13.

When I created a virtual machine it listed the audio as
"Host Driver: ALSA Audio Driver"
and
"Controller: ICH AC97"

When I went to install the operating system, XP-SP2, it returned this error message:

"No audio devices could be opened. Selecting Null audio backend with the consequences that no sound is audible."

Anyone know of a fix?
Thanks.

Edit in: OK, I tried the OSS setting as recommended above and it worked. Now I have sound in XP running in VirtualBox, but no sound in Slackware, but that is another problem in another thread.

Thanks.

Last edited by cwizardone; 10-04-2009 at 09:24 PM.
 
Old 10-05-2009, 12:13 AM   #4
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Rep: Reputation: 17
Hello,

I had the same problem with the PUEL version, could not get ALSA to work...
But the OSE Version works completly fine for me with ALSA output!

I posted in the VirtualBox forum, but that wasn't really helpful and I still suspect
that this is some kind of bug, but I was too lazy to make a real bugreport...
http://forums.virtualbox.org/viewtopic.php?f=7&t=22847

If you can live without:
Code:
    * Remote Desktop Protocol (RDP) control of VM
    * USB support, with remote devices over RDP
    * iSCSI support
    * Open Virtualization Format (OVF) support (import/export)
Then try the OSE VirtualBox.

You can find slackbuilds for it at slackbuilds.org

@cwizardone
Do you have a soundcard that uses the intel-hda driver?
I do and my sound is also blocked if something uses OSS.
But its also the other way around, if ALSA is in use /dev/dsp is "busy".
As long as everything uses ALSA I'm fine...

Last edited by hotchili; 10-05-2009 at 12:14 AM.
 
Old 10-05-2009, 01:09 AM   #5
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,233

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by hotchili View Post
...If you can live without:
Code:
    
    * USB support, with remote devices over RDP
Then try the OSE VirtualBox.
Thanks, but USB support is the reason for using the PUEL version. The OSE is of no use for my purposes.
Didn't have these problems using an older version of VirtualBox, but it won't work with the newer kernels.
Cheers.
 
Old 10-05-2009, 12:27 PM   #6
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
OSS fixed it for me, thanks!
 
Old 11-17-2009, 10:28 PM   #7
Domine
Member
 
Registered: Nov 2005
Posts: 31

Rep: Reputation: 17
Hello guys,
on that subject i found this.
In order to use ALSA for VirtualBox on Slackware64 13 you need to disable esound from libSDL. So you can uninstall the package. Compile your own version with disabled esound. You can use that command.
./configure --prefix=/usr/local --libdir=/usr/local/lib64 --enable-shared --disable-static --disable-esd --disable-x11-shared

Of course you can play with ./configure as you wish. Then install it and voila ALSA works for VBox.
I found that elsewhere on the net Give credit to unknown buddy.
That is how i did it.

Good luck and hope it helps
 
Old 11-17-2009, 11:17 PM   #8
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,375

Rep: Reputation: 164Reputation: 164
Actually, I had the same problem with Slackware64. I compiled a new kernel (2.6.31.1), and sound now works again in vbox using oss - plus sound still works in Slackware!
 
Old 02-14-2010, 07:24 PM   #9
slackcracker
LQ Newbie
 
Registered: Feb 2010
Location: Germany
Distribution: Slackware64-current (multilib) + KDE 4 - current
Posts: 13

Rep: Reputation: 1
Quote:
Originally Posted by em21701 View Post
OSS fixed it for me, thanks!
me too, works fine now
 
Old 02-15-2010, 01:50 AM   #10
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 921

Rep: Reputation: 92
Did you try 3.1.2 (or whatever the latest version is)? I had this same problem and with 3.1.2 it's gone (alsa output works). I should also add that I changed the guest system after upgrade (from Slack 12.2 to Pardus), but I don't think that it is the reason.
 
Old 02-15-2010, 07:41 PM   #11
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
I'm having the same problem. I'm running VirtualBox 3.1.4 r57640 on the -current kernel 2.6.32.7. I can't get any sound in an XP VM with alsa, but I can with OSS.

Quote:
Originally Posted by Domine View Post
In order to use ALSA for VirtualBox on Slackware64 13 you need to disable esound from libSDL. So you can uninstall the package. Compile your own version with disabled esound. You can use that command.
./configure --prefix=/usr/local --libdir=/usr/local/lib64 --enable-shared --disable-static --disable-esd --disable-x11-shared
In looking at the SlackBuild script for -current, --disable-esd is used, so I'm confused how rebuilding libSDL helps.
 
Old 02-19-2010, 03:12 PM   #12
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
I tried a recompile and a reinstall of libSDL last night from -current just to see if anything would change. I still don't have sound in VirtualBox when using ALSA.
 
Old 02-21-2010, 07:03 AM   #13
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,233

Rep: Reputation: 176Reputation: 176
Recently I did a fresh install of Slackware64-13, "upgraded" it to current, and then installed the latest version of VirtualBox.
Sound works in VB with both OSS and PulseAudio, but not with ALSA. However, as before, when VB is running there is no sound in KDE.
Does one have to be using ALSA in VirtualBox, if they can get it to work, to have sound in both KDE and VirtualBox at the same time?

Last edited by cwizardone; 02-21-2010 at 07:06 AM.
 
Old 02-21-2010, 01:54 PM   #14
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by cwizardone View Post
Recently I did a fresh install of Slackware64-13, "upgraded" it to current, and then installed the latest version of VirtualBox.
Sound works in VB with both OSS and PulseAudio, but not with ALSA. However, as before, when VB is running there is no sound in KDE.
Does one have to be using ALSA in VirtualBox, if they can get it to work, to have sound in both KDE and VirtualBox at the same time?
I use XFCE instead of KDE. I can get sound to work in VirtualBox via OSS, but then sound does not work for any other applications.
 
Old 02-24-2010, 08:46 PM   #15
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by cwizardone View Post
Recently I did a fresh install of Slackware64-13, "upgraded" it to current, and then installed the latest version of VirtualBox.
Sound works in VB with both OSS and PulseAudio, but not with ALSA. However, as before, when VB is running there is no sound in KDE.
Does one have to be using ALSA in VirtualBox, if they can get it to work, to have sound in both KDE and VirtualBox at the same time?
I just tried compiling PulseAudio with the dependencies that slackbuilds.org has, and it wouldn't compile for me.

I've Googled around more, and I still can't find a solution to this problem. Does anyone have any additional thoughts?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't install Slackware64-current on my Phenom box Lenard Spencer Slackware 12 08-24-2009 09:21 AM
[SOLVED] Slackware64-C client wont detect Slackware64-C Samba server slackass Slackware 5 08-07-2009 11:23 PM
slackware64 - enemy territory - et-sdl-sound ponce Slackware 7 06-07-2009 11:21 AM
Running virtual pc files in a virtual machine in linux ... preferably virtual box biharibong Linux - Software 4 01-21-2009 01:04 PM
Virtual Box. Removing a shared folder inside virtual xp. glore2002 Linux - Software 2 05-20-2007 11:12 AM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration