LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Virtual Box in Slackware64 13. No sound. (http://www.linuxquestions.org/questions/slackware-14/virtual-box-in-slackware64-13-no-sound-754662/)

glore2002 09-12-2009 11:37 AM

Virtual Box in Slackware64 13. No sound.
 
Hello!
I've installed Virtualbox 3.06 in Slackware64 13.Everything is going fine except sound.

How can I make VirtualBox recognize and play sound? Sound works fine in Slackware. So the problem has to be with virtualbox. I've tried any of the virtualbox possibilities (alsa, oss, etc) but no results.

Thanks in advance,

glore2002 09-12-2009 01:12 PM

Well, I will reply to myself.
Now sound works. I don't know why but after a couple of restarts, vbox recognizes OSS sound.

cwizardone 10-04-2009 07:36 PM

Same, same. No audio in VirtualBox.
 
I having the same problem with VirtualBox PUEL in Slackware64-13.

When I created a virtual machine it listed the audio as
"Host Driver: ALSA Audio Driver"
and
"Controller: ICH AC97"

When I went to install the operating system, XP-SP2, it returned this error message:

"No audio devices could be opened. Selecting Null audio backend with the consequences that no sound is audible."

Anyone know of a fix?
Thanks.

Edit in: OK, I tried the OSS setting as recommended above and it worked. Now I have sound in XP running in VirtualBox, but no sound in Slackware, but that is another problem in another thread.
:)
Thanks.

hotchili 10-05-2009 12:13 AM

Hello,

I had the same problem with the PUEL version, could not get ALSA to work...
But the OSE Version works completly fine for me with ALSA output!

I posted in the VirtualBox forum, but that wasn't really helpful and I still suspect
that this is some kind of bug, but I was too lazy to make a real bugreport...
http://forums.virtualbox.org/viewtopic.php?f=7&t=22847

If you can live without:
Code:

    * Remote Desktop Protocol (RDP) control of VM
    * USB support, with remote devices over RDP
    * iSCSI support
    * Open Virtualization Format (OVF) support (import/export)

Then try the OSE VirtualBox. :)

You can find slackbuilds for it at slackbuilds.org

@cwizardone
Do you have a soundcard that uses the intel-hda driver?
I do and my sound is also blocked if something uses OSS.
But its also the other way around, if ALSA is in use /dev/dsp is "busy".
As long as everything uses ALSA I'm fine...

cwizardone 10-05-2009 01:09 AM

Quote:

Originally Posted by hotchili (Post 3707929)
...If you can live without:
Code:

   
    * USB support, with remote devices over RDP

Then try the OSE VirtualBox. :)

Thanks, but USB support is the reason for using the PUEL version. The OSE is of no use for my purposes.
Didn't have these problems using an older version of VirtualBox, but it won't work with the newer kernels.
Cheers.
:)

em21701 10-05-2009 12:27 PM

OSS fixed it for me, thanks!

Domine 11-17-2009 10:28 PM

Hello guys,
on that subject i found this.
In order to use ALSA for VirtualBox on Slackware64 13 you need to disable esound from libSDL. So you can uninstall the package. Compile your own version with disabled esound. You can use that command.
./configure --prefix=/usr/local --libdir=/usr/local/lib64 --enable-shared --disable-static --disable-esd --disable-x11-shared

Of course you can play with ./configure as you wish. Then install it and voila ALSA works for VBox.
I found that elsewhere on the net :) Give credit to unknown buddy.
That is how i did it.

Good luck and hope it helps

mlangdn 11-17-2009 11:17 PM

Actually, I had the same problem with Slackware64. I compiled a new kernel (2.6.31.1), and sound now works again in vbox using oss - plus sound still works in Slackware!

slackcracker 02-14-2010 07:24 PM

Quote:

Originally Posted by em21701 (Post 3708536)
OSS fixed it for me, thanks!

me too, works fine now :p

Ilgar 02-15-2010 01:50 AM

Did you try 3.1.2 (or whatever the latest version is)? I had this same problem and with 3.1.2 it's gone (alsa output works). I should also add that I changed the guest system after upgrade (from Slack 12.2 to Pardus), but I don't think that it is the reason.

rmjohnso 02-15-2010 07:41 PM

I'm having the same problem. I'm running VirtualBox 3.1.4 r57640 on the -current kernel 2.6.32.7. I can't get any sound in an XP VM with alsa, but I can with OSS.

Quote:

Originally Posted by Domine (Post 3760796)
In order to use ALSA for VirtualBox on Slackware64 13 you need to disable esound from libSDL. So you can uninstall the package. Compile your own version with disabled esound. You can use that command.
./configure --prefix=/usr/local --libdir=/usr/local/lib64 --enable-shared --disable-static --disable-esd --disable-x11-shared

In looking at the SlackBuild script for -current, --disable-esd is used, so I'm confused how rebuilding libSDL helps.

rmjohnso 02-19-2010 03:12 PM

I tried a recompile and a reinstall of libSDL last night from -current just to see if anything would change. I still don't have sound in VirtualBox when using ALSA.

cwizardone 02-21-2010 07:03 AM

Recently I did a fresh install of Slackware64-13, "upgraded" it to current, and then installed the latest version of VirtualBox.
Sound works in VB with both OSS and PulseAudio, but not with ALSA. However, as before, when VB is running there is no sound in KDE.
Does one have to be using ALSA in VirtualBox, if they can get it to work, to have sound in both KDE and VirtualBox at the same time?

rmjohnso 02-21-2010 01:54 PM

Quote:

Originally Posted by cwizardone (Post 3871348)
Recently I did a fresh install of Slackware64-13, "upgraded" it to current, and then installed the latest version of VirtualBox.
Sound works in VB with both OSS and PulseAudio, but not with ALSA. However, as before, when VB is running there is no sound in KDE.
Does one have to be using ALSA in VirtualBox, if they can get it to work, to have sound in both KDE and VirtualBox at the same time?

I use XFCE instead of KDE. I can get sound to work in VirtualBox via OSS, but then sound does not work for any other applications.

rmjohnso 02-24-2010 08:46 PM

Quote:

Originally Posted by cwizardone (Post 3871348)
Recently I did a fresh install of Slackware64-13, "upgraded" it to current, and then installed the latest version of VirtualBox.
Sound works in VB with both OSS and PulseAudio, but not with ALSA. However, as before, when VB is running there is no sound in KDE.
Does one have to be using ALSA in VirtualBox, if they can get it to work, to have sound in both KDE and VirtualBox at the same time?

I just tried compiling PulseAudio with the dependencies that slackbuilds.org has, and it wouldn't compile for me.

I've Googled around more, and I still can't find a solution to this problem. Does anyone have any additional thoughts?


All times are GMT -5. The time now is 07:28 PM.