LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   vim won't open under screen (http://www.linuxquestions.org/questions/slackware-14/vim-wont-open-under-screen-588273/)

tuubaaku 09-29-2007 05:35 PM

vim won't open under screen
 
I just started using screen again, but it seems that vim won't open while I'm running screen. I can open elvis fine, as well as lynx, but no vim. It's the same whether I use Konsole or xterm. When I type the command, the cursor just moves to the next line and doesn't do anything. There's no processor activity, just nothing. When I list the processes, though, it shows the vim process.

Any thoughts? Things I can try/look into?

rg3 09-29-2007 05:51 PM

Inside screen, what's the value of the TERM environment variable? (echo $TERM). Also, can you post your ~/.screenrc if it exists?

tuubaaku 09-29-2007 08:47 PM

Here you go. I think everything's pretty much standard Slackware, except my escape command...

~$ echo $TERM
screen

~$ cat ~/.screenrc
escape ``
vbell on
autodetach on
startup_message off
pow_detach_msg "Screen session of \$LOGNAME \$:cr:\$:nl:ended."
defscrollback 1000

termcap xterm hs@:cs=\E[%i%d;%dr:im=\E[4h:ei=\E[4l
terminfo xterm hs@:cs=\E[%i%p1%d;%p2%dr:im=\E[4h:ei=\E[4l

termcapinfo xterm Z0=\E[?3h:Z1=\E[?3l:is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l

termcapinfo xterm* OL=100

termcapinfo xterm 'VR=\E[?5h:VN=\E[?5l'
termcapinfo xterm 'k1=\E[11~:k2=\E[12~:k3=\E[13~:k4=\E[14~'
termcapinfo xterm 'kh=\EOH:kI=\E[2~:kD=\E[3~:kH=\EOF:kP=\E[5~:kN=\E[6~'

termcapinfo xterm 'hs:ts=\E]2;:fs=\007:ds=\E]2;screen\007'

termcapinfo xterm 'vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l'

termcapinfo xterm 'XC=K%,%\E(B,[\304,\\\\\326,]\334,{\344,|\366,}\374,~\337'

termcapinfo xterm* be

termcapinfo wy75-42 xo:hs@

termcapinfo wy* CS=\E[?1h:CE=\E[?1l:vi=\E[?25l:ve=\E[?25h:VR=\E[?5h:VN=\E[?5l:cb=\E[1K:CD=\E[1J

termcapinfo hp700 'Z0=\E[?3h:Z1=\E[?3l:hs:ts=\E[62"p\E[0$~\E[2$~\E[1$}:fs=\E[0}\E[61"p:ds=\E[62"p\E[1$~\E[61"p:ic@'

termcap vt100* ms:AL=\E[%dL:DL=\E[%dM:UP=\E[%dA:DO=\E[%dB:LE=\E[%dD:RI=\E[%dC
terminfo vt100* ms:AL=\E[%p1%dL:DL=\E[%p1%dM:UP=\E[%p1%dA:DO=\E[%p1%dB:LE=\E[%p1%dD:RI=\E[%p1%dC
termcapinfo linux C8

bind k
bind ^k
bind .
bind ^\
bind \\
bind ^h
bind h
bind 'K' kill
bind 'I' login on
bind 'O' login off
bind '}' history

register [ "\033:se noai\015a"
register ] "\033:se ai\015a"
bind ^] paste [.]

rg3 09-30-2007 06:43 AM

I had a similar problem some time ago and I recalled it was due to the TERM environment variable, but yours is OK. You could try posting the output of the "env" command to try to see if there's anything weird, and also your vimrc if it exists and you could also try to run "strace vim" to see if there's anything weird. BTW, when you paste something use the "code" tag or it will be mangled by the forum software.

tuubaaku 09-30-2007 11:18 PM

Thanks for the ideas & for looking at this stuff. Here's my env output. I ran a diff on the output from running screen & not running it, and the main difference seems to be the whole TERMCAP stuff. The TERM variables also changes from xterm to screen.

Code:

CPLUS_INCLUDE_PATH=/usr/lib/qt/include:/usr/lib/qt/include
MANPATH=/usr/local/man:/usr/man:/usr/lib/java/man:/usr/lib/java/man:/usr/share/texmf/man
KDE_MULTIHEAD=false
DM_CONTROL=/var/run/xdmctl
HOSTNAME=slackbox.slacknet
SHELL=/bin/bash
TERM=screen
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/user/.gtkrc-2.0:/home/user/.kde/share/config/gtkrc-2.0
GS_LIB=/home/user/.fonts
GTK_RC_FILES=/etc/gtk/gtkrc:/home/user/.gtkrc:/home/user/.kde/share/config/gtkrc
WINDOWID=29360133
QTDIR=/usr/lib/qt
KDE_FULL_SESSION=true
USER=user
LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.bat=01;32:*.BAT=01;32:*.btm=01;32:*.BTM=01;32:*.cmd=01;32:*.CMD=01;32:*.com=01;32:*.COM=01;32:*.dll=01;32:*.DLL=01;32:*.exe=01;32:*.EXE=01;32:*.arj=01;31:*.bz2=01;31:*.deb=01;31:*.gz=01;31:*.lzh=01;31:*.rar=01;31:*.RAR=01;31:*.rpm=01;31:*.tar=01;31:*.taz=01;31:*.tb2=01;31:*.tbz2=01;31:*.tbz=01;31:*.tgz=01;31:*.tz2=01;31:*.z=01;31:*.Z=01;31:*.zip=01;31:*.ZIP=01;31:*.zoo=01;31:*.asf=01;35:*.ASF=01;35:*.avi=01;35:*.AVI=01;35:*.bmp=01;35:*.BMP=01;35:*.flac=01;35:*.FLAC=01;35:*.gif=01;35:*.GIF=01;35:*.jpg=01;35:*.JPG=01;35:*.jpeg=01;35:*.JPEG=01;35:*.m2a=01;35:*.M2A=01;35:*.m2v=01;35:*.M2V=01;35:*.m4a=01;35:*.M4A=01;35:*.m4p=01;35:*.M4P=01;35:*.m4v=01;35:*.M4V=01;35:*.mov=01;35:*.MOV=01;35:*.mp3=01;35:*.MP3=01;35:*.mpc=01;35:*.MPC=01;35:*.mpeg=01;35:*.MPEG=01;35:*.mpg=01;35:*.MPG=01;35:*.ogg=01;35:*.OGG=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.PNG=01;35:*.ppm=01;35:*.ram=01;35:*.RAM=01;35:*.rm=01;35:*.RM=01;35:*.tga=01;35:*.TGA=01;35:*.tif=01;35:*.TIF=01;35:*.tiff=01;35:*.TIFF=01;35:*.wav=01;35:*.WAV=01;35:*.wma=01;35:*.WMA=01;35:*.wmv=01;35:*.WMV=01;35:*.xbm=01;35:*.xcf=01;35:*.xpm=01;35:*.xwd=01;35:*.XWD=01;35:
GDK_USE_XFT=1
TERMCAP=SC|screen|VT 100/ANSI X3.64 virtual terminal:\
        :DO=\E[%dB:LE=\E[%dD:RI=\E[%dC:UP=\E[%dA:bs:bt=\E[Z:\
        :cd=\E[J:ce=\E[K:cl=\E[H\E[J:cm=\E[%i%d;%dH:ct=\E[3g:\
        :do=^J:nd=\E[C:pt:rc=\E8:rs=\Ec:sc=\E7:st=\EH:up=\EM:\
        :le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:\
        :li#38:co#124:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
        :cs=\E[%i%d;%dr:dl=\E[M:DL=\E[%dM:dc=\E[P:DC=\E[%dP:\
        :im=\E[4h:ei=\E[4l:mi:IC=\E[%d@:ks=\E[?1h\E=:\
        :ke=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:\
        :ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:\
        :se=\E[23m:mb=\E[5m:md=\E[1m:mr=\E[7m:me=\E[m:ms:\
        :Co#8:pa#64:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m:AX:\
        :vb=\Eg:G0:as=\E(0:ae=\E(B:\
        :ac=\140\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:\
        :po=\E[5i:pf=\E[4i:Z0=\E[?3h:Z1=\E[?3l:k0=\E[10~:\
        :k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS:k5=\E[15~:k6=\E[17~:\
        :k7=\E[18~:k8=\E[19~:k9=\E[20~:k;=\E[21~:F1=\E[23~:\
        :F2=\E[24~:F3=\E[2P:F4=\E[2Q:F5=\E[2R:F6=\E[2S:\
        :F7=\E[15;2~:F8=\E[17;2~:F9=\E[18;2~:FA=\E[19;2~:kb=^H:\
        :K2=\EOE:kB=\E[Z:kF=\E[1;2B:kR=\E[1;2A:*4=\E[3;2~:\
        :*7=\E[1;2F:#2=\E[1;2H:#3=\E[2;2~:#4=\E[1;2D:%c=\E[6;2~:\
        :%e=\E[5;2~:%i=\E[1;2C:kh=\E[1~:@1=\E[1~:kH=\E[4~:\
        :@7=\E[4~:kN=\E[6~:kP=\E[5~:kI=\E[2~:kD=\E[3~:ku=\EOA:\
        :kd=\EOB:kr=\EOC:kl=\EOD:km:
KDEDIR=/usr
SESSION_MANAGER=local/slackbox:/tmp/.ICE-unix/5250
XDG_CONFIG_DIRS=/etc/xdg:/etc/kde/xdg:/etc/xfce/xdg:/etc/kde/xdg:/etc/xfce/xdg
T1LIB_CONFIG=/usr/share/t1lib/t1lib.config
MINICOM=-c on
KONSOLE_DCOP=DCOPRef(konsole-5369,konsole)
PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/qt/bin:/usr/share/texmf/bin:.
DESKTOP_SESSION=kde
STY=6756.pts-3.slackbox
LC_COLLATE=C
PWD=/home/user
INPUTRC=/etc/inputrc
KONSOLE_DCOP_SESSION=DCOPRef(konsole-5369,session-3)
JAVA_HOME=/usr/lib/java
KDE_SESSION_UID=1000
LANG=en_US
PS1=\u@\h:\w\$
PS2=>
HOME=/home/user
SHLVL=3
LS_OPTIONS= -F -b -T 0 --color=auto
XCURSOR_THEME=default
LOGNAME=user
LESS=-M
WINDOW=0
LESSOPEN=|lesspipe.sh %s
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
DISPLAY=:0.0
COLORTERM=
_=/usr/bin/env

Here's my .vimrc (I don't think there's anything that's a problem, because it's the same problem whether or not I use it...):
Code:

set nocompatible
set softtabstop=3
set shiftwidth=3
syntax on
set foldmethod=marker
set autoindent
set nobackup
set number
set bs=2
set incsearch

"MAPS & ABBREVIATIONS
"mutt-style page up/down
noremap <Space> <PageDown>
noremap - <PageUp>
noremap t e
noremap T E
"insert/append a char & stay in normal mode
noremap e i <esc>r
noremap E a <esc>r
"alternative to <esc>
imap ii <esc>
"inoremap <tab> <esc>
"nnoremap > i<tab><esc>
"format paragraph
map f gqap
"yank whatever's selected into "w
map <F1> "wy
map <F2> "wp
imap <F2> <esc>"wpa
"grab a word and then paste it
imap <F3> <esc>B"zyWTa
imap <F4> <esc>"zpa
"tab stuff
map <F5> :tabnew<CR>
map <C-n> :tabnew<CR>
imap <F5> <esc>:tabnew<CR>i
imap <C-n> <esc>:tabnew<CR>i
map <F6> :tabprevious<CR>
map <C-Left> :tabprevious<CR>
map <F7> :tabnext<CR>
map <C-Right> :tabnext<CR>
imap <F6> <esc>:tabprevious<CR>i
imap <C-Left> <esc>:tabprevious<CR>i
imap <F7> <esc>:tabnext<CR>i
imap <C-Right> <esc>:tabnext<CR>i
map <F9> :set number!<CR>
imap <F9> <esc>:set number!<CR>i


rg3 10-01-2007 06:23 AM

I've compared your output of env with mine and there don't seem to be big differences. A bit in TERMCAP regarding the number of available lines and columsn, a bit in some KDE environment variables indicating that I use yakuake and you use konsole, etc. Everything seems to be minor, so I don't really know what more to check. See if you can resolv your hostname fine (slackbox.slacknet) and you have included an entry for it in /etc/hosts.

Code:

--- my-env.txt        2007-10-01 12:06:43.000000000 +0200
+++ his-env.txt        2007-10-01 12:04:55.000000000 +0200
@@ -16,62 +16,56 @@
        :kd=\EOB:kr=\EOC:kl=\EOD:km:
        :ke=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:\
        :le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:\
-        :li#32:co#159:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
+        :li#38:co#124:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
        :po=\E[5i:pf=\E[4i:Z0=\E[?3h:Z1=\E[?3l:k0=\E[10~:\
        :se=\E[23m:mb=\E[5m:md=\E[1m:mr=\E[7m:me=\E[m:ms:\
        :ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:\
        :vb=\Eg:G0:as=\E(0:ae=\E(B:\
 COLORTERM=
-CPLUS_INCLUDE_PATH=/usr/lib/qt/include
-DCOP_YAKUAKE_SESSION=3
-DESKTOP_SESSION=default
-DISPLAY=:0
+CPLUS_INCLUDE_PATH=/usr/lib/qt/include:/usr/lib/qt/include
+DESKTOP_SESSION=kde
+DISPLAY=:0.0
 DM_CONTROL=/var/run/xdmctl
 GDK_USE_XFT=1
-GPG_AGENT_INFO=/tmp/gpg-oIOVub/S.gpg-agent:1378:1
-GPG_TTY=/dev/pts/4
-GS_LIB=/home/rg3/.fonts
-GTK2_RC_FILES=/home/rg3/.gtkrc-2.0
-HISTCONTROL=ignoredups
-HISTSIZE=50
-HOME=/home/rg3
-HOSTNAME=localhost.localdomain
+GS_LIB=/home/user/.fonts
+GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/user/.gtkrc-2.0:/home/user/.kde/share/config/gtkrc-2.0
+GTK_RC_FILES=/etc/gtk/gtkrc:/home/user/.gtkrc:/home/user/.kde/share/config/gtkrc
+HOME=/home/user
+HOSTNAME=slackbox.slacknet
 INPUTRC=/etc/inputrc
 JAVA_HOME=/usr/lib/java
 KDEDIR=/usr
 KDE_FULL_SESSION=true
 KDE_MULTIHEAD=false
 KDE_SESSION_UID=1000
-KONSOLE_DCOP=DCOPRef(yakuake,konsole)
-KONSOLE_DCOP_SESSION=DCOPRef(yakuake,session-1)
-LANG=en_US.UTF-8
+KONSOLE_DCOP=DCOPRef(konsole-5369,konsole)
+KONSOLE_DCOP_SESSION=DCOPRef(konsole-5369,session-3)
+LANG=en_US
 LC_COLLATE=C
 LESS=-M
 LESSOPEN=|lesspipe.sh %s
-LOGNAME=rg3
+LOGNAME=user
 LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.bat=01;32:*.BAT=01;32:*.btm=01;32:*.BTM=01;32:*.cmd=01;32:*.CMD=01;32:*.com=01;32:*.COM=01;32:*.dll=01;32:*.DLL=01;32:*.exe=01;32:*.EXE=01;32:*.arj=01;31:*.bz2=01;31:*.deb=01;31:*.gz=01;31:*.lzh=01;31:*.rar=01;31:*.RAR=01;31:*.rpm=01;31:*.tar=01;31:*.taz=01;31:*.tb2=01;31:*.tbz2=01;31:*.tbz=01;31:*.tgz=01;31:*.tz2=01;31:*.z=01;31:*.Z=01;31:*.zip=01;31:*.ZIP=01;31:*.zoo=01;31:*.asf=01;35:*.ASF=01;35:*.avi=01;35:*.AVI=01;35:*.bmp=01;35:*.BMP=01;35:*.flac=01;35:*.FLAC=01;35:*.gif=01;35:*.GIF=01;35:*.jpg=01;35:*.JPG=01;35:*.jpeg=01;35:*.JPEG=01;35:*.m2a=01;35:*.M2A=01;35:*.m2v=01;35:*.M2V=01;35:*.m4a=01;35:*.M4A=01;35:*.m4p=01;35:*.M4P=01;35:*.m4v=01;35:*.M4V=01;35:*.mov=01;35:*.MOV=01;35:*.mp3=01;35:*.MP3=01;35:*.mpc=01;35:*.MPC=01;35:*.mpeg=01;35:*.MPEG=01;35:*.mpg=01;35:*.MPG=01;35:*.ogg=01;35:*.OGG=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.PNG=01;35:*.ppm=01;35:*.ram=01;35:*.RAM=01;35:*.rm=01;35:*.RM=01;35:*.tga=01;35:*.TGA=01;35:*.tif=01;35:*.TIF=01;35:*.tiff=01;35:*.TIFF=01;35:*.wav=01;35:*.WAV=01;35:*.wma=01;35:*.WMA=01;35:*.wmv=01;35:*.WMV=01;35:*.xbm=01;35:*.xcf=01;35:*.xpm=01;35:*.xwd=01;35:*.XWD=01;35:
 LS_OPTIONS= -F -b -T 0 --color=auto
-MANPATH=/usr/local/man:/usr/man:/usr/lib/java/man:/usr/share/texmf/man
+MANPATH=/usr/local/man:/usr/man:/usr/lib/java/man:/usr/lib/java/man:/usr/share/texmf/man
 MINICOM=-c on
-OLDPWD=/home/rg3/src/c_c++/chroot-run
-PATH=/home/rg3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/qt/bin:/usr/share/texmf/bin
-PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
-PS1= [1m[\u@\h \W]\$ [m
-PWD=/home/rg3
+PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/qt/bin:/usr/share/texmf/bin:.
+PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
+PS1=\u@\h:\w\$
+PS2=>
+PWD=/home/user
 QTDIR=/usr/lib/qt
-SESSION_MANAGER=local/localhost:/tmp/.ICE-unix/1450
+SESSION_MANAGER=local/slackbox:/tmp/.ICE-unix/5250
 SHELL=/bin/bash
 SHLVL=3
-STY=26255.pts-3.localhost
+STY=6756.pts-3.slackbox
 T1LIB_CONFIG=/usr/share/t1lib/t1lib.config
 TERM=screen
 TERMCAP=SC|screen|VT 100/ANSI X3.64 virtual terminal:\
-USER=rg3
-VISUAL=vim
+USER=user
 WINDOW=0
-WINDOWID=31476404
-XCURSOR_THEME=neutral
-XDG_CONFIG_DIRS=/etc/xdg:/etc/kde/xdg
-XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic,auto
-ZIPOPT=-r -9
+WINDOWID=29360133
+XCURSOR_THEME=default
+XDG_CONFIG_DIRS=/etc/xdg:/etc/kde/xdg:/etc/xfce/xdg:/etc/kde/xdg:/etc/xfce/xdg
+XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
 _=/usr/bin/env


tuubaaku 10-01-2007 03:20 PM

I do have any entry in /etc/hosts, and I can ping slackbox.slacknet fine, so I think that means everything's OK...

I noticed that vim is now mouse-aware in slackware (or if it was before, I didn't notice it). Now you can select text when running vim in Konsole, and vim changes to visual mode. Anyway, could that be something that's not working under screen?

I'm kind of grasping at straws, because I really don't know what kind of problem it is. :(

tuubaaku 10-01-2007 04:27 PM

OK, I've made progress. When I reboot, it works. But, when I got my dhcp address, where I was sending a different hostname, it stopped working. So, I changed my hostname to match what I was sending to the dhcp server, and that's not a problem anymore.

The other problem involves my svn KDE4. If I switch to my kde4 user & launch a KDE4 application from screen, vim stops working. I'm not sure exactly sure what's happening here, but I can work around it for now.

kierse 03-03-2008 03:07 PM

Has anyone had any luck identifying the source of this problem, and a solution? I'm currently experiencing this problem and haven't yet found a permanent workaround.

I'm running Slackware 12.0

thanks,
Kierse

zhoun 03-04-2008 08:15 AM

Did you upgraded some packages from slackware current such as gtk+2?

kierse 03-04-2008 11:26 AM

Not that I know of but its been a while since I've had to update anything on my machine. I've been experiencing this particular problem for quite some time but it hasn't really affected me until recently.

I'll compare my installed package against the Slack 12 list and see if there are any differences.

kierse 03-10-2008 12:03 PM

So I compared a list of installed packages on my machine against the Slack 12 list of packages and didn't notice anything unusual.

I did however come up with a functional (yet hackish) work around for anyone having this problem: while working in screen, each virtual terminal's environment variable TERM has a value of 'screen'. Setting this variable to 'xterm' (ie. enter TERM='xterm' in command prompt) in every virtual terminal you wish to run vim in seems to correct the issue. Vim obviously uses this variable for something but isn't written to properly handle a TERM value of 'screen'.

kierse 03-10-2008 12:05 PM

So I compared a list of installed packages on my machine against the Slack 12 list of packages and didn't notice anything unusual.

I did however come up with a functional (yet hackish) work around for anyone having this problem: while working in screen, each virtual terminal's environment variable TERM has a value of 'screen'. Setting this variable to 'xterm' (ie. enter TERM='xterm' in command prompt) in every virtual terminal you wish to run vim in seems to correct the issue. Vim obviously uses this variable for something but isn't written to properly handle a TERM value of 'screen'.

evilDagmar 03-10-2008 12:34 PM

I have a vague memory of something involving a bad interaction with gpm, but that's all I can remember at the moment. Try killing off gpm and see if the problem remains.

chess 08-08-2008 09:54 AM

Quote:

Originally Posted by evilDagmar (Post 3084022)
I have a vague memory of something involving a bad interaction with gpm, but that's all I can remember at the moment. Try killing off gpm and see if the problem remains.

For the sake of posterity, I have been running into this same problem -- vim freezing when used inside screen -- and disabling gpm was the answer. Thanks, Dagmar.


All times are GMT -5. The time now is 11:06 PM.