LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-17-2012, 08:02 AM   #1
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,310
Blog Entries: 5

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
vim in Slack14_64 gets 'stuck'


Funny thing happened on the way to my editor... I can't use "vim". It just hangs until I issue a "killall -9 vim".

I had an 'alias vi="vim"' but I remarked it out trying to track this down. I also REM'd out the EDITOR and export EDITOR statements in my .bashrc and .alias files. I mv'd the .vimrc to .vimrc.last and re-sourced everything.

/usr/bin/vim will not run. It just sits there.

Brand spanking new Slack14/64 with multilibs but I am not sure that has any bearing on this.

FWIW: "vim" also hangs for root.

Here's some stuff I hope will provide enough info for the community to help...

Packages installed:
Code:
-rw-r--r-- 1 root root  62K Oct 11 2012 10:20 PM vim-7.3.645-x86_64-1
-rw-r--r-- 1 root root 1.4K Oct 11 2012 10:26 PM vim-gvim-7.3.645-x86_64-1
vim --version
Code:
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Aug 29 2012 11:33:02)
Included patches: 1-645
... (truncated lengthy output)...
Thank you for your time.

Moderators:
Sorry, I never know which sub-forum I should post to with these types of Questions.
I use Slackware but other than that it could also be in Linux - Software - Thanks or Sorry!

I tried
Editing ~/.bashrc and modified EDITOR statement:
Code:
export EDITOR="/usr/bin/vim"
and it worked for a minute.

I REM'arked all references to vim in my ~/.bashrc and ~/.aliases files.
vi works flawless and without issue,
vim is still hosed.
Thank you!

Last edited by Habitual; 10-17-2012 at 03:01 PM.
 
Old 10-17-2012, 03:45 PM   #2
audriusk
Member
 
Registered: Mar 2011
Location: Klaipėda, Lithuania
Distribution: Slackware
Posts: 248

Rep: Reputation: 107Reputation: 107
Could you try running
Code:
$ strace -o strace-vim.log vim
and check the contents of strace-vim.log file? If you don't understand all the gibberish in that log file, post it here as attachment (it'll most likely be too big to post inline) so people can look at it.

Quote:
Originally Posted by Habitual View Post
vi works flawless and without issue,
vim is still hosed.
That's because /usr/bin/vi points to elvis in Slackware, which is different from vim.
 
Old 10-17-2012, 06:05 PM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hi,

you should check, if vim works for another user.

What did you do before vim broke? did you edit your .vimrc file?

Markus
 
Old 10-17-2012, 11:28 PM   #4
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Rep: Reputation: Disabled
My machine is having a problem with vi about the $LANG setup. It doesn't work properly. However, vim is working just fine for me. So I have a soft link of vi pointing to vim. You might want to try a soft link instead of all these setting. (I don't know it helps or not)
 
Old 10-18-2012, 09:50 AM   #5
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,310
Blog Entries: 5

Original Poster
Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
markush:

Thanks! Strange...
I added a new user vim added and I sudo su - vim and 'vim' worked. I exited and tried my own and it worked...? Logged in to console as vim and 'vim' worked. Same for root and my account.
I did a 'reinstall' yesterday when previous measures failed.
I edited nothing in recent memory.

audriusk:

Thanks also, I will run a strace when it happens next.

688a:

I didn't think mine was $LANG-related.
Code:
echo "$LANG"
en_US
grep lang /etc/profile.d/lang.sh 
export LANG=en_US
for now, I guess I'll give it some time. Maybe it is fixed?.

Thanks!

Last edited by Habitual; 10-18-2012 at 10:37 AM.
 
Old 10-23-2012, 11:40 AM   #6
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,310
Blog Entries: 5

Original Poster
Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
It happened again.
Tue Oct 23, 2012 - 12:33:49 PM EDT

This time I strace'd it.

attached.

I have logged out but I have not rebooted.

This cropped up again when I tried to "sudo /usr/sbin/sbopkg" I believe.

vim is broken for myself and root. the vim user it isn't.
Attached Files
File Type: log strace-vim.log (65.1 KB, 18 views)
 
Old 10-25-2012, 01:48 AM   #7
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
gpm is probably your issue as well https://bugzilla.redhat.com/show_bug.cgi?id=168076
 
Old 10-25-2012, 10:11 AM   #8
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,310
Blog Entries: 5

Original Poster
Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Quote:
Originally Posted by sahko View Post
gpm is probably your issue as well https://bugzilla.redhat.com/show_bug.cgi?id=168076
That 'feature' that I enabled this go-round (but never did in the past)?

Next time it gets stuck, I'll bounce/kill gpm.

Thanks for your time,

Edit0:
I see this thread too...http://www.linuxquestions.org/questi...screen-588273/

Last edited by Habitual; 10-25-2012 at 10:15 AM.
 
Old 11-07-2012, 08:25 AM   #9
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,310
Blog Entries: 5

Original Poster
Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
It got stuck again, this time I issued
Code:
sudo kill $(pidof gpm)
and vim 'magically' returned to 'normal'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Installing vim-gnome or vim-gtk dependency issues with apt, aptitude, synaptic alagenchev Linux - Software 3 05-15-2012 10:33 AM
LXer: Personalize and Optimize Vim editor using Packtís new Vim 7.2 book LXer Syndicated Linux News 0 05-20-2010 10:20 PM
Switching from vim to vim -g from inside vim iDragoon Linux - Software 4 05-15-2009 11:46 AM
Editor comparison: vim VS vim-lite, Cleaning vim Ruler2112 *BSD 4 04-13-2009 04:26 PM
apt-get gets stuck at vim-common PBSchmidt Debian 3 01-08-2008 09:15 AM


All times are GMT -5. The time now is 08:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration