LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Videos don't have sound (http://www.linuxquestions.org/questions/slackware-14/videos-dont-have-sound-4175483290/)

asero12 11-03-2013 06:21 PM

Videos don't have sound
 
Hey everybody.

I installed Slackware and I've really liked it, but I have had some problems with sound, specially in videos.
Initially it was with mp3s, but I installed "gst-plugins-ugly" and now it's working fine. nevertheless, sound in videos (you tube and downloaded ones(mp4)) still doesn't work; It's really strange since mp3 work and system sound work too.

*I already instaled ALSA.

andrewthomas 11-03-2013 06:44 PM

So your video player's sound output is getting directed to the wrong place.

What player do you use?

asero12 11-03-2013 07:31 PM

Quote:

Originally Posted by andrewthomas (Post 5057864)
So your video player's sound output is getting directed to the wrong place.

What player do you use?



I use Mplayer and sometimes Kplayer, but nither
of the installed players work anyway.

kingbeowulf 11-03-2013 08:02 PM

If you have a Video Card with an HDMI output (most cards these days), make sure your video player is not sending sound to HDMI by default. This drove me nuts on my Nvidia GT430 so that I just blacklisted the Alsa nvidia HDMI modules. Also, KDE can be tricky in how you tell phonon to route sound from Alsa and which "hardware" device.

These CLI commands are your best friends for audio troubleshooting:

alsamixer
aplay
speaker-test

asero12 11-03-2013 09:10 PM

Quote:

Originally Posted by kingbeowulf (Post 5057885)
If you have a Video Card with an HDMI output (most cards these days), make sure your video player is not sending sound to HDMI by default. This drove me nuts on my Nvidia GT430 so that I just blacklisted the Alsa nvidia HDMI modules. Also, KDE can be tricky in how you tell phonon to route sound from Alsa and which "hardware" device.

These CLI commands are your best friends for audio troubleshooting:

alsamixer
aplay
speaker-test

No, it doesn't work even with HDMI

When i wrote speaker-test, I got this:

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_hw.c:1741: (_snd_pcm_hw_open) Unknown field slave
Playback open error: -22,Argumento inválido (Invalid Argument)


Last two lines seem to tell there's a problem.

Drakeo 11-03-2013 09:46 PM

I have the same thing and multiple cards and I had to point alsa to the card I wanted to use. hope this helps.

asero12 11-03-2013 10:10 PM

Quote:

Originally Posted by Drakeo (Post 5057921)
I have the same thing and multiple cards and I had to point alsa to the card I wanted to use. hope this helps.

Could you tell me please how you did that?

Drakeo 11-03-2013 11:12 PM

sure open a terminal and type alsamxer that will be your default card. that is what it placed it as. and if that is not the card you want as default then we go on to other things to do. in alsamixer press F6 to see all your devices. http://alsa.opensrc.org/Alsamixer

or you can also as root use this cat /proc/asound/cards
Quote:

# cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xf9ff4000 irq 16
1 [HD2200 ]: USB-Audio - HP Webcam HD-2200
HP Webcam HD-2200 HP Webcam HD-2200 at usb-0000:00:13.2-2, high speed
2 [CMI8738 ]: CMI8738 - C-Media CMI8738
C-Media CMI8738 (model 37) at 0xe800, irq 21
3 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfbd7c000 irq 19
This one is mine but when I installed the C-Media card bios always set it to 0 position.
so I finally just edited my /etc/modprobe.d/sound.conf


Quote:

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.25 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd slots=snd-hda-intel,snd_cmipci,snd-usb-audio
# --- END: Generated by ALSACONF, do not edit. ---

I heard other ways to do it with alsa but the fact is this works for me and
that's what matters. This tells alsa what slot to use for the first second third device after that all the other sound devices load
after them. Note the do not edit yes well ok I do edit it. Learned it from Alsa manual.

asero12 11-04-2013 09:27 AM

Quote:

Originally Posted by Drakeo (Post 5057934)
sure open a terminal and type alsamxer that will be your default card. that is what it placed it as. and if that is not the card you want as default then we go on to other things to do. in alsamixer press F6 to see all your devices. http://alsa.opensrc.org/Alsamixer

or you can also as root use this cat /proc/asound/cards


This one is mine but when I installed the C-Media card bios always set it to 0 position.
so I finally just edited my /etc/modprobe.d/sound.conf



I heard other ways to do it with alsa but the fact is this works for me and
that's what matters. This tells alsa what slot to use for the first second third device after that all the other sound devices load
after them. Note the do not edit yes well ok I do edit it. Learned it from Alsa manual.

I tried all that you said but sound's still not working, when I "cat /proc/asound/cards" get this:

Quote:

0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7e10000 irq 41

I'm begging to think it has something to do with the drivers, 'cause Amarok reproduces MP3 correctly, but xmms tells me to check if my soundcard is configured or if the output plugin is the right one or if a program is locking the soundcard.
And Audacious gives this error
Quote:

ALSA error:snd_pcm_open failed: Invalid Argument
Also once KDE showed a message that told me that some audio devices weren't found, and if I wanted the system to "forget" about them,
but in Kinfo center they all appear anyway:

Quote:

THESE ARE ALL THE ALSA INTERFACES THAT KINFO CENTER DETECTS:
-ALSA TIMER DEVICE
-HDA INTEL PCH(92HD91BXX Analog)
-HDA INTEL PCH (HDA Intel ALSA Hardware specific device).
-HDA INTEL PCH.
-HDA INTEL PCH (HDA Intel ALSA Hardware specific device)
-HDA INTEL PCH(92HD91BXX Analog)
-HDA INTEL PCH(HDMI 0)

kikinovak 11-04-2013 02:44 PM

Sometimes I have a similar problem with SMPlayer, a different frontend for MPlayer. I usually resolve it by deleting ~/.config/smplayer.

andrewthomas 11-04-2013 05:54 PM

Quote:

Originally Posted by asero12 (Post 5058168)
I tried all that you said but sound's still not working, when I "cat /proc/asound/cards" get this:

What is your lspci output for your integrated audio
Code:

asus-gentoo ~ # lspci -vv|grep Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]


asero12 11-04-2013 08:35 PM

Quote:

Originally Posted by andrewthomas (Post 5058357)
What is your lspci output for your integrated audio
Code:

asus-gentoo ~ # lspci -vv|grep Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]



lspci shows:


Quote:

ash-4.2# lspci -vv|grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)



andrewthomas 11-04-2013 08:44 PM

Code:

nano /etc/modprobe.d/alsa-base.conf
And add the following line:

Code:

options snd-hda-intel model=generic
or maybe :
Code:

options snd-hda-intel index=0

asero12 11-04-2013 11:54 PM

Quote:

Originally Posted by andrewthomas (Post 5058455)
Code:

nano /etc/modprobe.d/alsa-base.conf
And add the following line:

Code:

options snd-hda-intel model=generic
or maybe :
Code:

options snd-hda-intel index=0

No man, none of them worked, I even rebooted my pc, when I turned it on, a message said that it had stoped detecting some audio devices.
this problem is kinda' weird

asero12 11-05-2013 12:24 AM

I was seeing the audio configuration in Amarok, and i saw that phonon is in charge of managing audio devices, it detects a lot, but the only one that works is HDA Intel PCH (92HD91BXX Analog) there are also the HDMI ones but they don't sound, I imagine they do when a wire pluged. The rest have error messages, except hw:0,3 it doesn't show any error messages, but simply doesn't sound, yesterday it did, I don't know what hapenned. the fact is that when the mouse pinter stands still over the HDA Intel PCH (92HD91BXX Analog) it says that it has two devices "in it"

Quote:

ALSA:x-phonon:CARD=0,DEV=0
ALSA: plughw:CARD=0,DEV=0

I don't know if this can help somehow.


All times are GMT -5. The time now is 10:00 AM.