LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2013, 07:21 PM   #1
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Rep: Reputation: Disabled
Question Videos don't have sound


Hey everybody.

I installed Slackware and I've really liked it, but I have had some problems with sound, specially in videos.
Initially it was with mp3s, but I installed "gst-plugins-ugly" and now it's working fine. nevertheless, sound in videos (you tube and downloaded ones(mp4)) still doesn't work; It's really strange since mp3 work and system sound work too.

*I already instaled ALSA.
 
Old 11-03-2013, 07:44 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
So your video player's sound output is getting directed to the wrong place.

What player do you use?
 
Old 11-03-2013, 08:31 PM   #3
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by andrewthomas View Post
So your video player's sound output is getting directed to the wrong place.

What player do you use?


I use Mplayer and sometimes Kplayer, but nither
of the installed players work anyway.
 
Old 11-03-2013, 09:02 PM   #4
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Rep: Reputation: 140Reputation: 140
If you have a Video Card with an HDMI output (most cards these days), make sure your video player is not sending sound to HDMI by default. This drove me nuts on my Nvidia GT430 so that I just blacklisted the Alsa nvidia HDMI modules. Also, KDE can be tricky in how you tell phonon to route sound from Alsa and which "hardware" device.

These CLI commands are your best friends for audio troubleshooting:

alsamixer
aplay
speaker-test
 
1 members found this post helpful.
Old 11-03-2013, 10:10 PM   #5
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by kingbeowulf View Post
If you have a Video Card with an HDMI output (most cards these days), make sure your video player is not sending sound to HDMI by default. This drove me nuts on my Nvidia GT430 so that I just blacklisted the Alsa nvidia HDMI modules. Also, KDE can be tricky in how you tell phonon to route sound from Alsa and which "hardware" device.

These CLI commands are your best friends for audio troubleshooting:

alsamixer
aplay
speaker-test
No, it doesn't work even with HDMI

When i wrote speaker-test, I got this:

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_hw.c:1741: (_snd_pcm_hw_open) Unknown field slave
Playback open error: -22,Argumento inválido (Invalid Argument)


Last two lines seem to tell there's a problem.

Last edited by asero12; 11-03-2013 at 10:12 PM.
 
Old 11-03-2013, 10:46 PM   #6
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
I have the same thing and multiple cards and I had to point alsa to the card I wanted to use. hope this helps.
 
Old 11-03-2013, 11:10 PM   #7
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Drakeo View Post
I have the same thing and multiple cards and I had to point alsa to the card I wanted to use. hope this helps.
Could you tell me please how you did that?
 
Old 11-04-2013, 12:12 AM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
sure open a terminal and type alsamxer that will be your default card. that is what it placed it as. and if that is not the card you want as default then we go on to other things to do. in alsamixer press F6 to see all your devices. http://alsa.opensrc.org/Alsamixer

or you can also as root use this cat /proc/asound/cards
Quote:
# cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xf9ff4000 irq 16
1 [HD2200 ]: USB-Audio - HP Webcam HD-2200
HP Webcam HD-2200 HP Webcam HD-2200 at usb-0000:00:13.2-2, high speed
2 [CMI8738 ]: CMI8738 - C-Media CMI8738
C-Media CMI8738 (model 37) at 0xe800, irq 21
3 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfbd7c000 irq 19
This one is mine but when I installed the C-Media card bios always set it to 0 position.
so I finally just edited my /etc/modprobe.d/sound.conf


Quote:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.25 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd slots=snd-hda-intel,snd_cmipci,snd-usb-audio
# --- END: Generated by ALSACONF, do not edit. ---
I heard other ways to do it with alsa but the fact is this works for me and
that's what matters. This tells alsa what slot to use for the first second third device after that all the other sound devices load
after them. Note the do not edit yes well ok I do edit it. Learned it from Alsa manual.

Last edited by Drakeo; 11-04-2013 at 12:24 AM. Reason: added more stuff
 
Old 11-04-2013, 10:27 AM   #9
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Drakeo View Post
sure open a terminal and type alsamxer that will be your default card. that is what it placed it as. and if that is not the card you want as default then we go on to other things to do. in alsamixer press F6 to see all your devices. http://alsa.opensrc.org/Alsamixer

or you can also as root use this cat /proc/asound/cards


This one is mine but when I installed the C-Media card bios always set it to 0 position.
so I finally just edited my /etc/modprobe.d/sound.conf



I heard other ways to do it with alsa but the fact is this works for me and
that's what matters. This tells alsa what slot to use for the first second third device after that all the other sound devices load
after them. Note the do not edit yes well ok I do edit it. Learned it from Alsa manual.
I tried all that you said but sound's still not working, when I "cat /proc/asound/cards" get this:

Quote:
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7e10000 irq 41

I'm begging to think it has something to do with the drivers, 'cause Amarok reproduces MP3 correctly, but xmms tells me to check if my soundcard is configured or if the output plugin is the right one or if a program is locking the soundcard.
And Audacious gives this error
Quote:
ALSA error:snd_pcm_open failed: Invalid Argument
Also once KDE showed a message that told me that some audio devices weren't found, and if I wanted the system to "forget" about them,
but in Kinfo center they all appear anyway:

Quote:
THESE ARE ALL THE ALSA INTERFACES THAT KINFO CENTER DETECTS:
-ALSA TIMER DEVICE
-HDA INTEL PCH(92HD91BXX Analog)
-HDA INTEL PCH (HDA Intel ALSA Hardware specific device).
-HDA INTEL PCH.
-HDA INTEL PCH (HDA Intel ALSA Hardware specific device)
-HDA INTEL PCH(92HD91BXX Analog)
-HDA INTEL PCH(HDMI 0)
 
Old 11-04-2013, 03:44 PM   #10
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,944

Rep: Reputation: 967Reputation: 967Reputation: 967Reputation: 967Reputation: 967Reputation: 967Reputation: 967Reputation: 967
Sometimes I have a similar problem with SMPlayer, a different frontend for MPlayer. I usually resolve it by deleting ~/.config/smplayer.
 
Old 11-04-2013, 06:54 PM   #11
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by asero12 View Post
I tried all that you said but sound's still not working, when I "cat /proc/asound/cards" get this:
What is your lspci output for your integrated audio
Code:
asus-gentoo ~ # lspci -vv|grep Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]
 
Old 11-04-2013, 09:35 PM   #12
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by andrewthomas View Post
What is your lspci output for your integrated audio
Code:
asus-gentoo ~ # lspci -vv|grep Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]

lspci shows:


Quote:
ash-4.2# lspci -vv|grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

 
Old 11-04-2013, 09:44 PM   #13
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Code:
nano /etc/modprobe.d/alsa-base.conf
And add the following line:

Code:
options snd-hda-intel model=generic
or maybe :
Code:
options snd-hda-intel index=0

Last edited by andrewthomas; 11-04-2013 at 09:46 PM.
 
Old 11-05-2013, 12:54 AM   #14
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by andrewthomas View Post
Code:
nano /etc/modprobe.d/alsa-base.conf
And add the following line:

Code:
options snd-hda-intel model=generic
or maybe :
Code:
options snd-hda-intel index=0
No man, none of them worked, I even rebooted my pc, when I turned it on, a message said that it had stoped detecting some audio devices.
this problem is kinda' weird
 
Old 11-05-2013, 01:24 AM   #15
asero12
LQ Newbie
 
Registered: Nov 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
I was seeing the audio configuration in Amarok, and i saw that phonon is in charge of managing audio devices, it detects a lot, but the only one that works is HDA Intel PCH (92HD91BXX Analog) there are also the HDMI ones but they don't sound, I imagine they do when a wire pluged. The rest have error messages, except hw:0,3 it doesn't show any error messages, but simply doesn't sound, yesterday it did, I don't know what hapenned. the fact is that when the mouse pinter stands still over the HDA Intel PCH (92HD91BXX Analog) it says that it has two devices "in it"

Quote:
ALSA:x-phonon:CARD=0,DEV=0
ALSA: plughw:CARD=0,DEV=0

I don't know if this can help somehow.

Last edited by asero12; 11-05-2013 at 01:28 AM. Reason: add info
 
  


Reply

Tags
problems, slackware, sound, videos


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus Eeepc 900 Xandros - Youtube videos don't run! ruistracke Linux - Newbie 5 09-13-2011 02:06 PM
youtube videos have no sound baronobeefdip Linux - Software 8 05-16-2011 03:34 AM
[SOLVED] No sound, Videos play extremely fast with no sound boydw Linux - Newbie 1 01-19-2011 09:59 PM
SUSE Linux videos don't work pcg Linux - Software 3 01-24-2007 04:50 AM
Playing videos without sound? Brian Knoblauch Suse/Novell 1 09-03-2005 04:51 AM


All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration