LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-11-2011, 09:38 PM   #1
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
"Video tearing" with today's -current updates


Found the new updates on my HD this morning (thanks to AlienBOB & mirror-slackware-current.sh). Installed on my desktop (Intel graphics) with no issues, all worked well. Then moved to my laptop (Toshiba Satellite P205D-S7805).
Code:
#lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
I use both KDE-4.6 & fluxbox on this laptop, depending on the situation. I use "wally-2.4" to set the wallpaper. On both desktops, the wallpaper displays properly & will switch fine. All of the KDE apps work OK, but LibreOffice, xfe, xscreensaver (among others) would cause the display to "tear" badly. I tried to get a screenshot, but all I could do was Ctrl-Alt-Bkspc to kill X. I did a lot of googling, but found nothing recent. I upgraded to the mesa that is in testing, but while it worked (& is still working), it didn't solve my problem. I figured the problem was the video driver, so downgraded to the xf86-video-ati-6.13.2-x86_64-1 package & that provided stable video.
So, I have "worked around" my problem. Just wanted to report it & hope that someone might have a solution instead of a work around.
Regards,
Bill
 
Old 02-11-2011, 09:59 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,220

Rep: Reputation: 177Reputation: 177
Have you tried enabling vsync? I know with the nvidia driver you can enable it globally, but I believe you can enable for certain individual things like GL screensavers, kwin effects, etc. I always get terrible tearing if I don't enable vsync.

However it is odd than downgrading fixed your problem, so vsync is probably not the culprit, but its worth a look.

Last edited by Daedra; 02-11-2011 at 10:05 PM.
 
Old 02-11-2011, 10:10 PM   #3
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Original Poster
Rep: Reputation: 55
Hi,Daedra. Thanks for the response. I can't seem to find a method to "enable vsync". It's not a program, module or option in the kernel config. This is ati (radeon), not nvidia; would that be the difference?
Regards,
Bill
 
Old 02-11-2011, 10:39 PM   #4
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,220

Rep: Reputation: 177Reputation: 177
Are you using the proprietary ATI linux driver? Because I know it can be done with there driver. With opensource ATI drivers I found this page which may have some useful information. I can't really help much because I have never had to deal with ATI under linux.


http://phoronix.com/forums/showthrea...d-%28open%29GL
 
Old 02-11-2011, 10:47 PM   #5
NoStressHQ
Member
 
Registered: Apr 2010
Location: Lausanne - Switzerland ( Bordeaux - France / Montreal - QC - Canada)
Distribution: Slackware Leet - 32/64bit
Posts: 278

Rep: Reputation: 94
I might be totally wrong, and it might be totally unrelated... But have you noticed this ?

http://www.slackware.com/changelog/current.php?cpu=x86_64

Code:
"x/xf86-video-ati-6.14.0-i486-1.txz: Upgraded.
       This new driver requires KMS, which is set by default in the new kernel.
       Otherwise, create /etc/modprobe.d/radeon.conf with this content:
       options radeon modeset=1
       Also, the kernel should be booted with vga=normal.
       Problems have been observed when trying to use KMS after starting a VESA
       framebuffer console. Sorry about the penguins."
Edit: And this:

Code:
pasture/xf86-video-ati-6.13.2-i486-1.txz: Added.
       Provide an alternate ATI driver in case of problems with the latest one.

Last edited by NoStressHQ; 02-11-2011 at 10:50 PM.
 
Old 02-11-2011, 10:49 PM   #6
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,632

Rep: Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429
Are you running a compositing manager (like Compiz, xcompmgr. etc)? I've found that they cause tearing on my Intel integrated card.
 
Old 02-12-2011, 11:20 AM   #7
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Original Poster
Rep: Reputation: 55
@ Daedra: I'm using the open source radeon driver. I think my graphics chip is no longer supported by the proprietary driver, but I will check that out.

@ NoStressHQ: I was using KMS with the earlier kernels. I did rename /etc/modprobe.d/radeon.conf so that the kernel could start kms prior to my trying the new kernel. I didn't think it would matter, since I had no "vga=XXX" statement in my grub2 stanza, but in desperation, I added "vga=normal". Made no difference. In my first post I stated that using xf86-video-ati-6.13.2-i486-1.txz was the work around I used. Thanks for the suggestions, though.

@ dugan: Nope, no compositing manager. I don't require much eye-candy, except for changing the wallpaper every few minutes, & wally takes care of that.

Anyone else have any ideas?
Regards,
Bill
 
Old 02-12-2011, 12:05 PM   #8
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Quote:
Originally Posted by TSquaredF View Post
I did rename /etc/modprobe.d/radeon.conf so that the kernel could start kms prior to my trying the new kernel.
I don't think it matters what a file is named in modprobe.d so renaming radeon.conf to something else doesn't really do anything. Try removing the file from modprobe.d and see if that helps. I just upgraded a 64-current radeon box and had to remove the modprobe.d/radeon.conf file.

Last edited by Chuck56; 02-12-2011 at 12:36 PM.
 
Old 02-12-2011, 02:27 PM   #9
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,632

Rep: Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429Reputation: 1429
If you're using an xorg.conf, then check if it contains the following line. If it does, remove it:

Code:
Option "Composite" "Enable"
 
Old 02-12-2011, 03:54 PM   #10
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Original Poster
Rep: Reputation: 55
@ Chuck56: I removed the radeon.conf file from /etc/modprobe.d, but no joy.

@ dugan: Thanks, but not using an xorg.conf.
Regards,
Bill
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
64-current updates == X11 tearing, corruption, brutal lag, NVIDIA warnings GrapefruiTgirl Slackware 14 12-11-2010 09:09 PM
[SOLVED] today's updates on -current - exaile would not start sycamorex Slackware 2 08-28-2010 04:22 AM
Current CM Updates on HTC (Spanish "Rogers" type) Dream business_kid Linux - Mobile 1 08-24-2010 07:39 AM
[SOLVED] GeForce 210 video tearing / artifacts with current stable mrmnemo Linux - Hardware 2 07-18-2010 10:24 AM
"xv" video driver not working in slackware-current athanatos Slackware 4 08-31-2006 02:27 AM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration