LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Video Problems in VirtualBox on Slackware64-current (http://www.linuxquestions.org/questions/slackware-14/video-problems-in-virtualbox-on-slackware64-current-742087/)

TSquaredF 07-22-2009 06:38 PM

Video Problems in VirtualBox on Slackware64-current
 
I have been using Slackware64-current on my Toshiba laptop for a couple of weeks now. I use XFCE with no xorg.conf file. The default conf file used the radeon driver & found the native resolution (1440x900) of the monitor. All was well until I installed VirtualBox PUEL version 3.0.2 & then tried to install Slackware-current (32 bit) in VB. The VB video was smeared & the color wasn't proper. I attempted to install WinXP & got the same results. The only solution was to use xorg.conf-vesa as xorg.conf. This allowed the VB video to work properly, but regardless of how I modified my xorg.conf file, I could not get the resolution up to 1440x900. The best I've been able to do is 1152x864. I've also tried using "xorgsetup". The resulting xorg.conf file works well, but VB doesn't. I'd really like to get VB working properly & have the highest resolution I can get, preferably using the radeon driver. Anyone have any ideas?
Regards,
Bill

manwichmakesameal 07-22-2009 06:48 PM

Depending on what card you have, have you tried creating an xorg.conf and using the radeonhd driver? I have a Toshiba L305D-S5934 and that's how I got my resolution right.

speccy 07-22-2009 07:05 PM

Sounds like the same problem I had:

Try running (on the host):

Code:

VBoxManage set extradata global "GUI/RenderMode" sdl
then put your xorg.conf back as it was before. This should fix the colours & smears.

Have you installed the guest additions? This fixes the resolution problems for me.

TSquaredF 07-22-2009 08:35 PM

manwichmakesameal: I have used "xorgsetup" to make a custom xorg.conf. It, however, used the radeon driver, so I did it again & modified the driver to radeonhd. This works well, at my preferred resolution, but the video in VirtualBox is still unusable. Thanks, though, for pointing out the radeonhd driver.

speccy: The command you provided does not work. I get a huge number of lines explaining usage then, finally:
Quote:

Syntax error: Invalid command 'set'
I will do some digging on this.
I did install the guest additions, but still have VB video problems, if I'm not using the vesa driver.
Regards,
Bill

marrowsuck 07-23-2009 02:30 AM

According to http://www.virtualbox.org/ticket/3789 putting this
Quote:

Section "Extensions"

Option "Composite" "Off"

EndSection
in your xorg.conf may help.

speccy 07-23-2009 04:31 AM

Apologies, the command should be:
Code:

VBoxManage setextradata global "GUI/RenderMode" sdl
I had put a space after "set".

TSquaredF 07-23-2009 11:39 AM

Quote:

Originally Posted by speccy (Post 3617488)
Apologies, the command should be:
Code:

VBoxManage setextradata global "GUI/RenderMode" sdl
I had put a space after "set".

Bingo! Thanks, speccy, that did it.

marrowsuck: I appreciate the reply, but tried the above first. Since it worked, I won't go any further.
Regards,
Bill

cwizardone 10-04-2009 07:28 PM

Quote:

Originally Posted by marrowsuck (Post 3617396)
According to http://www.virtualbox.org/ticket/3789 putting this

in your xorg.conf may help.

Thanks. That solved the video problem I was having with VirtualBox.

shadowsnipes 10-20-2009 11:44 PM

Quote:

Originally Posted by marrowsuck (Post 3617396)
According to http://www.virtualbox.org/ticket/3789 putting this

in your xorg.conf may help.

It fixed my issue with VirtualBox as well and made KDE4 a bit snappier! This is with the radeon driver. Thanks!

Here was my issue: Once I started VirtualBox, everytime I clicked on a qt4 app the colors of my screen would invert and get a bit garbled. I could get back correct colors by clicking on the desktop, but there were still graphical glitches. This would continue regardless of whether or not VirtualBox was still open, and it would not be fixed until I restarted the WM session. This problem happened regardless of the WM. For instance, I had the same problem in a vanilla Fluxbox session.

Btw, my xorg.conf only contains that small section. With the exception of perhaps my kb special keys, everything else is detected properly.

Edit: Also, this was on 32-bit Slackware 13.


All times are GMT -5. The time now is 01:55 PM.