LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-21-2003, 09:32 AM   #1
techkabouter
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Rep: Reputation: 0
Angry Via Ac97 (a7v333)


Yesterday, i have installed slackware 8.1, the only thing that doesn't work is my onboard soundcard. I have download a drive package from ww.viaarena.com, but not a specific slackware one. I try to read the readme.txt, but it's to difficult for me...Is this the only option to install my oboard soundcard?(AC97)...this is the readme.txt

*************************
** Driver Installation **
*************************
Please follow the instructions listed below to install the driver :

A) Login as a super user.

B) Change directory according to the Linux version, e.g..

# mcd a:/linux/redhat

for RedHat

C) Copy compressed file according to the Linux version to a certain
directory, e.g..

# mkdir ./viaudio
# mcopy a:74audio.rht72.gz ./viaudio

for RedHat 7.2

D) Uncompress the compressed file by using tar command, e.g.

# tar xzvf 74audio.rht72.gz

for RedHat 7.2 and


E) Change directory to the relative directory to do the installation.

# ./vinstall
or
# sh vinstall

For RedHat 7.2, this program will copy some files, e.g.

/lib/modules/2.4.7-10/sound/viaudio.o

and backup the original files as the following :

/etc/modules.conf to /etc/modules.conf.old
or
/etc/modules.conf to /etc/old.modules.conf

After the installation, the VIA Audio Linux driver could be
loaded on the RedHat 7.2.


* Please turn on the USB Host Controller and USB 2 Host Controller in
the BIOS setting first. Otherwise, the Audio function will not detect
by LINUX 2.2.5 kernel. It is the LINUX 2.2.5 kernels' bug.
 
Old 08-21-2003, 01:46 PM   #2
BigBadPenguin
Member
 
Registered: Jun 2003
Location: Warwick (.ac.uk)
Distribution: Arch, Slackware 9.0, (knoppix standing by)
Posts: 256

Rep: Reputation: 30
yeah, you're right. That seems weird for many reasons, are you even running kernel 2.2.5 or 2.4.7? I strongly doubt it, slack 8.1 comes with 2.4.18 if memory serves. You should try to use the ac97 driver that comes with slack, what does 'modprobe ac97_codec' give you if you type it in as root? Try that, and in the future you'd be best avoiding rh packages if you can
 
Old 08-21-2003, 01:49 PM   #3
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Rep: Reputation: 30
VIA motherboard? You may have to use drivers from the ALSA Project:

www.alsa-project.org
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Sarge on ASUS A7V333 (PDC20276) bck Debian 1 03-02-2005 05:28 PM
fasttrak133 lite on a a7v333 with 2.6.8.1 monohouse Linux - Hardware 4 10-24-2004 07:27 AM
Sound on slackware 9.1 - Asus A7V333 squash_racket Linux - Newbie 6 05-05-2004 11:55 AM
A7V333 Raid + Linux = no? Skirge01 Linux - Hardware 0 10-06-2002 01:51 PM
New ASUS A7V333-R ... Comments for a Linux box? taz.devil Linux - Hardware 9 07-14-2002 08:55 AM


All times are GMT -5. The time now is 05:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration