LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-04-2011, 02:04 PM   #1
bsdunix
Senior Member
 
Registered: May 2006
Distribution: Caldera, CTOS, Debian, FreeBSD, Mac OS X, Mandrake, Minix, OpenBSD, Slackware, SuSE
Posts: 1,757

Rep: Reputation: 79
VGA framebuffer, lilo.conf, and Slackware64 13.37


Two different computers of mine do the same thing. I specified "vga = normal" for lilo.conf which should give me a 80x25 text console size, but during bootup the normal console size changes to some very high framebuffer setting making the characters on the screen very small. The runlevel is set to "3" in my inittab file. Same settings used in Slackware64 13.1 and I didn't have this framebuffer problem.

One computer is using an ATI Radeon HD5450 video card (DVI connection) and the other is using the onboard ATI Radeon HD3000 Graphics (VGA connection). Each computer is using a LCD monitor.

Below is my lilo.conf file, is something not right? Do I have to disable framebuffer support in the kernel?

Thanks in advance.

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
#compact        # faster, but won't work on all systems.
# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255
# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Append any additional kernel parameters:
append=" vt.default_utf8=0"
prompt
timeout = 50
# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda2
  label = james
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 05-04-2011, 02:20 PM   #2
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
This is because KMS (kernel mode setting) is now enabled by default on Intel, ATI, and Nvidia graphics chipsets.

You can disable it by adding "nomodeset" to the append line in your lilo.conf, but then Xorg will stop working with the Intel and ATI drivers.

A better solution is to specify a lower console resolution by appending something like "video=640x480" in your lilo.conf

This is all in CHANGES_AND_HINTS.TXT
 
3 members found this post helpful.
Old 05-04-2011, 03:43 PM   #3
bsdunix
Senior Member
 
Registered: May 2006
Distribution: Caldera, CTOS, Debian, FreeBSD, Mac OS X, Mandrake, Minix, OpenBSD, Slackware, SuSE
Posts: 1,757

Original Poster
Rep: Reputation: 79
Thanks for the reply, didn't realize the change as I generally just use the console and not worry about X11/graphics/chipset/framebuffer stuff.

Per your suggestion, I made the following changes and updated lilo:

Code:
#append=" vt.default_utf8=0"
append="video=640x480"
Works much better now.
 
1 members found this post helpful.
Old 12-13-2012, 01:02 PM   #4
wje_lq
Member
 
Registered: Sep 2007
Location: Mariposa
Distribution: Debian lenny, Slackware 12
Posts: 809

Rep: Reputation: 178Reputation: 178
Many thanks!

I came looking for a solution to this problem, and stumbled upon it today. Whew!

For those using grub, there are several alternatives. Here are two:

The first alternative, which you can use to test this approach, is to press the "e" key when the grub boot screen comes up, and change the "linux" command so that it ends with
Code:
 video=640x480
(The initial space before video may be important, depending on your previous context, and it's always ok to insert it.)

The second alternative, which you can use to make this change permanent, is to change file /etc/default/grub so that the line
Code:
GRUB_CMDLINE_LINUX=""
becomes
Code:
GRUB_CMDLINE_LINUX="video=640x480"
Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware64 13.1 Nvidia framebuffer woes - blank screen after lilo ahmadj Slackware 18 06-12-2010 11:02 AM
vga framebuffer setting banditman Slackware 2 05-27-2010 08:57 PM
setting framebuffer (vga mode) after booting zoombee Linux - General 2 12-04-2008 05:41 PM
framebuffer and vga settings.... Basslord1124 Slackware 5 12-13-2005 08:32 PM
Console, VESA VGA, Framebuffer Support Question chrisk5527 Linux - General 0 11-01-2004 10:15 PM


All times are GMT -5. The time now is 01:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration