LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Very week microphone recording (http://www.linuxquestions.org/questions/slackware-14/very-week-microphone-recording-407215/)

kosmonaft 01-24-2006 12:29 AM

Very week microphone recording
 
I've been trying to figure out why my microphone recording is so week in linux. The same microphone with the same sound card work like a charm in windows XP, but in linux it pretty doesn't record. I tried turning everything on and all the way up in alsamixer and that didn't help. About 10 people on freenode spent quite a lot of time trying to get my mic to record well by playing with alsamixer, but without luck. At this point I have no clue what the problem is and what to do.

On http://putfile.com/kosmonaft you can find the following info:
- alsamixer /proc info screen
- alsamixer capture controls only
- alsamixer playback controls only
- Microphone recording test in Windows XP
- Microphone recording test in Slackware 10.2 (turn your volume all the way up :/)


Thanks for all the help in advance. This forum has been helpful throughout the years and I hope you guys will be able to help out on this one as well.

Ilgar 01-24-2006 01:30 AM

There's usually a Mic boost switch in the mixer, did you check that? In KMix or gnome mixer you'll see it under the switches tab.

kosmonaft 01-24-2006 04:59 PM

Quote:

Originally Posted by Ilgar
There's usually a Mic boost switch in the mixer, did you check that? In KMix or gnome mixer you'll see it under the switches tab.

I actually posted the pictures. There is a link if you didn't notice and one of them has a screenshot of alsamixer playback controls which has mic boost enabled.

Ilgar 01-24-2006 09:19 PM

Oops, sorry. I've looked at the pictures but I was expecting to see mic boost in the capture window. So it is on... And it seems there's not a separate "capture" channel as there is in some cards. Then I've no idea.

Check this (found with google):
http://openwengo.com/support/forum/v...a19e0b62b3d2d5

There's a poster who says he improved the recording sound level using amixer instead of alsamixer. This may help.

kosmonaft 01-25-2006 05:48 PM

I don't see how changing settings of the same sound card with a different tool will solve the problem.

Ilgar 01-25-2006 05:56 PM

How? I think you didn't read the thread. Here's the quote:

Quote:

After *alot* of tinkering, I eventually figured out that the alsamixer wasn't presenting all of the available controls for my soundcard...using 'amixer' instead, although a bit less inutitive, actually revealed that my Mic Boost option had both playback and capture settings (same for Mic Volume)...modifying this seems to given me a workable volume (although still not great).


All times are GMT -5. The time now is 10:59 AM.