LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Very low sound on my Slackware 14 64-bit (http://www.linuxquestions.org/questions/slackware-14/very-low-sound-on-my-slackware-14-64-bit-4175466771/)

info.latawaz 06-20-2013 02:48 PM

Very low sound on my Slackware 14 64-bit
 
1 Attachment(s)
Hi,

Today I played my first video on my new Slackware and the sound was there. :D

But I had to increase the level of sound to 70% approx to hear. This didn't happen in windows. On Windows, on level 20, the sound in headphones was so much that it was unbearable.

I haven't installed any driver as of now for audio but I think installing it should improve the output of audio.

Necessary Output.

lspci
Code:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series]
02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]
04:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
07:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
07:00.1 System peripheral: Ricoh Co Ltd Memory Stick Host Controller (rev 01)
07:00.2 System peripheral: Ricoh Co Ltd Device e852 (rev 01)
07:00.3 FireWire (IEEE 1394): Ricoh Co Ltd FireWire Host Controller (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

lsmod | grep snd
Code:

snd_seq_dummy          1455  0
snd_seq_oss            29048  0
snd_seq_midi_event      5620  1 snd_seq_oss
snd_seq                51265  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          5228  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            39183  0
snd_mixer_oss          15404  1 snd_pcm_oss
snd_hda_codec_hdmi    24057  1
snd_hda_codec_idt      55294  1
snd_hda_intel          23267  4
snd_hda_codec          81925  3 snd_hda_intel,snd_hda_codec_idt,snd_hda_codec_hdmi
snd_hwdep              6324  1 snd_hda_codec
snd_pcm                72864  4 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_pcm_oss
snd_page_alloc          7081  2 snd_pcm,snd_hda_intel
snd_timer              18798  2 snd_pcm,snd_seq
snd                    57796  20 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_idt,snd_hda_codec_hdmi,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore              5474  1 snd

cat /proc/asound/modules
Code:

0 snd_hda_intel
 1 snd_hda_intel

aplay -l
Code:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Snapshot of alsamixer attached.

number22 06-20-2013 05:05 PM

Welcome to slackware.
I have 2 sound cards both using snd-hda-intel module. one is standard realteck ALC888 named SB, another is ATI radeon audio named HDMI. software mixing, and SB is my main card.
This my asound.conf file, it is working example. Replace sound card name SB to Intel for your card.
Code:

#
# DMIX output device
#
pcm.output {
      type dmix
      ipc_key 1234
      ipc_perm 0660
      slave {
              pcm "hw:0,0"
              period_time 0
              period_size 2048
              buffer_size 8192
              rate 44100
      }
      bindings {
              0 0
              1 1
      }
}

#
# DSNOOP input device
#
pcm.input {
      type dsnoop
      ipc_key 4321
      ipc_key_add_uid yes
      ipc_perm 0660
      slave {
              pcm "hw:0,0"
              periods 0
              period_time 0
              period_size 2048
              buffer_size 8192
              rate 44100
      }
}

#
# ASYM duplex device
#
pcm.duplex {
      type asym
      playback.pcm "output"
      capture.pcm "input"
}

ctl.duplex {
      type plug
      card SB
}

pcm.softvol {
      type softvol
      slave {
              pcm "duplex"
      }
      control {
              name "Pre-Amp"
              card SB
      }
      min_dB  -20.0
      max_dB  20.0
      resolution 20
}
ctl.softvol {
      type plug
      card SB
}

#
# Make the duplex device default
#
pcm.!default {
      type plug
      slave.pcm "softvol"
}

ctl.!default {
      type  hw
      card  SB
}

#aoss
pcm.!dsp {
        type plug
        slave.pcm "duplex"
}

#ctl device for xmms
ctl.!mixer {
        type hw
        card SB
}

Slackware 14 has additional alsa-plugins which includes plug for softvol, more volume adjustment, and alsa-plugins is not standard for 13.37, need to download from ALSA projects site.

my /etc/modprobe.d/sound.conf
Code:

# ALSA portion
alias char-major-116 snd
options snd major=116 cards_limit=2
alias snd-card-0 snd-hda-intel
alias snd-card-1 snd-hda-intel
options snd-hda-intel id=SB,HDMI index=0,1 model=auto

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-slot-0 snd-slot-0
alias sound-slot-1 snd-card-1
alias sound-slot-1 snd-slot-1

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/dsp0 snd-pcm-oss

# card #2
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
alias /dev/dsp1 snd-pcm-oss

need to reboot computer for alsa to take effects, I am using kms,
Hope it will help you anyway.

info.latawaz 06-21-2013 01:15 AM

Quote:

This my asound.conf file, it is working example. Replace sound card name SB to Intel for your card.
Where is this file? (Also if you can pass a command to find files, it will be bonus :D Currently I am using 'whereis')


Quote:

whereis sound.conf
sound: /usr/src/linux/sound /usr/src/linux-3.2.29/sound /usr/include/sound
I don't have sound.conf file in /etc/modprobe.d/


Quote:

dir /etc/modprobe.d/
README blacklist-fglrx.conf

Celyr 06-21-2013 04:22 AM

Quote:

Originally Posted by info.latawaz (Post 4975808)
Where is this file? (Also if you can pass a command to find files, it will be bonus :D Currently I am using 'whereis')

Put asound.conf in /etc/
Quote:

Originally Posted by info.latawaz (Post 4975808)
I don't have sound.conf file in /etc/modprobe.d/

You have to create it.

info.latawaz 06-22-2013 03:28 AM

From what I infer, I have to add asound.conf in /etc/

And it's contents should be what? number22 gave the output of two different files. What should I put in the file /etc/asound.conf that I create. Also, what about the other output? Ignore that or put it in another file somewhere else?

Celyr 06-22-2013 04:06 AM

One fine is asound.conf put it in /etc/ (wich is the first one)
The other file is sound.conf, indeed you can change this name it's only important that you put it in /etc/modprobe.d/ (this is the second one). I suggest you also to read the modprobe.d readme file so you will understand what files here inside do.

info.latawaz 06-22-2013 06:11 AM

Celyr, thanks for your directions. As you asked, I read README file and now understand what is happening. :D

So as I have done the above and created both the files, do I have to make them executable or something? What do I do once I have created both the files?

Celyr 06-22-2013 02:13 PM

Well, about permission asound.conf should be root:root and 644
Code:

# chmod 644 file
# chown root:root file

about sound.conf you can chown it same as asound.conf and chmod it to 755.
After a reboot you should be ok, if not the issue was not there (and I'm sorry about that but I don't have such audio card).

info.latawaz 06-24-2013 02:14 AM

1 Attachment(s)
So I did all that. Now, when I restart, or start, I get a message. I have attached it's screenshot.

info.latawaz 06-25-2013 02:07 AM

The solution didn't work. Infact after adding those files, the sound card was no getting detected resulting in no sound at all. I am pretty happy with the sound that I have compared to no sound.


All times are GMT -5. The time now is 10:14 PM.