LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2012, 02:12 AM   #1
michijo
Member
 
Registered: Apr 2011
Posts: 162

Rep: Reputation: 0
UTF8 Slackware


I recently upgraded to Slackware 14 and lost my UTF8 fonts. Now I cant remember how I made them work in the first place.
 
Old 11-03-2012, 02:50 AM   #2
Sjorrit
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware, Slamd64
Posts: 10

Rep: Reputation: 2
Not sure if this is what you mean, but you can set the LANG environment variable to en_US.utf8:
Code:
export LANG=en_US.utf8
You can put this in your .bash_profile/.bashrc

Alternatively, edit /etc/profile.d/lang.sh and/or /etc/profile.d/lang.csh to make the change system wide.

You'll also need a font that has glyphs for the characters you want to see. The DeJaVu fonts have quite an extensive range.
 
Old 11-03-2012, 04:08 AM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,546
Blog Entries: 1

Rep: Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001
Quote:
Originally Posted by michijo View Post
I recently upgraded to Slackware 14 and lost my UTF8 fonts. Now I cant remember how I made them work in the first place.
Here's a tutorial on setting it up in Slackware:
http://duganchen.ca/writings/slackware/fonts/
 
Old 11-03-2012, 05:44 AM   #4
michijo
Member
 
Registered: Apr 2011
Posts: 162

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by sycamorex View Post
Here's a tutorial on setting it up in Slackware:
http://duganchen.ca/writings/slackware/fonts/
Got it. Changed the default in this file to Utf8, then had to restart the system.

/etc/profile.d/lang.sh

Also I did this:

edit /usr/bin/startx and change

defaultserverargs=""

to

defaultserverargs="-dpi 96"

Thanks, I will make not of that for the future.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ntfs-3g locale=es_US.utf8 - Not Working Slackware current renecohrt Slackware 4 02-20-2010 07:17 PM
adding utf8 support to slackware 10.2 mahdif Slackware 2 09-23-2006 01:44 AM
utf8 hraposo Debian 1 08-11-2006 10:59 AM
Utf8 akasantos Fedora 2 11-18-2003 10:03 AM
NTFS and UTF8 Imyrryr Linux - Newbie 1 08-08-2003 03:08 PM


All times are GMT -5. The time now is 05:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration