LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   UTF8 Slackware (http://www.linuxquestions.org/questions/slackware-14/utf8-slackware-4175435420/)

michijo 11-03-2012 02:12 AM

UTF8 Slackware
 
I recently upgraded to Slackware 14 and lost my UTF8 fonts. Now I cant remember how I made them work in the first place.

Sjorrit 11-03-2012 02:50 AM

Not sure if this is what you mean, but you can set the LANG environment variable to en_US.utf8:
Code:

export LANG=en_US.utf8
You can put this in your .bash_profile/.bashrc

Alternatively, edit /etc/profile.d/lang.sh and/or /etc/profile.d/lang.csh to make the change system wide.

You'll also need a font that has glyphs for the characters you want to see. The DeJaVu fonts have quite an extensive range.

sycamorex 11-03-2012 04:08 AM

Quote:

Originally Posted by michijo (Post 4821240)
I recently upgraded to Slackware 14 and lost my UTF8 fonts. Now I cant remember how I made them work in the first place.

Here's a tutorial on setting it up in Slackware:
http://duganchen.ca/writings/slackware/fonts/

michijo 11-03-2012 05:44 AM

Quote:

Originally Posted by sycamorex (Post 4821268)
Here's a tutorial on setting it up in Slackware:
http://duganchen.ca/writings/slackware/fonts/

Got it. Changed the default in this file to Utf8, then had to restart the system.

/etc/profile.d/lang.sh

Also I did this:

edit /usr/bin/startx and change

defaultserverargs=""

to

defaultserverargs="-dpi 96"

Thanks, I will make not of that for the future.


All times are GMT -5. The time now is 02:48 PM.