LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2009, 09:21 PM   #1
lightkuragari
LQ Newbie
 
Registered: Jan 2005
Location: Cuernavaca, Morelos, México
Distribution: Slackware
Posts: 23

Rep: Reputation: 1
UTF8 in NTFS from boot


Hi all, i'm using slackware 12.2 and i have 2 NTFS partitions mounted. Both were added to fstab in the setup process, and I modified fstab to add iocharset=utf8. Then i re-mounted the partitions and i could see all my files and directories.

However, the next time i turned on my box, i found out the partitions weren't showing those files and directories with special characters, so each time i reboot i have to

umount /ntfspartition && mount /ntfspartition

after this, i can see those files again. My question is, why they don't get mounted from the beginning with the utf8 charset? it seems at boot time, fstab setting "iocharset=utf8" is completely ignored.

Does anyone know why is this?
 
Old 07-19-2009, 02:08 PM   #2
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 89
Check this thread for a solution...
 
Old 07-19-2009, 08:38 PM   #3
lightkuragari
LQ Newbie
 
Registered: Jan 2005
Location: Cuernavaca, Morelos, México
Distribution: Slackware
Posts: 23

Original Poster
Rep: Reputation: 1
Thanks niels.horn, i-ll try that... i solved it on my laptop without setting the locale param, instead i commented LANG=en_US and added LANG=es_MX.UTF-8 in /etc/profiles.d/lang.sh and that did the trick, besides i upgraded to ntfs-3g-2009-4-4, since full utf8 support for ntfs-3g was released since version 2009-1-1, and slack 12.2 ships with 1.15, and that did the trick.

However, i have the same issue in my desktop pc... i'll try just setting the locale param and see what happens. I'll post back the results.

Thank you!!

P.S. If anyone would like to upgrade to the new version of ntfs-3g, just remember to backup your /usr/share/hal/fdi/policy/10osvendor/10-ntfs-3g-policy.fdi before removing ntfs-3g package, because it gets deleted after that, and you'll need to copy it back if you install from source.
 
Old 07-19-2009, 08:48 PM   #4
lightkuragari
LQ Newbie
 
Registered: Jan 2005
Location: Cuernavaca, Morelos, México
Distribution: Slackware
Posts: 23

Original Poster
Rep: Reputation: 1
I'm back with the results...

Without doing nothing besides setting the locale param in /etc/fstab like this:

/dev/sdb1 /lightkuragari ntfs-3g umask=022,locale=es_MX.UTF-8

and after that:

umount /lightkuragari && mount /lightkuragari

what i get is the missing directories showing up this time, however accents are displayed as a 2 letter code like
Imágenes instead of Imágenes (as you may guess, or know, that's "images" in spanish), but i guess this is due to the system locale, which is still en_US and thunar displays those names that way, so i guess this is a solved matter. Thanks!!
 
Old 07-19-2009, 08:52 PM   #5
lightkuragari
LQ Newbie
 
Registered: Jan 2005
Location: Cuernavaca, Morelos, México
Distribution: Slackware
Posts: 23

Original Poster
Rep: Reputation: 1
Forgot to mention...

USB ntfs devices need to get mounted automatically with the same locale, so, that's why i still need to set the global locale. Could there be another way to achieve this?
 
Old 07-19-2009, 09:08 PM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Maybe I don't understand, my first dialect being Redneck.

Have you set this file up:
Code:
root@silas64:~# cat /etc/profile.d/lang.sh
#!/bin/sh
# Set the system locale.  (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
#   locale -a

# en_US is the Slackware default locale:
#export LANG=en_US

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968.  These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#export LANG=C

# There is also support for UTF-8 locales, but be aware that
# some programs are not yet able to handle UTF-8 and will fail to
# run properly.  In those cases, you can set LANG=C before
# starting them.  Still, I'd avoid UTF unless you actually need it.
export LANG=en_US.UTF-8

# Another option for en_US:
#export LANG=en_US.ISO8859-1

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
export LC_COLLATE=C

# End of /etc/profile.d/lang.sh
You can also use one for normal users in your ~/ directory:
Code:
mingdao@silas64:~$ cat .profile
export LANG=en_US.UTF-8
 
Old 07-19-2009, 09:41 PM   #7
lightkuragari
LQ Newbie
 
Registered: Jan 2005
Location: Cuernavaca, Morelos, México
Distribution: Slackware
Posts: 23

Original Poster
Rep: Reputation: 1
Oh! i didn't know that. Thanks, Bruce. Well, that way i won't need to set the whole system locale, and i suppose it still works with usb ntfs-3g auto mounted units.
 
  


Reply

Tags
boot, ntfs, utf8


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting ntfs usb disks with utf8 sloteel Linux - Hardware 4 07-13-2008 03:57 AM
utf8 fonts failed by ntfs read kandahari Fedora 1 04-11-2005 07:34 PM
NTFS partition: how to mount with UTF8 charset NullDevice23 Linux - General 0 02-28-2005 09:30 AM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 09:28 PM
NTFS and UTF8 Imyrryr Linux - Newbie 1 08-08-2003 03:08 PM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration