LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   UTF8 in kde show wrong letters (http://www.linuxquestions.org/questions/slackware-14/utf8-in-kde-show-wrong-letters-906055/)

pascal79 10-02-2011 08:45 AM

UTF8 in kde show wrong letters
 
Hi,

I've installed Slack 13.37. I've enabled in lilo the utf8 and all is ok when I'm in terminal tty.

But in kde (4.5) I see the wrong encoding?

It looks utf is enabled in terminal and not in kde.

Why?

Thanks, Pascal

Tribulation 10-02-2011 11:49 AM

Have you added UTF-8 after export LANG=en_US (or whatever language you're using) in /etc/profile.d/lang.sh?

pascal79 10-02-2011 02:04 PM

Yes, I put it_IT@utf8 in lang.sh and lang.csh.

Now I have rsynced again from my backup disk in konsole. Now I have:
kde: correct letters
terminal tty: wrong letter.

I tryed to remove the lilo append=" vt.default_utf8=1", I tryed to change my LANG var to it_IT.

I have no IDEA what is wrong with my slack.
I can live with my actual config, but it's just to understand how it works.
Anyway thanks!
Pascal

Martinus2u 10-02-2011 05:10 PM

shouldn't it be it_IT.utf8?

After changing LANG the newly created files and file names should be utf-8 encoded, but the old files and filenames will still be in the previous encoding. You can switch them using

http://freshmeat.net/projects/convmv/

pascal79 10-02-2011 11:23 PM

Quote:

Originally Posted by Martinus2u (Post 4488392)
shouldn't it be it_IT.utf8?

Yes it is!

Solved :D

Thanks

Martinus2u 10-03-2011 03:23 PM

no worries. :D


All times are GMT -5. The time now is 09:14 AM.