LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /usr/local/lib or /usr/local/lib64 (http://www.linuxquestions.org/questions/slackware-14/usr-local-lib-or-usr-local-lib64-742313/)

rigelan 07-23-2009 05:24 PM

/usr/local/lib or /usr/local/lib64
 
I have downloaded, compiled and installed many programs in slackware-64. Most of them install their libraries in /usr/local/lib by default.

I downloaded kmymoney just a few days ago, and it installed its libraries in /usr/local/lib64.

I found this odd because no other program so far has installed them in that location. The program did not work because the program couldn't find the libraries. So I updated the /etc/ld.so.conf to include /usr/local/lib64.

These are all 64-bit libraries; does anyone know why it might choose one directory by default over the other? Is it simply the preference of the programmers of kmymoney? Should one or the other directories be used? I would expect if I were to install 32-bit libraries on my system too, I might want those to go into /usr/local/lib and the 64-bit ones to stay in /usr/local/lib64. But as of now, I don't have 32-bit on my system.

Either way, it caused an issue until I added the directory to my ldconfig.

mlangdn 07-23-2009 06:47 PM

Yep - this is usually the preference of the programmer. I always check the default install, and then change it if necessary. Not every piece of software has a slackbuild, and I never (usually) accept the default.

I got into that kind of mess a couple of years ago. I have tried to keep it sane ever since.

rigelan 07-23-2009 07:25 PM

How would you check for the default lib install directory?

I usually do the
Code:

1. 'make install DESTDIR=/tmp/a' to another location,
2. browse through it with a 'find', (this would be where I check the directories)
3. chmod it to root,
4. and makepkg foo.txz.


rigelan 07-23-2009 07:26 PM

And by the way, my solution to kmymoney (which now has a KDE4 working copy - through SVN) was to symlink /usr/local/lib64 to /usr/local/lib so they are really the same directory. (This isn't reasonable on a system-wide basis, but it does seem reasonable for the 10 non-slackware local packages that I usually install)

manwichmakesameal 07-23-2009 08:36 PM

You can also usually use a --prefix=/your/dir/to/go/to during the configure. There are also --libdir options too.

mlangdn 07-23-2009 08:37 PM

Run the configure script with:

Code:

./configure --help
That will list all the options for configuring your build. Then an actual example:

Code:

./configure --prefix=/usr --libdir=/usr/lib64 --enable-some-feature --disable-some-feature

niels.horn 07-23-2009 08:46 PM

I have been in this mess as well...

The steps suggested by mlangdn should help you out in 95% of all cases.
For all other packages you need to study the configure script and Makefile...

Michielvw 07-24-2009 10:19 AM

To be honest, kmymoney2 is a bit of a bugger with regards to slackware64.

See also this thread as with regards to actually using the SlackBuild for 12.2

As things stand now, Kmymoney2 will *not* make the cut for 13.0 for mainly the two following reasons:
1) You'll need to install KDE3compat from extra, plus all the extra tricks as mentioned in above thread
2) While it will compile on slackware64-current, it will not build on slackware-current [1], so that's a no go.
3) They only just started porting to KDE4, so nothing usuable as far as I know.

If the kmymoney team starts putting out decent KDE4 builds, I will have a look at inclusion at SBo. [2]

[1] - I am willing to see proof to the other point.
[2] - Or someone can feel free to take over maintenance.

-M.

ROXR 07-24-2009 06:24 PM

I Can't download, the link is broken, all links.

Michielvw 07-24-2009 07:32 PM

Quote:

Originally Posted by ROXR (Post 3619363)
I Can't download, the link is broken, all links.

Perhaps a bit more specific would be useful here. What link(s), are we talking about.

As far the kmymoney2 slackbuild, the link works for me. You might be running into the silly-dead-mirror-bad-link bug that can plague sourceforge at times.


All times are GMT -5. The time now is 04:51 AM.