LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-06-2009, 03:06 PM   #1
dishbreak
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Rep: Reputation: 0
Using Slackware in a Virtual Machine -- adjust window size


Hi all,

I recently set up Slackware 13.0 x86 inside a VirtualBox setup. The installation went well, but I'm having a bit of a niggle.

I'm using Slackware to develop C code for a class, so I don't start X11. What this means that my virtual display is too big for the window, and I have scroll-bars on my console. (I've attached a picture to show what I mean) -> Photobucket Link

Is there any way to limit the size of the console display? I know it's not something one normally messes with, but this is starting to get kind of irritating, especially when i'm using vim.

Thanks for your time!

Last edited by dishbreak; 10-06-2009 at 03:36 PM. Reason: replaced picture with better example.
 
Old 10-06-2009, 03:59 PM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Edit /etc/lilo.conf

Look for this section (around line 38)
Code:
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
1024x768 is the default (vga=773)

Comment vga = 773 and try uncommenting vga=771 for an 800x600 display.

After changing and saving /etc/lilo.conf, you have to run lilo
$ lilo
This rewrites lilo to the mbr to save the settings. Restart the vm.

Or, you could just maximize your Virtual Screen
 
Old 10-06-2009, 04:53 PM   #3
dishbreak
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Original Poster
Rep: Reputation: 0
disturbed1,

Thanks! That sorted out my issue. I had tried changing the vga code prior, but I set it to a different one and didn't run lilo after I modified the config (I figured rebooting would do the job, makes sense that the MBR wasn't touched).

Small thing for other users: I had to switch to root using su to run lilo. I couldn't run it using sudo. Of course, I can't issue commands like shutdown and poweroff within my account, so that might be another issue entirely.

Thanks again! (and yes, I was using the VM in fullscreen mode. )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to share files between my linux virtual machine and window vista host? huy_china Linux - Newbie 8 10-07-2008 05:42 PM
Slackware 11.0 RC1 Virtual Machine centauricw Slackware 7 02-01-2007 09:23 AM
Slackware Virtual Machine centauricw Slackware 6 01-01-2007 05:06 PM
Adjust KDE Maximized Window Size elempoimen Linux - Software 2 11-08-2004 06:19 PM
KDE: Changing Font Size in Virtual Window Panel? oswald21 Linux - Software 0 06-12-2003 01:31 PM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration