LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-29-2004, 01:39 PM   #1
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Rep: Reputation: 15
using autofs to auto mount my usb drives


I have recently moved from MDK 9.2 to Slack 10. I have finally gotten everything working save two devices. My Maxtor onetouch USB external hard drive and a cheap little USB pen drive I got free from a vendor. The autofs setup was handled by MDK automatically so this is my first forray into it. Both drives used to automount in MDK so I know they function with Linux. My current kernel is the adaptec.s (I have an adaptec 2940U2W for my cd burner, wich I must say works far better under Slack than MDK) kernel included in the Slack 10 CD. I have read the various previous posts on the topic and here is where I am at.

First I have created an /etc/auto.master, an /etc/auto.removable, and a /etc/auto.removable2 each containing the following:

auto.master contains:
/mnt/removable /etc/auto.removable --timeout=1
/mnt/removable2 /etc/auto.removable2 --timeout=1

auto.removable contains:
usbdisk -fstype=vfat,umask=000 :/dev/sda

auto.removable2 contains:
usbkey -fstype=vfat,umask=000 :/dev/sdb

I also found the rc.autofs script for Slack 10 which basically reads from my auto.master. I then added the following to my /etc/rc.d/rc.M:

/etc/rc.d/rc.autofs start

On boot it starts autofs without error but neither usb drive is mounted. I know I am probably making a newbie mistake and just missing something minor (for instance, are sda and sdb the correct devices?)
 
Old 07-29-2004, 03:10 PM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
adaptec.s doesn't have compiled-in support for USB, so you may need to load some modules, usb-core and others.
You could also try installing the kernel meant for the wrongly-deprecated ZipSlack. ZipSlack has lots of secrets, including zipslack.s that has support for both adaptec and USB! Also has support for parallel-port IDE and lots of other stuff, so your dmesg is long.
Either that or load the modules before automounter gets called.
 
Old 07-29-2004, 03:58 PM   #3
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Original Poster
Rep: Reputation: 15
Thanks for the quick reply.
Checked that. I can now manually mount them with these commands:
USB HDD:
mount -t vfat /dev/sda1 /mnt/removable -o
USB Key:
mount -t vfat /dev/sdb1 /mnt/removable2 -o

I have changed auto.removable and auto.removable2 to reflect these changes and ran

/etc/rc.d/rc.autofs restart

still no automounting ability
 
Old 07-30-2004, 01:09 AM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
I'm not an atuomount user, so I can't really help more, sorry
 
Old 07-30-2004, 03:08 AM   #5
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
adaptec.s is a kernel for Adaptec SCSI controllers. Do you actually have a SCSI system? (I think you may be confusing CD-RW SCSI emulation and actual SCSI devices.)
 
Old 07-30-2004, 03:27 AM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Well if you want them to mount on boot why not use fstab?
 
Old 07-30-2004, 11:10 AM   #7
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Original Poster
Rep: Reputation: 15
to WMD: I have an Adaptec 2940 U2W (which is SCSI2 Ultra Wide). I have loaded the USB modules succesfully as shown by the results of the lsmod command (pertinent lines shown here):
usb-uhci 22256 0 (unused)
usbcore 59308 1 [usb-storage usb-uhci]

to gbonvehi: these drives are not always connected to my system. While I can mount and umount them manually, I know the automount system works if I can just work out the details. It would be un-Linux-User-like for me to not try to solve this problem. Who knows, maybe another newbie might read this and find that he has the same trouble and we solved it for him.

to all: thanks for putting up with me. I know the solutions is so close I can taste it.
 
Old 07-30-2004, 11:21 AM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Maybe you should take a look at /usr/doc/autofs-3.1.7/samples there you have sample configurations to use with autofs (i haven't used autofs and don't have any usb storage to test this stuff, but it should guide you).
Never give up, it's just a matter of time to solve things

Last edited by gbonvehi; 07-30-2004 at 11:29 AM.
 
Old 07-30-2004, 11:27 AM   #9
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Original Poster
Rep: Reputation: 15
Thanks, I'll tell you how the hunt goes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems auto-mounting usb drives in kernel 2.6.13.3 dizzi Slackware 8 10-29-2005 02:41 PM
removable drives don't auto mount paintitmatt Ubuntu 2 04-15-2005 02:14 PM
udev, USB Flash Drives, and usb-mount talkingwires Debian 13 11-07-2004 01:15 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 01:26 PM


All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration