Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 04-26-2004, 09:47 PM   #1
LQ Guru
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Question using an older version of gcc

the live cd distro i want to install squid onto needs everything to be compiled with gcc-2.95.x and linked against glibc-2.2.x, but those are the versions slackware 8.1 uses, and i'm using slackware 9.1 on my pc...

how can i compile squid on slackware 9.1 using the gcc and stuff from slackware 8.1???

Last edited by win32sux; 05-12-2004 at 12:42 AM.
Old 05-12-2004, 01:53 AM   #2
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
you should install gcc and glibc with a ./configure --prefix=/<dir> option so you install them but in another dir than standard, so they won't overwrite current versions. something like /opt/gcc-2.95 and /opt/glibc-2.2 would do. You can tell the squid configure script where gcc and glibc are with some option like ./configure --glibc=/opt/glibc --gcc=/opt/gcc but I'm not sure about that options, try a ./configure --help for that

.-=~ iluvatar ~=-.

Last edited by iluvatar; 05-12-2004 at 01:57 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 02:54 PM
How can I install an older gcc thorney Fedora 1 11-25-2005 08:16 PM
kernel build problems -how to install older gcc version? kpachopoulos Fedora 3 07-04-2005 08:56 AM
compiling older gcc srinis Linux - Newbie 1 04-01-2005 11:18 AM
Install older version of gcc s9902245 Linux - Newbie 1 09-16-2003 03:08 PM

All times are GMT -5. The time now is 12:21 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration