-   Slackware (
-   -   using an older version of gcc (

win32sux 04-26-2004 09:47 PM

using an older version of gcc
the live cd distro i want to install squid onto needs everything to be compiled with gcc-2.95.x and linked against glibc-2.2.x, but those are the versions slackware 8.1 uses, and i'm using slackware 9.1 on my pc...

how can i compile squid on slackware 9.1 using the gcc and stuff from slackware 8.1???

iluvatar 05-12-2004 01:53 AM

you should install gcc and glibc with a ./configure --prefix=/<dir> option so you install them but in another dir than standard, so they won't overwrite current versions. something like /opt/gcc-2.95 and /opt/glibc-2.2 would do. You can tell the squid configure script where gcc and glibc are with some option like ./configure --glibc=/opt/glibc --gcc=/opt/gcc but I'm not sure about that options, try a ./configure --help for that ;)

.-=~ iluvatar ~=-.

All times are GMT -5. The time now is 01:04 PM.