LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-11-2003, 06:53 PM   #1
puntme
LQ Newbie
 
Registered: Jul 2003
Posts: 8

Rep: Reputation: 0
Users can't access Fat drives.


None of the users can access the Fat drives I have mounted.

Here is my fstab:

Code:
/dev/hda1        swap             swap        defaults         0   0
/dev/hda2        /                ext3        defaults         1   1
/dev/hda3        /usr             ext3        defaults         1   2
/dev/hda4        /home            ext3        defaults         1   2
/dev/hdb1        /fat1            vfat        defaults         1   0
/dev/hdb2        /fat2            vfat        noauto,user,ro   0   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
I think I messed it up when I was trying to fix it, also, since it wont display the files in Root anymore.

Thanks.
 
Old 08-11-2003, 07:42 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
/dev/hdb1 /fat1 vfat defaults 1 0
/dev/hdb2 /fat2 vfat noauto,user,ro 0 0

These two lines (above) in your /etc/fstab are dodgy.

Personally I'd create mount points in your /mnt directory

Open a Command line - su to root user

mkdir /mnt/fat1
mkdir /mnt/fat2

Then edit both lines in /etc/fstab to read as follows:

/dev/hdb1 /mnt/fat1 vfat auto,uid=501,umask=000 0 0
/dev/hdb2 /mnt/fat2 vfat auto,uid=501,umask=000 0 0

(just substitute in your user id number in place of my example one) - To get your uid (user id number) -

open a command line

type

id username (substitute in your username in place of username)

for example

id michael
id Sarah

look for the

uid=xxx

thats your uid number

Last edited by Skyline; 08-11-2003 at 07:51 PM.
 
Old 08-11-2003, 08:20 PM   #3
puntme
LQ Newbie
 
Registered: Jul 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks, it worked!
 
Old 08-12-2003, 01:24 PM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Wink

Nice
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Users can't access mounted drives NosLycn Linux - Software 4 04-01-2005 03:37 PM
grant user access to /fat-c & copying users' preferences to another user n0x Linux - Newbie 1 07-04-2004 12:04 AM
How to access NTFS/FAT drives from Fedora Core 2 lapierrem Linux - Newbie 4 06-16-2004 09:54 AM
Mounting fat drives in fstab.. subnet Linux - Newbie 3 10-10-2003 03:02 AM
Slackware 9.0 - unable to see fat-c/d drives evano Slackware 9 04-22-2003 11:07 AM


All times are GMT -5. The time now is 01:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration