LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2013, 07:03 PM   #1
waddles
Member
 
Registered: Sep 2012
Posts: 373

Rep: Reputation: 0
use of alt key not producing icon ver 13.37 & xfce


I have seen 2 different versions of how to produce icons via alt key and use of keypad (with num lock on). For me neither works just get a number entered on screen.
Any ideas?
Have to use my right window key then compose character keys but do not believe that should be the compose key which I think is the one to the right of it (has black page above white one with arrow pointing down).
Can someone validate that for me?
Is there a way to set up the particular key for compose key or alt key to be used with keypad?
Ideas on proper way to produce skull & X-bones?

Last edited by waddles; 01-13-2013 at 07:05 PM.
 
Old 01-13-2013, 07:41 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,601
Blog Entries: 2

Rep: Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060
The Unicode character SKULL AND CROSSBONES has the hexadecimal number 2620. To type it in press Ctrl+Shift+u to activate the input mode for Unicode characters. An underlined u should appear, now type in the number and press the Enter key.

Last edited by TobiSGD; 01-13-2013 at 07:43 PM.
 
Old 01-15-2013, 02:28 AM   #3
waddles
Member
 
Registered: Sep 2012
Posts: 373

Original Poster
Rep: Reputation: 0
use of alt key not producing icon ver 13.37 & xfce

Thanks but when I tried it in "Terminal" mode I got a ? as an output. In konsole mode and in xterm I do not get even an underlined u.
This must be due to the Uni codes. Can U brief me on the result?
 
Old 01-15-2013, 03:26 AM   #4
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
The ability to enter Unicode values using CTRL+Shift+u is a GTK thing. I don't know what analog exists, if any, for Qt apps.

The reason you're getting a question mark in the Xfce Terminal after entering the sequence is likely because you aren't using a UTF-8 locale. Type "locale" to see what your current settings are. Try this to see if it works correctly for you:

Open up a new Terminal window. Within that window type

Code:
LANG=en_US.UTF-8 Terminal
to start yet another new Terminal window, this time using a UTF-8 locale. Then try the CTRL+Shift+u 2620 sequence to get your skull and crossbones.
 
1 members found this post helpful.
Old 01-15-2013, 06:16 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,601
Blog Entries: 2

Rep: Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060Reputation: 4060
Quote:
Originally Posted by Mike_M View Post
The ability to enter Unicode values using CTRL+Shift+u is a GTK thing.
Thanks, I didn't know that, I rarely use Qt apps.
 
Old 01-15-2013, 01:59 PM   #6
waddles
Member
 
Registered: Sep 2012
Posts: 373

Original Poster
Rep: Reputation: 0
use of alt key not producing icon ver 13.37 & xfce

OK but it didn't work as advertised.
Be aware there are 3 display mechanisms available to xfce:
Terminal (what it says at the top), xterm and konsole. I am using former.
Here is locale from terminal:
Code:
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
I cut/pasted LANG=en_US.UTF-8 Terminal inside my regular Terminal and got another Terminal in which I tried the skull&X-bones 2x. None worked.
Am aware of Qt & GTK tho not in detail but have gtk+ ver 4.8.1, gtl+2 ver 2.24.4 and Qt 4.7.0 installed.

Last edited by waddles; 01-15-2013 at 02:18 PM.
 
Old 01-15-2013, 04:43 PM   #7
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Quote:
Be aware there are 3 display mechanisms available to xfce
I'm well aware there are multiple terminal emulators, which is why I have been specific in stating which one to use. The one called "Terminal" is Xfce's terminal emulator program, and it is a GTK program unlike the others. It is the only of the three you listed that will work with CTRL+Shift+U.

I had to set up my environment to be non UTF-8 in order to replicate what you're seeing. With UTF-8 disabled executing "LANG=en_US.UTF-8 Terminal" from within Terminal did not allow me to display the Unicode characters in the newly launched Terimal. However, executing "LANG=en_US.UTF-8 Terminal" from within Konsole (KDE's QT based terminal emulator) worked fine and the newly launched Terminal displayed the Unicode characters properly. Also, setting LANG with "export LANG=en_US.UTF-8" prior to starting X worked.

What you can do is add the line following line to your ~/.bash_profile file (assuming you use the Bash shell; adjust accordingly for other shells):

Code:
export LANG=en_US.UTF-8
then exit X, logout from the terminal, login again, restart X and try again.

You can also enable UTF-8 globally by adding the following to /etc/lilo (or uncomment it if it is already there):

Code:
append=" vt.default_utf8=1"
run "lilo" as root, and reboot. The default in Slackware is to have that disabled. There may be reasons for that, but I have had it enabled for at least the last two Slackware versions without any problems. Someone more knowledgeable can chime in on any potential pitfalls.
 
Old 01-16-2013, 12:20 AM   #8
waddles
Member
 
Registered: Sep 2012
Posts: 373

Original Poster
Rep: Reputation: 0
Thanks to everyone!!
I found the following very instructive and clarifying:
http://docs.slackware.com/slackware:localization
and would not have found it without the assistance given here.
Apparently a temporary UTF-8 setup is available via "unicode-start/unicode-stop". At least I hope so as I have yet to try it. If not perhaps someone will have a script for accomplishing the goal.
Again THANKS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox & Alt key... Splin Linux - Software 15 12-18-2013 03:45 PM
ALT+B, ALT+F key combinations in xterm don't work nIMBVS cAos 4 12-15-2011 01:52 AM
Why does Krunner not show up when pressing alt+F2 in Slackware64 Ver. 13.0? Timberwolf753 Slackware 17 09-11-2009 08:39 PM
How do I get Right-Alt key to be just Alt and not generate special characters? (KDE) KWTm Linux - General 2 06-25-2005 09:26 PM
fluxbox & alt key kurrupt Linux - Software 4 10-26-2004 04:18 PM


All times are GMT -5. The time now is 07:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration