LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2005, 06:58 AM   #16
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Original Poster
Rep: Reputation: 30

Quote:
When you do :
lsmod

Do you see autofs module loaded ?
I would say no here.

tsun@sKex:/etc/rc.d$ lsmod
Module Size Used by
cisco_ipsec 393868 1
snd_pcm_oss 61220 0
snd_mixer_oss 21120 3 snd_pcm_oss
snd_via82xx 25632 4
snd_ac97_codec 76512 1 snd_via82xx
snd_pcm 99716 4 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd_page_alloc 9220 2 snd_via82xx,snd_pcm
snd_mpu401_uart 7936 1 snd_via82xx
snd_rawmidi 23456 1 snd_mpu401_uart
nvidia 3463100 8


Quote:
Also could you post your /etc/auto.misc file content ?
Directory of mounting usb drive is located at /mnt/usb.
Here you are:
tsun@sKex:/etc/rc.d$ cat ../auto.misc
# $Id: auto.misc,v 1.2 1997/10/06 21:52:04 hpa Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

#kernel -ro ftp.kernel.org:/pub/linux
#boot -fstype=ext2 :/dev/hda1
usb -fstype=vfat :/dev/sda1
#cd -fstype=iso9660,ro :/dev/hdc
#floppy -fstype=auto :/dev/fd0

tsun@sKex:/etc/rc.d$ cat ../auto.master
# $Id: auto.master,v 1.2 1997/10/06 21:52:03 hpa Exp $
# Sample auto.master file
# Format of this file:
# mountpoint map options
# For details of the format look at autofs(8).
/mnt /etc/auto.misc
 
Old 01-15-2005, 09:52 AM   #17
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,444

Rep: Reputation: 94
Have you the autofs module ?
/sbin/modprobe -l | grep autofs

If yes, it is weird as /etc/rc.d/rc.autofs should load it, anyway try modprobe autofs

Or maybe as built-in, in both case autofs should appear in
cat /proc/filesystems
 
Old 01-26-2005, 10:02 AM   #18
Jacknight
LQ Newbie
 
Registered: Dec 2001
Location: UM NO
Distribution: Red Hat, Mandrake
Posts: 2

Rep: Reputation: 0
USB automount

Does anyone know how Linspire (formerly Lindows) set up their automount? I'm not quite enough of a geek to figure it out. There setup is pretty nice though I plug my pen drive in and it auto mounts and an icon is created for it just like the cdrom. A green arrow is put on top of the icon to indicate it is mounted. When I'm done with it I right click hit unmount the green arrow goes away. Then I can unplug it at which point the icon goes away.

I also like the way that they have the cdrom set up. It automounts like most distros but if I close all windows related to the cd then it auto umounts.

If anyone has any insight into this it is appreciated
 
Old 01-26-2005, 08:53 PM   #19
JrLz
Member
 
Registered: Mar 2004
Location: Jakarta
Posts: 164

Rep: Reputation: 30
Quote:
Originally posted by WMD
You can't even do that in Windows!
well, at least ...it's one of many great opportunities for GNU/Linux to beat them..............
but how to do the umount automatically ??????????
let's find out.............
 
Old 01-26-2005, 09:25 PM   #20
DaWallace
Member
 
Registered: Feb 2004
Location: Southern Maine, United States
Distribution: Slackware Ubuntu Debian FreeBSD
Posts: 418

Rep: Reputation: 31
there's an rc.autofs for slackware

I found it earlier today..

http://mariner.cs.ucdavis.edu/slackw...ware/rc.autofs

google ffs
 
Old 01-27-2005, 09:02 PM   #21
JrLz
Member
 
Registered: Mar 2004
Location: Jakarta
Posts: 164

Rep: Reputation: 30
Re: USB automount

Quote:
Originally posted by Jacknight
Does anyone know how Linspire (formerly Lindows) set up their automount? I'm not quite enough of a geek to figure it out. There setup is pretty nice though I plug my pen drive in and it auto mounts and an icon is created for it just like the cdrom. A green arrow is put on top of the icon to indicate it is mounted. When I'm done with it I right click hit unmount the green arrow goes away. Then I can unplug it at which point the icon goes away.

I also like the way that they have the cdrom set up. It automounts like most distros but if I close all windows related to the cd then it auto umounts.

If anyone has any insight into this it is appreciated
You'll also have it on Suse/Novell and ubuntu......
I've experienced it.......
But I don't have it on my slackware.............
I'll find it out, and I'll post once I get to those machines...
 
Old 01-28-2005, 06:49 AM   #22
jawkins
LQ Newbie
 
Registered: Jan 2005
Location: London
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
Quote:
Originally posted by JrLz
well, at least ...it's one of many great opportunities for GNU/Linux to beat them..............
but how to do the umount automatically ??????????
let's find out.............
Automatic umounting when you remove the device would only be possible if you mount the device with the sync and dirsync options to ensure the data is always written to the device immediately. According to my "man mount" sync only works with ext2, ext3 and ufs, so I wouldn't trust it on a USB FAT filesystem. It's also slower and would reduce the lifetime of the flash from unneccessary writes.

Jim
 
Old 02-03-2005, 05:07 AM   #23
zparihar
Member
 
Registered: Sep 2004
Distribution: Fedora, Debian
Posts: 59

Rep: Reputation: 15
mtools

Hey guys...

I'm actually trying to figure out a similar problem... i've put up a thread about this already...
http://www.linuxquestions.org/questi...hreadid=285696



You do not need to actually mount our unmount the USB key to access files on it...


If you guys have mtools installed... just simply add the following line to your /etc/mtools.conf:

drive u: file="/dev/sdb1" exclusive mformat_only



(sdb or sda - depending on your system)

make sure the permissions on /dev/sdb1 is set to 777

then in Konqueror type in the address ' floppy:/u '

and then you're in your USB Flash....
Do a man mtools to find out more

Simple!

However, my problem is that when i unplug the usb key, my /dev/sdb1 dissappears. (which is ok)
But when i plug in my usb key, the device /dev/sdb1 is recreated with the permissions 700 ! (only root)

Does anyone know a solution on how I can get my permissions to automatically be set to 777 when I plug in my USB Key?


Thanks

Zubin Parihar
 
Old 02-03-2005, 04:28 PM   #24
zparihar
Member
 
Registered: Sep 2004
Distribution: Fedora, Debian
Posts: 59

Rep: Reputation: 15
Heres my howto

Hey guys...

Here is my howto on how to access your USB Flash Device without mounting and unmounting it!

http://www.linuxquestions.org/questi...hreadid=285916


Hope it helps anyone!


Zubin Parihar
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can not mount usb flashdrive walterbyrd Debian 14 03-18-2006 12:53 PM
still more USB flashdrive problems... Lord Zoltar Linux - Hardware 8 01-22-2005 12:38 PM
USB flashdrive problems endfx Linux - Hardware 11 01-01-2005 05:40 PM
USB FlashDrive -- Again kadalz Linux - Newbie 1 10-12-2003 11:20 AM
USB Flashdrive disto cli_man General 7 02-23-2003 04:56 AM


All times are GMT -5. The time now is 11:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration