LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-21-2005, 02:18 PM   #1
dkpw
Member
 
Registered: Sep 2003
Location: Scotland
Distribution: LinuxMint16 & Ubuntu 12.0.4 LTS
Posts: 218

Rep: Reputation: 30
USB Drive in 8.3 File Format


I'm just getting to grips with Slackware after spending time in SuSE and Yellow Dog and so far so good. It's fast, stable and I found it easy to install on an Evo 510 SFF. I do have a question regarding my USB pen drive.

I edited my /etc/fstab to include:
/dev/sda1 /mnt/gizmo vfat noauto,users,rw 0 0

I created the gizmo directory in /mnt/ and a desktop shortcut to it. To mount and unmount I right click the icon and that's it.

Only thing is that KDE displays my folders in a truncated DOS 8.3 name convention. I know that the drive is formatted as FAT but SuSE and other distros could display the long names.

Is there a way in Slackware to amend this behaviour so I can avoid folder names such as "applic~1"?

Thanks for any pointers.

dkpw
 
Old 03-21-2005, 04:09 PM   #2
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Check that the USB drive is actually being mounted as vfat - type
Code:
mount -l
- and check the output for that partition. It might be falling back on a different type if you're lacking something in the kernel.

Cheers,

mj
 
Old 03-21-2005, 05:54 PM   #3
dkpw
Member
 
Registered: Sep 2003
Location: Scotland
Distribution: LinuxMint16 & Ubuntu 12.0.4 LTS
Posts: 218

Original Poster
Rep: Reputation: 30
Thanks MJ,

Here's the output from the mount command and the last line shows the problem - it's mounted as an MSDOS volume despite what /etc/fstab says.

Code:
root@slack:~# mount -l
/dev/hda2 on / type reiserfs (rw)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/sda1 on /mnt/gizmo type msdos (rw)
The above output is achieved with the pen drive mounted using my desktop alias of /mnt/gizmo. If I use the command line to mount the drive.

Code:
mount /dev/sda1
the output changes to

Code:
/dev/sda1 on /mnt/gizmo type vfat (rw,noexec,nosuid,nodev)
and the drive is back to its long-named splendour.

I have created a small shell script to mount the drive and when I open alias long names are displayed. While this works, it doesn't seem neat.

Can MJ or anyone else suggest why fstab is being "ignored" and can I get a one step process from the desktop?

Kind regards,

dkpw
 
Old 03-21-2005, 06:01 PM   #4
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Re: USB Drive in 8.3 File Format

Quote:
I created the gizmo directory in /mnt/ and a desktop shortcut to it. To mount and unmount I right click the icon and that's it.[/B]
I suspect that this may be your problem. Under KDE, you need to create a new link to a device, not to a directory. I.e., right click on the desktop -> Create new -> Device -> Hard disk, and then select your fstab entry from the drop-down box on the third tab (Devices).

Somehow it's using the 'auto' option instead of directly specifying vfat, when mounting at the same time as opening the directory, and failing miserably

Cheers,

mj
 
Old 03-21-2005, 06:31 PM   #5
dkpw
Member
 
Registered: Sep 2003
Location: Scotland
Distribution: LinuxMint16 & Ubuntu 12.0.4 LTS
Posts: 218

Original Poster
Rep: Reputation: 30
Thanks again MJ,

I hear what you're saying about creating a link to a device rather than a directory. Unfortunately that's what I did.

Just to make sure, I created a new link with the drive mounted as a vfat device rather than an MSDOS device. This regrettably did not make a difference.

As you say it seems indifferent to my wishes.
I have a workaround at least thanks to your help, it's just there must be something else going on....

Kind regards,

dkpw
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format a USB flash drive? Erik_the_Red Linux - Hardware 4 08-29-2005 01:47 PM
USB Drive Format and Image aeuzent Linux - Newbie 2 06-25-2005 01:39 AM
trouble format USB hard drive shortname Fedora 2 03-11-2005 12:05 PM
Why do file names keep getting changed to dos 8.3 format on my usb drive? firehawk256 Linux - Newbie 1 02-25-2005 04:32 PM
trouble format USB hard drive shortname Linux - Hardware 1 02-14-2005 09:02 AM


All times are GMT -5. The time now is 01:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration