Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 09-22-2006, 08:41 AM   #1
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 397

Rep: Reputation: 33
USB device speed

I have an external USB hard drive that, on one of my Slackware computers, I can only write to at around 2.3MB/s. It is USB 2.0, and I have checked this on another Slackware computer, and seems to work fine there. The hard drive is partitioned as reiserfs. I have checked the drive using reiserfsck and everything comes up alright there. Also, I will lose connection to the drive when writing to it on the problematic computer, where it stalls when writing, and then I have to physically disconnect and reconnect it to the computer. I am running Slackware-current on the computer that is experiencing this problem, and mostly a base 10.2 installation on the other one where there does not appear to be a problem, if these factors matter. Thanks.
Old 09-23-2006, 12:52 PM   #2
Registered: Feb 2004
Posts: 307

Rep: Reputation: 30
Make sure the USB port is a 2.0 port, not a 1.1 port.
Old 09-23-2006, 01:02 PM   #3
Senior Member
Registered: Dec 2003
Posts: 3,161
Blog Entries: 4

Rep: Reputation: 135Reputation: 135
Another thing, if you're using a usb hub, then the speed will be limited to the maximum speed of the hub.

I'm saying this because I found the same thing in the USB flash drive I was using when I used it with and without the hub. I wondered why it was so slow until I realized that it was connected to the hub.

You can generally see the USB info using the KInfoCenter app (in KDE System menu if you're using KDE).


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive not working properly, read only device? (USB key storage device) Arodef Linux - Hardware 14 01-01-2010 08:32 AM
USB 2.0 speed degraded to USB 1.1 speed friendship7 Debian 5 07-13-2006 02:22 AM
How to force kernel to use a USB 2.0-compatible device (ehci_hcd) as a USB 1.1 device eze Linux - Hardware 0 05-16-2006 06:24 AM
usb 2.0 hdd working through usb 2.0 pcmcia card full speed in 2.4, but slow in 2.6 chilly_willy2 Linux - Hardware 11 02-02-2006 07:16 PM
HP Deskjet (USB) & CUPS & Slackware 9.1: Unable to open USB device "usb:/dev/usb/lp0&qu arnostienen Slackware 2 01-29-2004 04:22 PM

All times are GMT -5. The time now is 05:42 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration