LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-11-2007, 06:36 PM   #1
zmarius
LQ Newbie
 
Registered: Jun 2007
Posts: 7

Rep: Reputation: 0
upping open files from 1024 :|


Hey, I've only been able to find two seperate articles on this website under slackware forums on changing the open file limit.. I'm new to slackware, under other linux flavors I can manage, but slack is kicking my butt.

I just need to up it for certain users on the box, this is mainly for irc daemon purposes.
 
Old 06-11-2007, 07:35 PM   #2
theoffset
Member
 
Registered: Aug 2005
Location: Guadalajara, Jal, Mexico
Distribution: Slackware Linux
Posts: 211

Rep: Reputation: 30
I haven't actually ever changed such value (1024 its a LOT of open files!), but hope this helps:

Code:
$ man limits
[...]
DESCRIPTION
       The  limits  file  (/etc/limits  by  default  or LIMITS_FILE  defined config.h)
       describes the resource limits you wish to impose.  It should be  owned  by  root
       and readable by root account only.

       By  default  no quotas are imposed on 'root'. In fact, there is no way to impose
       limits via this procedure to root-equiv accounts (accounts with UID 0).

       Each line describes a limit for a user in the form:

       user LIMITS_STRING

       The LIMITS_STRING is a string of a concatenated list of resource  limits.   Each
       limit consists of a letter identifier followed by a numerical limit.

       The valid identifiers are:

       A: max address space (KB)
       C: max core file size (KB)
       D: max data size (KB)
       F: maximum filesize (KB)
       M: max locked-in-memory address space (KB)
       N: max number of open files
       R: max resident set size (KB)
       S: max stack size (KB)
       T: max CPU time (MIN)
       U: max number of processes
       K: file creation mask, set by umask(2).
       L: max number of logins for this user
       P: process priority, set by setpriority(2).

       For  example,  L2D2048N5  is a valid LIMITS_STRING. For reading convenience, the
       following entries are equivalent:

       username L2D2048N5
       username L2 D2048 N5
[...]
$ ulimit -a
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
file size               (blocks, -f) unlimited
pending signals                 (-i) 1918
max locked memory       (kbytes, -l) 32
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 1918
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited
 
Old 06-11-2007, 07:57 PM   #3
zmarius
LQ Newbie
 
Registered: Jun 2007
Posts: 7

Original Poster
Rep: Reputation: 0
when I went to check for /etc/limits I had no file... so in an editor it was reported as a new file.. well I used that format "username N8192" and logged in with the particular username, and i still had the same amount of open file descriptors limited (1024)...
why wouldn't i even have the /etc/limits file?!?!?! crazy
 
Old 06-11-2007, 08:17 PM   #4
theoffset
Member
 
Registered: Aug 2005
Location: Guadalajara, Jal, Mexico
Distribution: Slackware Linux
Posts: 211

Rep: Reputation: 30
Quote:
Originally Posted by zmarius
when I went to check for /etc/limits I had no file... so in an editor it was reported as a new file.. well I used that format "username N8192" and logged in with the particular username, and i still had the same amount of open file descriptors limited (1024)...
why wouldn't i even have the /etc/limits file?!?!?! crazy

The /etc/limits file doesn't exists by default, so that's totally normal.

I just tried it and it seems to work here (but I'm running -current right now).

A thing to check: did you make sure to "chmod 600 /etc/limits" as root? It seems that login(1) doesn't like it when such file has more permissions than that.

There was a way to put the ulimits in the comment field of /etc/passwd... but can't seem to find the correct syntax anywhere.
 
Old 07-01-2007, 11:25 AM   #5
zmarius
LQ Newbie
 
Registered: Jun 2007
Posts: 7

Original Poster
Rep: Reputation: 0
still no dice, anybody else have any input?
 
Old 07-01-2007, 10:31 PM   #6
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
See http://slackwiki.org/Resource_Limits
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Sun upgrades Solaris 10 OS while upping the channel ante on Red Hat LXer Syndicated Linux News 0 01-22-2007 03:33 AM
How do I open appleworks files (.cwk) in open office? mkpovak Linux - Desktop 1 08-08-2006 04:03 AM
how to open files from a network server from open office or any apps reycapoy Linux - Software 4 01-26-2006 07:00 PM
upping fsb junctionking Linux - Software 0 06-17-2005 02:16 PM
Can Open Office open WordPerfect files hemenm Linux - Software 2 03-10-2004 05:14 PM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration