LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-17-2010, 02:15 AM   #1
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
upon startx, 64 bit SW 13.1 looses its virt terminals radeon


Hi,

64 13.1 it's patched to the very latest.

I need my terminals. I use them. They do work until X is started. How do I get them to not go away when X is started?

radeon 5450

I added an append in lilo.conf of

video=radeonfb

And I load the radeon module before I startx

/sbin/modprobe radeon

But all of the tty(2 through 6) still disappear as soon as X is started.

By "disappear", I mean that there's no cursor or text on the screen -- appears as if is in sleep mode but neither the mouse nor the keyboard -- IOW tty login remains not available.

--
Alan.
 
Old 09-17-2010, 09:47 AM   #2
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 225

Rep: Reputation: 52
My understanding is that you need to enable KMS.
Based on some previous posts from other forumites, here is what I did on my laptop that has a Radeon HD2600:

I blacklisted radeonfb and radeon in /etc/modprobe.d/blacklist.conf:
Code:
# Stop radeon modules from loading too early:                                                             
blacklist radeonfb                                                                                        
blacklist radeon
I put this entry in /etc/modprobe.d/radeon.conf to enable KMS:
Code:
options radeon modeset=1
(You will probably have to create this file.)

I then added this right at the bottom of /etc/rc.d/rc.modules:
Code:
### Since we blacklisted the radeon module earlier we must now load it                                    
/sbin/modprobe radeon
Then I removed any "vga=" entries from my lilo.conf, because these should only still be used if KMS is disabled.
Here is my append line from /etc/lilo.conf:
Code:
append="vt.default_utf8=1,fbcon=font:SUN12x22"
YMMV. Hope that helps.
 
Old 09-18-2010, 01:07 AM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 49
Hi,

Thanks. I've got it working! Rather well, yes. radeon HD 5450

Oh, BTW, I'm running 2.6.35.4 with I config/compiled it using Robby Workman's "generic config for 2.6.35.4" that there's a link to that config in a forum post somewhere right here in the Slackware forum.

But 13.1's 2.6.33.4 generic and huge kernel also formerly had the same (virtual terminals disappearing) problem.

fskmh -- of your 4 listed solution items, the two in the middle made it work.

Re your top item, radeonfb was already blacklisted. I've not yet blacklisted radeon as it doesn't seem to need this in my case. lsmod appears correct with/showing a radeon loaded.

gpu accell is disabled -- it couldn't load the firmware or something to that effect. But I don't care on this one (I guess so anyways) 'cause I don't do games.

http://www.linuxquestions.org/questi...ml#post3883056

http://www.linuxquestions.org/questi...aphics-829120/

--
Alan.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
radeon kernel modules blanks console terminals. page_seven Linux - Hardware 7 09-09-2010 09:05 PM
LXer: Hacking libvirt/virsh/virt-manager/virt-install at Xen 4.0 Dom0 on top of Ubunt LXer Syndicated Linux News 0 05-06-2010 02:50 PM
LXer: Virt-install&Virt-manager at Xen 4.0-rc8 (2.6.32.10 pvops) Dom0 on top Ubuntu K LXer Syndicated Linux News 0 03-26-2010 09:41 PM
LXer: Virt-install at Xen 3.2.1 F8 Dom0 (64-bit) LXer Syndicated Linux News 0 06-01-2008 08:12 PM
radeon 9000 help with errors at startx Scruff Linux - Hardware 0 10-03-2003 10:16 PM


All times are GMT -5. The time now is 09:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration