LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   upgraded to 2.6.15.4 and now slack won't boot (http://www.linuxquestions.org/questions/slackware-14/upgraded-to-2-6-15-4-and-now-slack-wont-boot-423290/)

moises 03-09-2006 05:39 PM

upgraded to 2.6.15.4 and now slack won't boot
 
i compiled the new kernel 2.6.15.4 using the instructions on

http://www.linuxquestions.org/questi...d.php?t=174447

now, the system starts to boot, but it stops and shows this message

Code:

kernel panic-not syncing: VFS: Unable to mount root fs on unknown-block (3,2)
anyone might know what this means? the original kernel 2.4.31 still boots fine.

cwwilson721 03-09-2006 06:01 PM

What filesystem is your '/' drive using? Odds are, you did not include the filesystem min the kernel, only as a module. The kernel needs the filesystem long before it loads modules.

Either config the kernel w/the correct filesystem included, or us the 'initrd' option.

moises 03-09-2006 07:39 PM

thanks

i had to set to yes rather than module.


All times are GMT -5. The time now is 03:14 AM.