LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2008, 08:30 AM   #16
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,192

Rep: Reputation: Disabled

Quote:
Originally Posted by unamed_user View Post
The author of the shell script mkinitrd assumes that it's running in an environment with GNU coreutils installed. But actually the installation environment only provides busybox's utils. Some of the command's options can't be recognised by the busybox's utils. For example option --parents in cp. Without an initrd.gz I can't boot into the normal system which has GNU coreutils. The $PATH contains installed system's /bin directory, but busybox's will be choosen to invoke first.

This flaw brings some of the initrd problems.
I think mkinitrd should be modified to be compatible with busybox.
I am one of the contributors to mkinitrd. This script is not meant to be started directly in the installer environment!

Instead, you should do a "chroot /mnt" after Slackware's setup completes and then run mkinitrd in the 'chroot'. This is by design. We expect the coreutils and bash to be available.

If you boot the Slackware installer as a "rescue CD" then you will have to mount your harddisk partition(s) manually below /mnt first, and then mount /proc and sys below /mnt so that the scripts and applications that you run in the chroot can properly query the hardware configuration:
Code:
mount -o bind /sys /mnt/sys
mount -o bind /proc /mnt/proc
chroot /mnt
<plug> Try the mkinitrd_command_generator.sh script - it will analyze your computer and suggest a mkinitrd commandline that should generate a correct initrd.gz image for you. You can also let it generate the block of lines that you can write to /etc/lilo.conf

Eric
 
Old 04-23-2008, 09:30 AM   #17
unamed_user
LQ Newbie
 
Registered: Apr 2008
Location: China
Distribution: Slackware 12.0
Posts: 10

Rep: Reputation: 0
Quote:
Originally Posted by Alien Bob View Post
I am one of the contributors to mkinitrd. This script is not meant to be started directly in the installer environment!

Instead, you should do a "chroot /mnt" after Slackware's setup completes and then run mkinitrd in the 'chroot'. This is by design. We expect the coreutils and bash to be available.

If you boot the Slackware installer as a "rescue CD" then you will have to mount your harddisk partition(s) manually below /mnt first, and then mount /proc and sys below /mnt so that the scripts and applications that you run in the chroot can properly query the hardware configuration:
Code:
mount -o bind /sys /mnt/sys
mount -o bind /proc /mnt/proc
chroot /mnt
<plug> Try the mkinitrd_command_generator.sh script - it will analyze your computer and suggest a mkinitrd commandline that should generate a correct initrd.gz image for you. You can also let it generate the block of lines that you can write to /etc/lilo.conf

Eric
Maybe it's my fault. I can't remember whether I saw the instruction telling me to chroot. Thank you for your work.

I have tried the suggestion given by mkinitrd_command_generator.sh. But no help.

Thanks for your great work again.
 
Old 04-23-2008, 11:08 AM   #18
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,915
Blog Entries: 51

Rep: Reputation: Disabled
I can't remember seeing any instruction to chroot /mnt to run mkinitrd. According to the INITRD.readme it's cd /boot, which is what I did after the post-install reboot.

Last edited by brianL; 04-23-2008 at 11:09 AM.
 
Old 04-23-2008, 11:57 AM   #19
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,192

Rep: Reputation: Disabled
Quote:
Originally Posted by brianL View Post
I can't remember seeing any instruction to chroot /mnt to run mkinitrd. According to the INITRD.readme it's cd /boot, which is what I did after the post-install reboot.
Ah, yes, but after the post-install reboot, you are running Slackware itself and not the limited environment in the installer!

You followed the correct instructions shown in README.initrd. But these instructions do not apply while you are still in the installer stage before the reboot, unless you do the chroot thingie.

Eric
 
Old 04-23-2008, 01:05 PM   #20
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,915
Blog Entries: 51

Rep: Reputation: Disabled
Ah, yes, sorry, Eric. I was misinterpreting this in your previous post:

Quote:
Instead, you should do a "chroot /mnt" after Slackware's setup completes and then run mkinitrd in the 'chroot'.
I was taking it to mean post-install.
 
Old 04-24-2008, 02:28 AM   #21
unamed_user
LQ Newbie
 
Registered: Apr 2008
Location: China
Distribution: Slackware 12.0
Posts: 10

Rep: Reputation: 0
My problem is solved. As ChrisAbela said, I need to change from /dev/sdax to /dev/hdax in GRUB.

Thanks you, ChrisAbela and everyone else.
 
Old 05-04-2008, 03:15 PM   #22
UncleBark
LQ Newbie
 
Registered: May 2008
Location: Plantagenet, ON., Canada
Distribution: Slackware 14
Posts: 10

Rep: Reputation: 0
Question

Hello all,

I've run into the same problem. While trying to boot from GRUB I get this message:

Code:
VFS: Cannot open root device "sdc5" or unknown-block(o,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
I followed the code posted earlier in this thread to boot from my installation CD,
Code:
hugesmp.s root=/dev/sdc5 rdinit= ro
but I still stop at the same place.

Not sure what to do now.

I have Ubuntu 8, XP and Slackware 12, each on their own HDD and can boot the other 2 from GRUB with no problem.
 
Old 05-04-2008, 03:24 PM   #23
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,244

Rep: Reputation: 619Reputation: 619Reputation: 619Reputation: 619Reputation: 619Reputation: 619
If you can't even get into your system using the install CD, then either your root partition (/) is not located on /dev/sdc5 or your system is messed up and is totally unbootable (it's probably not the second one, but it's still a possibility). Try passing the "hda=noprobe" option to see if your drive is incorrectly being assigned /dev/hdx instead of /dev/sdx (assuming that your drive is actually an SATA drive and your SATA controller is supported by the kernel).
 
Old 05-04-2008, 04:06 PM   #24
UncleBark
LQ Newbie
 
Registered: May 2008
Location: Plantagenet, ON., Canada
Distribution: Slackware 14
Posts: 10

Rep: Reputation: 0
Slackware is on a SATA.
XP is on a PATA and Ubuntu is on a SATA and as I said those two boot fine.
I've had problems setting up SATA's on this mobo, it's old. I'm thinking of doing a clean re-install now that my system can actually see the SATA drives better. Had to do some work in BIOS just so the computer could boot into Ubuntu.

I've tried having it as a hdc instead but still no luck.

My mobo is a Foxxconn 761GXK8M....old, but it was all I could find for my AMD socket 939.....
 
Old 05-04-2008, 04:46 PM   #25
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,244

Rep: Reputation: 619Reputation: 619Reputation: 619Reputation: 619Reputation: 619Reputation: 619
If that's the case then it highly likely that the kernel has an option that is attempting to probe for IDE devices. Try passing "hda=noprobe" to see if it'll boot then. If not, you may want to recompile the kernel (assuming you can somehow get into your system) to remove a certain option. See this recent post by Franklin: http://www.linuxquestions.org/questi...65#post3142465
 
Old 05-04-2008, 10:45 PM   #26
UncleBark
LQ Newbie
 
Registered: May 2008
Location: Plantagenet, ON., Canada
Distribution: Slackware 14
Posts: 10

Rep: Reputation: 0
OK, found it. I discovered the root was on an entirely different partition. Everything went ahead normally.....for now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic-not syncing unable to mount the root file system on unknown block(0,0) cybersrin Linux - Hardware 2 08-14-2007 12:00 AM
Just upgraded to 2.6.19.2 - kernel panic enigma_0Z Linux - Kernel 8 02-01-2007 06:51 PM
Kernel Panic - Not Syncing VFS: unable to mount root file system push Slackware 8 08-28-2006 07:17 AM
kernel panic : Upgraded from 2.4.x to 2.6.17.6 slack_baby Linux - Kernel 15 07-25-2006 02:37 PM
kernel panic unable to mount root (yes ive read/read other posts) dmx9595 Linux - General 4 01-17-2004 05:07 AM


All times are GMT -5. The time now is 01:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration