LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Upgrade to -12.0 loses eth1 and wireless networking. (http://www.linuxquestions.org/questions/slackware-14/upgrade-to-12-0-loses-eth1-and-wireless-networking-593695/)

rshepard 10-22-2007 12:16 PM

Upgrade to -12.0 loses eth1 and wireless networking.
 
I have a Sony Vaio GCP-V505BC which came with Slackware installed in late 2003. The wireless card is a 3Com 3CRWE154GT2 that uses the prism54 driver. It worked flawlessly through -11.0. Now, however, the port eth1 is not recognized (eth0 is the wired connection and the wireless card has always been seen on eth1).

The error I get when trying 'ifconfig eth1 up' is: 'SIOCSIFFLAGS: no such file or directory' which tells me that the firmware cannot be found. The prism firmware, isl3890 is in /usr/lib/hotplug/firmware, and I put this path in /etc/hotplug/firmware.agent. But, it's not being seen, even if I restart /etc/rc.d/rc.hotplug.

Where should I place (or link) the firmware, isl3890, so that the kernel finds it and allows me to load eth1 and make wireless network connections?

Rich

evilDagmar 10-22-2007 01:23 PM

Quote:

Originally Posted by rshepard (Post 2932681)
I have a Sony Vaio GCP-V505BC which came with Slackware installed in late 2003. The wireless card is a 3Com 3CRWE154GT2 that uses the prism54 driver. It worked flawlessly through -11.0. Now, however, the port eth1 is not recognized (eth0 is the wired connection and the wireless card has always been seen on eth1).

The error I get when trying 'ifconfig eth1 up' is: 'SIOCSIFFLAGS: no such file or directory' which tells me that the firmware cannot be found. The prism firmware, isl3890 is in /usr/lib/hotplug/firmware, and I put this path in /etc/hotplug/firmware.agent. But, it's not being seen, even if I restart /etc/rc.d/rc.hotplug.

Where should I place (or link) the firmware, isl3890, so that the kernel finds it and allows me to load eth1 and make wireless network connections?

Rich

Reading directions helps quite a bit. The firmware doesn't go in that directory, it goes into /lib/firmware. Hotplug is obsolete so stop trying to invoke it manually.

rshepard 10-22-2007 01:44 PM

Er, I don't follow your complaint. The firmware is in /usr/lib/hotplug/firmware/. Where are you suggesting it should go? Since hotplug has been deprecated, why does -12.0 put the isl3890 firmware in the directory it does?

What directions have I not read?

Rich

rshepard 10-22-2007 01:48 PM

Quote:

Originally Posted by evilDagmar (Post 2932742)
Reading directions helps quite a bit. The firmware doesn't go in that directory, it goes into /lib/firmware. Hotplug is obsolete so stop trying to invoke it manually.

OK, I missed the /lib/firmware part because when I had looked in there I saw nothing similar. I copied isl3890 in there and the interface comes up.

Still don't know to what directions you referred, but that solved this problem.

Thank you,

Rich


All times are GMT -5. The time now is 03:58 PM.