LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2009, 07:21 AM   #1
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 89
Upgrade of shared-mime-info (-current): all icons missing?


Just upgraded the latest packages from -current and all my icons went missing.

I tried the normal 'update-mime-database' but it had no effect.
Finally I returned the 0.60 package from 13.0-stable and that gave me all my icons back.

Any idea?

I am using Xfce as a DE by the way...
 
Old 10-18-2009, 07:56 AM   #3
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Original Poster
Rep: Reputation: 89
Yes, I searched the forum before posting and tried the update-mime-database (although it is in the doinst.sh script in the package) but that did not solve anything, like I said in my original post.
 
Old 10-18-2009, 08:08 AM   #4
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Did you logout and relogin?
 
Old 10-18-2009, 08:21 AM   #5
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Original Poster
Rep: Reputation: 89
Quote:
Originally Posted by sahko View Post
Did you logout and relogin?
Yes, tried that as well...
Actually, I also logged out & in again after falling back to 0.60. Only then the icons came back.

I went back to 0.60 as I have some work to do, but I am updating a second machine now to do some tests there.

Last edited by niels.horn; 10-18-2009 at 08:22 AM.
 
Old 10-18-2009, 08:41 AM   #6
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Alien BOB made a blog entry about this:http://alien.slackbook.org/blog/gtk-...denly-missing/
FWIW using the two mentioned commands and reloging in worked for me.
 
Old 10-18-2009, 08:49 AM   #7
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 421

Rep: Reputation: 45
Thanks sahko and alienBOB! It works like a charm!

P.S. When I found problem using slackware I come to LQ for help and it always works! ;D
 
Old 10-18-2009, 09:02 AM   #8
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Original Poster
Rep: Reputation: 89
OK, I tried it on another -current (32-bits) box and the two lines:

Code:
# update-mime-database /usr/share/mime
(as root)

and

Code:
$ update-mime-database $HOME/.local/share/mime
(as normal user)

Brought my icons back

Just wonder why it did not work on this box (64-bits).
I'll try again later when I have some more time, but I'll consider the subject closed as this seems to be a very local problem on this particular box
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SWARET upgrade missing shared libraries libc.so.6 RLH1919 Slackware 5 04-04-2008 08:23 AM
No more icons in amarok after upgrade to current BSlack Slackware 3 07-31-2006 07:39 AM
Limited mime icons for Gnome jong357 Slackware 4 06-25-2006 12:45 PM
KDE 3.1 upgrade to 3.3.1 - missing icons? decavolt Suse/Novell 4 11-03-2004 12:51 PM
Missing icons in Gnome 2.6 After Upgrade to Current? Lucinda Slackware 4 05-29-2004 02:21 PM


All times are GMT -5. The time now is 03:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration