LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Upgrade glib2 in current? (http://www.linuxquestions.org/questions/slackware-14/upgrade-glib2-in-current-4175460987/)

marrowsuck 05-07-2013 04:11 AM

Upgrade glib2 in current?
 
A few programs I recently tried to compile depend on newer versions (>2.36).
glib-2.36.1 compiles just fine under current so I was wondering ...

tuxbg 05-08-2013 02:20 PM

Quote:

Originally Posted by marrowsuck (Post 4946453)
A few programs I recently tried to compile depend on newer versions (>2.36).
glib-2.36.1 compiles just fine under current so I was wondering ...

Which programs ?

gmgf 05-09-2013 08:13 AM

I agree with marrowsuck, it's probably a goo idea to upgrade glib2, gtk+3, pango, pixman, libgphoto2........................

marrowsuck 05-10-2013 05:06 AM

Quote:

Which programs ?
easystroke and webkit.
I understand that this is a critical update -- the ChangeLog mentions several incompatible changes.
I just went ahead and upgraded to 2.36.1. No problems so far. I report any errors.

ponce 05-10-2013 06:30 AM

just FYI, webkitgtk-1.10.2 works fine on -current.

volkerdi 05-10-2013 01:11 PM

I looked at easystroke and see no direct linkage to glib2 in there, although it uses a few libraries that would link to it.

While there's a very good change that the gtk+3 related libraries will see an update, I'm more hesitant to do the same on the gtk+2 side. That's the "stable" branch that a lot of thing depend upon, and it wasn't all that long ago that we updated those and endured a lot of breakage. I haven't yet looked to see what all the differences are, but given past experiences I would expect to see a lot of widely used functions deprecated or removed. I will do some research on it though and see what I can find out.

bartgymnast 05-13-2013 02:31 AM

rworkman has alot of slackbuild script for these packages if you people are intrested.

http://www.slackware.com/~rworkman/GTK3/

these include glib2, gtk+3, pango, etc.

marrowsuck 05-22-2013 03:27 AM

Quote:

Mon May 20 21:01:33 UTC 2013
[...]
l/glib2-2.36.2-x86_64-1.txz: Upgraded.
[...]
:-) -- Merci!


All times are GMT -5. The time now is 07:12 PM.