LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Upgrade 10.0 ---> 10.1 problem (http://www.linuxquestions.org/questions/slackware-14/upgrade-10-0-10-1-problem-328068/)

cragwolf 05-28-2005 05:13 PM

Upgrade 10.0 ---> 10.1 problem
 
After upgrading from Slackware 10.0 to 10.1, I have a problem. I get a warning messsage during startup saying that fschk (I think I may have spelled that wrong) will be slow because I do not have dma turned on. When I try a "hdparm -d 1 /dev/hda" I get:

Code:

setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)

A "hdparm -i /dev/hda" gives me:

Code:

/dev/hda:

 Model=WDC WD1200JD-00GBB0, FwRev=02.05D02, SerialNo=WD-WMAET2161714
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=74
 BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=234441648
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: device does not report version:

 * signifies the current active mode

And a "/sbin/lspci | grep -i ide" gives me:

Code:

00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
I'm using the standard kernel that comes with Slackware 10, v2.4.xx. I think it's 2.4.29.

It certainly is slow with dma turned off, particularly when the hard drive is busy. So how do I turn it on?

mdarby 05-28-2005 05:35 PM

Try this:
Code:

hdparm -X66 -d1 -u1 -m16 -c3 /dev/hda

cragwolf 05-28-2005 05:57 PM

Thanks, but no, that doesn't work either:

Code:

/dev/hda:
 setting 32-bit IO_support flag to 3
 setting multcount to 16
 setting unmaskirq to 1 (on)
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 setting xfermode to 66 (UltraDMA mode2)
 multcount    = 16 (on)
 IO_support  =  3 (32-bit w/sync)
 unmaskirq    =  1 (on)
 using_dma    =  0 (off)


gbonvehi 05-28-2005 06:31 PM

That usually happens when you don't have support for your chipset loaded. I don't know if can be solved by loading a module, I've always compiled support for my chipset directly into the kernel.
Are you sure you didn't upgrade the kernel or kernel modules too?

Shade 05-28-2005 06:31 PM

Are you using SATA or regular IDE discs?

You need to determine what chipset you have and are using, and load the module for it. Your 'Operation Not Permitted' error is because there is no support in the kernel.

--Shade


All times are GMT -5. The time now is 01:02 PM.