LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Updating xf86-video-intel for 2.6.29 kernel (http://www.linuxquestions.org/questions/slackware-14/updating-xf86-video-intel-for-2-6-29-kernel-722112/)

Romanus81 04-27-2009 08:21 PM

Updating xf86-video-intel for 2.6.29 kernel
 
I wanted to try the new kernel mode setting in the 2.6.29 kernel, I've built the kernel, but before I boot I need to get the new 2.6 version of the intel driver. The website ( http://www.x.org/wiki/IntelGraphicsDriver ) says that the newest intel driver, 2.6.2, requires xorg 1.6, and the slackware.org says that 12.2 runs 1.4.2. How big a headache am I looking at here? I figure all I would need is to download the slackbuilds off the source CD, and replace the two source packages, correct? Or is it a lot more complex than that?

sahko 04-27-2009 09:11 PM

What 2 source packages? If those 2 include xorg-server then no. That wont work. You have to update a large part of the xorg protos and libs.
Cant you just use an earlier than 2.6.2 version of the Intel driver with xorg-server-1.4.2?

Romanus81 04-28-2009 01:32 PM

The sources I was talking about was the xorg-server and xf86-video-intel sources, but I guess it might not be that complicated, the README in the updated video-intel source says it requires xorg 1.2.0 or newer. I'll try it out and see what happens.


All times are GMT -5. The time now is 11:09 PM.