LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-02-2013, 11:00 PM   #1
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Rep: Reputation: 23
Updating KDE from 4.8.5 to 4.10.3 killed sound


Updated Slackware 14_64 multilib32/64 libraries, Asus notebook from KDE 4 from 4.8.5 to 4.10.3 Following alienBob's blog.

Sound stopped working but otherwise everything seems fine. Logging into Kde gives the message:

'The audio playback device HDA Intel ALC663 analog does not work. Falling back to pulseaudio sound.'

Checked both alsamixer & KDE sound settings.

Any ideas would be appreciated.

#rsync -av --exclude=x86 rsync://alien.slackbook.org/alien/ktown/14.0/4.10.3 . --reinstall --install-new x86_64/deps/*.t?z

# upgradepkg --reinstall --install-new x86_64/deps/*.t?z
# upgradepkg --reinstall --install-new x86_64/kde/*.t?z
# removepkg kdegames
# removepkg kdemultimedia
# removepkg ksecrets
# removepkg printer-applet

Last edited by nick_th_fury; 06-02-2013 at 11:03 PM.
 
Old 06-03-2013, 05:01 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
Apparently you have pulseaudio installed. If that is on purpose and you are actually using pulseaudio, then you should probably reconfigure pulseaudio so that it works with ALSA and KDE.
If you installed pulseaudio just to be able to play Steam games, then you should be aware that that initial requirement is long gone, and you do not need to have pulseaudio installed for that nowadays.

Eric
 
Old 06-03-2013, 05:42 AM   #3
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Original Poster
Rep: Reputation: 23
Yes we only installed that for his steam client. If we remove pulse audio will KDE be fine then?
He just wants basic sound in that & his steam games. That makes sense to me now.

I tested the upgrade on my notebook first and it went perfect. The only difference between ours is I do not have Steam installed yet.
BTW, I really like the new KDE. Appreciate your making that available to us on Slack 14.
Trey
 
Old 06-03-2013, 08:30 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
You can remove pulseaudio if you only installed it for the steamclient. If you are using my steamclient package, then there is no other dependency except for the flashplayer-plugin in order to play movies in the Steam Store.
And if you are running 64-bit Slackware, you will need multilib.
See http://alien.slackbook.org/blog/surv...ming-on-steam/

Eric
 
1 members found this post helpful.
Old 06-03-2013, 11:33 AM   #5
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Original Poster
Rep: Reputation: 23
We have removed pulse audio. Unfortunately there is no sound in kde or xfce.
Which is odd as it was working perfectly before.
Here is a list of the alsa components we have installed. Is there anything we've done wrong for the multilib 64bit?

pkgtool shows:
alsa-lib-1.0.26-x86_64-1
alsa-lib--compat32-1.0.26-x
alsa-oss-1.0.25-x86_64-1
alsa-oss-compat32-1.0.25-x
alsa-plugins-1.0.26-x86_64
alsa-utils-1.0.26-x86_64-1
 
Old 06-03-2013, 03:11 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
Try removing or renaming /var/lib/alsa/asound.state and reboot the machine. Slackware will reconfigure ALSA for a default sound state.
Then check KDE's sound configuration and otherwise check alsamixer (console program) for issues with muted channels.

There may also be something you configured yourself in either /etc/asound.conf or ~/.asoundrc which you have forgotten about.

Eric
 
1 members found this post helpful.
Old 06-04-2013, 02:19 AM   #7
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Original Poster
Rep: Reputation: 23
Removing Pulse audio & setting Alsa back to defaults fixed it.
KDE 4.10.3 is running like a champ on both our notebooks.
Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] I've killed KDE again bgeddy Slackware 3 04-29-2011 12:20 AM
Help - I've killed KDE !! bgeddy Slackware 5 10-05-2006 11:32 PM
KDE killed sound on i845 Mthr Brd knitin Fedora 5 12-29-2004 01:07 AM
What Did I Do To Kde!!!! I Think I Killed It :-( Sherpa Linux - Newbie 2 05-19-2004 08:02 AM
Sound killed itself. BongFish Linux - General 5 08-09-2003 01:24 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration