LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Updating Alien's multilib packages with slapt-get ? (http://www.linuxquestions.org/questions/slackware-14/updating-aliens-multilib-packages-with-slapt-get-4175460439/)

torimus 05-02-2013 09:07 AM

Updating Alien's multilib packages with slapt-get ?
 
Hi,

I'm wondering what am I doing wrong if trying to install/update packages from Alien's repository at http://slackware.com/~alien/multilib/current .

In /etc/slapt-get/slapt-getrc there is the following record:
Code:

# Alien's Multilib packages for Slackware64
SOURCE=http://slackware.com/~alien/multilib/current/:DEFAULT

Running slapt-get -u went ok:
Code:

Retrieving package data [http://slackware.com/~alien/multilib/current/]...Cached
Retrieving patch list [http://slackware.com/~alien/multilib/current/]...Done
Retrieving checksum list [http://slackware.com/~alien/multilib/current/]...Cached
Retrieving checksum signature [http://slackware.com/~alien/multilib/current/]...Cached
Verifying checksum signature [http://slackware.com/~alien/multilib/current/]...Verified
Retrieving ChangeLog.txt [http://slackware.com/~alien/multilib/current/]...Done
Reading Package Lists...Done

Now, if I want to fetch/install some package, slapt-get aborts with the following unspecific error:

Code:

# slapt-get -i glib2-compat32
Reading Package Lists...Done
The following packages will be installed:
  glib2-compat32
0 upgraded, 0 reinstalled, 1 newly installed, 0 to remove, 0 not upgraded.
Need to get 972.0kB of archives.
After unpacking 3.7MB of additional disk space will be used.
Do you want to continue? [y/N] y
1/1 Get http://connie.slackware.com/~alien/multilib/ glib2-compat32
2.34.3-x86_64-1compat32 [972.0kB]...Failed to download: HTTP response code said error

Packages from other repositories can be installed without any issues.

Alien Bob 05-02-2013 03:42 PM

You may be hitting a bandwidth issue there.
It is considered bad manners to use the slackware.com web server (http://connie.slackware.com/) as the source for your package downloads. It is much more polite to use a mirror instead, like:
http://taper.alienbase.nl/mirrors/pe...tilib/current/
Don't let the ".nl" domain fool you, this is a mirror server hosted in a US datacenter.
Or else, use http://www.slackware.org.uk/people/a...tilib/current/ which is a very fast UK mirror server.

Eric

trnh 05-02-2013 04:47 PM

I believe this is because the PACKAGES.TXT file in the multilib repo contains this extra bit
which causes slapt-get to append that to the PACKAGE LOCATION. Maybe it should have not been there at all, which is what PACKAGES.TXT in the main source tree looks like.

To work around this, I rsync the whole directory to my local slapt-get repo and then rebuild the metadata using http://software.jaos.org/git/slapt-g....html#slgFAQ17.

HTH

torimus 05-02-2013 05:11 PM

Quote:

Originally Posted by trnh (Post 4943668)
I believe this is because the PACKAGES.TXT file in the multilib repo contains this extra bit


which causes slapt-get to append that to the PACKAGE LOCATION. Maybe it should have not been there at all, which is what PACKAGES.TXT in the main source tree looks like.

To work around this, I rsync the whole directory to my local slapt-get repo and then rebuild the metadata using http://software.jaos.org/git/slapt-g....html#slgFAQ17.

HTH

Great, I think this is the source of the issue. I can manually download packages with lftp, wget or other clients from the same server.
Maybe I have to send a notice to Eric about that.

Alien Bob 05-03-2013 04:14 PM

Then report that as a bug in slapt-get please, I am not going to fix anything.

I added "PACKAGE MIRROR" because of slapt-get. See http://software.jaos.org/git/slapt-get/plain/FAQ.html

Eric

torimus 05-05-2013 06:04 AM

Quote:

Originally Posted by Alien Bob (Post 4944404)
Then report that as a bug in slapt-get please, I am not going to fix anything.

I added "PACKAGE MIRROR" because of slapt-get. See http://software.jaos.org/git/slapt-get/plain/FAQ.html

Eric

Hi,

you are correct, there is no issue with PACKAGE_MIRROR field. However there is a problem in PACKAGE_LOCATION, as in your repo PACKAGES.TXT it miss the leading path at every package record.

For example for repo on http://connie.slackware.com/~alien/multilib/current the location record for compat32-tools-3.0-noarch-8alien.tgz should look like
Code:

PACKAGE LOCATION:  ./current
.
Check the stock Slackware repos if you do not believe it.

schmatzler 05-05-2013 05:41 PM

Just remove the "current" from your slapt-getrc and it works:

Code:

SOURCE=http://connie.slackware.com/~alien/multilib/:CUSTOM
Fetches multilib automatically here.

Alien Bob 05-06-2013 07:14 AM

Quote:

Originally Posted by torimus (Post 4945254)
For example for repo on http://connie.slackware.com/~alien/multilib/current the location record for compat32-tools-3.0-noarch-8alien.tgz should look like
Code:

PACKAGE LOCATION:  ./current
.
Check the stock Slackware repos if you do not believe it.

Of course not.
For repo http://connie.slackware.com/~alien/multilib/current/ ,the package location of compat32-tools-3.0-noarch-8alien.tgz is
Code:

PACKAGE LOCATION:  .
(note the dot) exactly like it is written in slackware.com/~alien/multilib/current/PACKAGES.TXT


Eric


All times are GMT -5. The time now is 10:39 AM.