LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-02-2013, 10:07 AM   #1
torimus
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 81

Rep: Reputation: Disabled
Updating Alien's multilib packages with slapt-get ?


Hi,

I'm wondering what am I doing wrong if trying to install/update packages from Alien's repository at http://slackware.com/~alien/multilib/current .

In /etc/slapt-get/slapt-getrc there is the following record:
Code:
# Alien's Multilib packages for Slackware64
SOURCE=http://slackware.com/~alien/multilib/current/:DEFAULT
Running slapt-get -u went ok:
Code:
Retrieving package data [http://slackware.com/~alien/multilib/current/]...Cached
Retrieving patch list [http://slackware.com/~alien/multilib/current/]...Done
Retrieving checksum list [http://slackware.com/~alien/multilib/current/]...Cached
Retrieving checksum signature [http://slackware.com/~alien/multilib/current/]...Cached
Verifying checksum signature [http://slackware.com/~alien/multilib/current/]...Verified
Retrieving ChangeLog.txt [http://slackware.com/~alien/multilib/current/]...Done
Reading Package Lists...Done
Now, if I want to fetch/install some package, slapt-get aborts with the following unspecific error:

Code:
# slapt-get -i glib2-compat32
Reading Package Lists...Done
The following packages will be installed:
  glib2-compat32
0 upgraded, 0 reinstalled, 1 newly installed, 0 to remove, 0 not upgraded.
Need to get 972.0kB of archives.
After unpacking 3.7MB of additional disk space will be used.
Do you want to continue? [y/N] y
1/1 Get http://connie.slackware.com/~alien/multilib/ glib2-compat32
2.34.3-x86_64-1compat32 [972.0kB]...Failed to download: HTTP response code said error
Packages from other repositories can be installed without any issues.
 
Old 05-02-2013, 04:42 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,395

Rep: Reputation: Disabled
You may be hitting a bandwidth issue there.
It is considered bad manners to use the slackware.com web server (http://connie.slackware.com/) as the source for your package downloads. It is much more polite to use a mirror instead, like:
http://taper.alienbase.nl/mirrors/pe...tilib/current/
Don't let the ".nl" domain fool you, this is a mirror server hosted in a US datacenter.
Or else, use http://www.slackware.org.uk/people/a...tilib/current/ which is a very fast UK mirror server.

Eric
 
1 members found this post helpful.
Old 05-02-2013, 05:47 PM   #3
trnh
LQ Newbie
 
Registered: Apr 2013
Posts: 2

Rep: Reputation: Disabled
I believe this is because the PACKAGES.TXT file in the multilib repo contains this extra bit
which causes slapt-get to append that to the PACKAGE LOCATION. Maybe it should have not been there at all, which is what PACKAGES.TXT in the main source tree looks like.

To work around this, I rsync the whole directory to my local slapt-get repo and then rebuild the metadata using http://software.jaos.org/git/slapt-g....html#slgFAQ17.

HTH
 
1 members found this post helpful.
Old 05-02-2013, 06:11 PM   #4
torimus
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by trnh View Post
I believe this is because the PACKAGES.TXT file in the multilib repo contains this extra bit


which causes slapt-get to append that to the PACKAGE LOCATION. Maybe it should have not been there at all, which is what PACKAGES.TXT in the main source tree looks like.

To work around this, I rsync the whole directory to my local slapt-get repo and then rebuild the metadata using http://software.jaos.org/git/slapt-g....html#slgFAQ17.

HTH
Great, I think this is the source of the issue. I can manually download packages with lftp, wget or other clients from the same server.
Maybe I have to send a notice to Eric about that.
 
Old 05-03-2013, 05:14 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,395

Rep: Reputation: Disabled
Then report that as a bug in slapt-get please, I am not going to fix anything.

I added "PACKAGE MIRROR" because of slapt-get. See http://software.jaos.org/git/slapt-get/plain/FAQ.html

Eric
 
Old 05-05-2013, 07:04 AM   #6
torimus
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 81

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Then report that as a bug in slapt-get please, I am not going to fix anything.

I added "PACKAGE MIRROR" because of slapt-get. See http://software.jaos.org/git/slapt-get/plain/FAQ.html

Eric
Hi,

you are correct, there is no issue with PACKAGE_MIRROR field. However there is a problem in PACKAGE_LOCATION, as in your repo PACKAGES.TXT it miss the leading path at every package record.

For example for repo on http://connie.slackware.com/~alien/multilib/current the location record for compat32-tools-3.0-noarch-8alien.tgz should look like
Code:
PACKAGE LOCATION:  ./current
.
Check the stock Slackware repos if you do not believe it.
 
Old 05-05-2013, 06:41 PM   #7
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 218

Rep: Reputation: 65
Just remove the "current" from your slapt-getrc and it works:

Code:
SOURCE=http://connie.slackware.com/~alien/multilib/:CUSTOM
Fetches multilib automatically here.
 
Old 05-06-2013, 08:14 AM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,395

Rep: Reputation: Disabled
Quote:
Originally Posted by torimus View Post
For example for repo on http://connie.slackware.com/~alien/multilib/current the location record for compat32-tools-3.0-noarch-8alien.tgz should look like
Code:
PACKAGE LOCATION:  ./current
.
Check the stock Slackware repos if you do not believe it.
Of course not.
For repo http://connie.slackware.com/~alien/multilib/current/ ,the package location of compat32-tools-3.0-noarch-8alien.tgz is
Code:
PACKAGE LOCATION:  .
(note the dot) exactly like it is written in slackware.com/~alien/multilib/current/PACKAGES.TXT


Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] After updating to Alien's Kde 4.7, slackpgk install-new shows old packages... disco_slack Slackware 4 09-05-2011 02:30 PM
[SOLVED] Error compiling compiz plugins with Alien Bob's multilib packages installed Daedra Slackware 5 07-25-2011 06:54 AM
Multilib current alien issue mmpl Slackware 4 03-05-2011 04:22 AM
New multilib glibc packages. - security fix from Alien. Martinezio Slackware 8 10-25-2010 11:40 AM
[SOLVED] Slackware 13 64 - Alien Bob's multilib and Wine gezley Slackware 20 05-14-2010 12:04 PM


All times are GMT -5. The time now is 02:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration