LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-30-2006, 07:47 AM   #1
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 36
Updated Slack 10.2 and it broke :(


Okay, I did the forbidden and issued "slapt-get --dist-upgrade"

Now when I tried to compile Pure-FTP from source it complains that it doesn't find gcc.
Well, I installed the gcc with slapt-get and now I get the following:
Code:
root@slackbox:/paketit/pure-ftpd-1.0.21# ./configure
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking for ranlib... ranlib
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... none
checking dependency style of gcc... none
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
root@slackbox:/paketit/pure-ftpd-1.0.21
Any idea how to fix the system? I like the gentoo better as it can be updated easily but it's so slow to get up and running on a older PC like my going-to-be-server PC
 
Old 03-30-2006, 09:17 AM   #2
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 411

Rep: Reputation: 39
You've probably forgot to instal g++ .
 
Old 03-30-2006, 10:29 AM   #3
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
I tried downloading source tarball from here

put can't get it installed. When running ./configure in just states:
Code:
root@slackbox:/paketit/gcc-4.0.2/libstdc++-v3# ./configure
configure: error: cannot find install-sh or install.sh in . ./.. ./../..
root@slackbox:/paketit/gcc-4.0.2/libstdc++-v3#
Was that the right package and how to get it installed?
 
Old 03-30-2006, 10:38 AM   #4
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
It would be easier to install the official slackware package:

ftp://ftp.slackware.com/pub/slackwar...3.6-i486-1.tgz
 
Old 03-30-2006, 10:41 AM   #5
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
The Slackware package browser, search for gcc

http://slackware.it/en/pb/
 
Old 03-30-2006, 12:30 PM   #6
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Okay, I downloaded the gcc and g++ packages and installed them but still get the following
Code:
root@slackbox:/paketit# cd pure-ftpd-1.0.21
root@slackbox:/paketit/pure-ftpd-1.0.21# ./configure
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking for ranlib... ranlib
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... none
checking dependency style of gcc... none
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
root@slackbox:/paketit/pure-ftpd-1.0.21#
 
Old 03-30-2006, 12:36 PM   #7
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
You need to reinstall glibc.
http://slackware.it/en/pb/package.ph...c-2.3.6-i486-2
 
Old 03-30-2006, 02:38 PM   #8
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 411

Rep: Reputation: 39
And I would add you have to read config.log if not sure what's the problem. Failed configure script suggested it to you.
 
Old 03-30-2006, 03:13 PM   #9
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Yeah, I read it. Said pretty much the same as the above posts but I'll look it again after I get to test re-installing glibc.

Last edited by Zmyrgel; 03-30-2006 at 03:18 PM.
 
Old 04-01-2006, 06:09 AM   #10
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Okay, I did the following after the above didn't work. I reinstalled Slack on clear partition. I blacklisted kernel-things in slackpkg and uncommented a slackware current mirror and installed samba using it. Then I upgraded my apache, irssi and java using Slackpkg. Now when I downloaded newest kernel from kernel.org and tried to compile it just stated that I didn't have "make". Probably due I 'smartly' left programming tools uninstalled during my slackware installation. Now I installed make using slackpkg. Then I tried to run 'make mrproper' but it stated I was missing gcc. Well, no suprise if make was missing so I installed that too with slackpkg. I installed the support for c++, java and such but now when I tried to issue "make menuconfig" I get following:

Code:
root@slackbox:/usr/src/linux# make menuconfig
  HOSTCC  scripts/basic/fixdep
In file included from /usr/include/bits/posix1_lim.h:153,
                 from /usr/include/limits.h:144,
                 from /usr/lib/gcc/i486-slackware-linux/3.4.6/include/limits.h:122,
                 from /usr/lib/gcc/i486-slackware-linux/3.4.6/include/syslimits.h:7,
                 from /usr/lib/gcc/i486-slackware-linux/3.4.6/include/limits.h:11,
                 from scripts/basic/fixdep.c:113:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
In file included from /usr/include/sys/socket.h:35,
                 from /usr/include/netinet/in.h:24,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:115:
/usr/include/bits/socket.h:304:24: asm/socket.h: No such file or directory
scripts/basic/fixdep.c: In function `use_config':
scripts/basic/fixdep.c:214: error: `PATH_MAX' undeclared (first use in this function)
scripts/basic/fixdep.c:214: error: (Each undeclared identifier is reported only once
scripts/basic/fixdep.c:214: error: for each function it appears in.)
scripts/basic/fixdep.c:214: warning: unused variable `s'
scripts/basic/fixdep.c: In function `parse_dep_file':
scripts/basic/fixdep.c:310: error: `PATH_MAX' undeclared (first use in this function)
scripts/basic/fixdep.c:310: warning: unused variable `s'
make[1]: *** [scripts/basic/fixdep] Error 1
make: *** [scripts_basic] Error 2
root@slackbox:/usr/src/linux#
 
Old 04-01-2006, 06:20 AM   #11
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Do you have ncurses installed?
 
Old 04-01-2006, 06:57 AM   #12
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Yes, Ncurses 5.4 appaerantly.

I try to upgrade it to 5.5 to see if it helps.

Edit: nope, It did not help at all

Last edited by Zmyrgel; 04-01-2006 at 07:28 AM.
 
Old 04-01-2006, 08:01 AM   #13
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
I don't really know but try to reinstall/upgrade binutils.
 
Old 04-01-2006, 08:11 AM   #14
danieldk
Member
 
Registered: Aug 2002
Posts: 150

Rep: Reputation: 15
Install "kernel-headers" (the 2.4 version) from d/, and make sure that "glibc" from l/ is installed. "ncurses" is also required for menuconfig.
 
Old 04-01-2006, 09:45 AM   #15
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
To reinstall a package just do
Code:
upgradepkg --reinstall name-of-the-package.tgz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated to Gnome 2.12 broke login script kellinjar Linux - Software 2 01-15-2006 08:54 PM
keep slack 10 updated with wget? mipia Slackware 8 10-13-2004 05:01 PM
Just how long are old versions of Slack updated? slackMeUp Slackware 3 09-17-2004 05:32 AM
Keeping slack updated Werpon Slackware 5 03-09-2004 01:18 PM
I think I broke my slack nemat0de Slackware 5 06-26-2003 08:33 AM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration