LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-10-2011, 02:54 PM   #1
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,019

Rep: Reputation: 157Reputation: 157
update to current, rtorrent throws error, won't start


32 bit current

Code:
mrclisdue@laptop:~$ rtorrent
rtorrent: print_download_info(...) wrote past end of the buffer.
googling the error returns patch & diff stuff dating from '06 until '10, but doesn't offer much in help to me.

I dl'd the latest rtorrent/libtorrent from svn, but neither would build - I can post the errors if someone believes them to be pertinent.

cheers,
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 03-10-2011, 03:07 PM   #2
Darth Vader
Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 553

Rep: Reputation: 103Reputation: 103
Looks right as an NX buffer-overflow denial action from a PAE/NX kernel.

Then, in your app is a BIG BUG, which allow the buffer-overflows and kernel killed it. Blame the rtorrent developers for crappy code.

BTW, we have NX active by default, now? Why not PAE too?
 
0 members found this post helpful.
Old 03-10-2011, 03:48 PM   #3
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 641

Rep: Reputation: 90
This error has been mentioned in the rtorrent bugtracker and certainly on my system (slackware current with the recent upgrade to ncurses 5.8) the suggested patch kick-started rtorrent 0.8.6 well enough... The maintainer for SBo might be interested to pick up this patch as well I suspect.
 
3 members found this post helpful.
Old 03-10-2011, 04:36 PM   #4
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,019

Original Poster
Rep: Reputation: 157Reputation: 157
Thank you, andrew.46; I applied the patch to the 0.8.7 tarball and it installed and runs perfectly (I'm not concerned about the svn not compiling...)

cheers,
 
Old 03-11-2011, 08:14 AM   #5
diwljina
Member
 
Registered: Jun 2009
Distribution: Slackware
Posts: 104

Rep: Reputation: 7
Thanks Andrew, this helped me too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After moving mysql db to NFS[netapp] unable to start mysql server throws error naveenrajn Linux - General 3 09-13-2010 02:20 AM
[SOLVED] start KDE error after update to -current but interrupted by electricity problem ! el_jauzaa Slackware 2 09-13-2010 12:43 AM
screen & rtorrent init.d start imagineaxion Ubuntu 8 04-19-2008 01:32 PM
Slackware current--imagemagick won`t work. AlanL Slackware 1 05-09-2006 12:46 AM
Current-Update:'libart_lgpl' causing X to not start BearClaw Slackware 1 09-11-2003 02:12 AM


All times are GMT -5. The time now is 10:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration