LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Unwanted apps starting when logging into KDE (http://www.linuxquestions.org/questions/slackware-14/unwanted-apps-starting-when-logging-into-kde-781067/)

pimy 01-09-2010 10:46 AM

Unwanted apps starting when logging into KDE
 
KDE 3.5.4
Kernel 2.6.17.13
Slack 11

A few weeks ago, my system locked up and I had to do a hard reboot (hold down power button). When I powered back on, the programs (KDE System Guard, Konsole window, MythFrontEnd) that were running at the time of the lockup appeared again. I exited System Guard and the Konsole window and then restarted normally. However, they keep appearing in the same spot when I log in to KDE. I looked through some logs in /var/log, but I don't see anything I haven't seen before.

I deleted the /home/myuser/.kde/cache-hostname folder and its contents while in single-user mode, but that had no impact.

Help please.

Thanks,
pimy

Drakeo 01-09-2010 11:32 AM

check your /tmp file most likely the program running cache was never deleted when the system went down. so when you restart it reads the /tmp file for this . delete what ever you want in tmp EXCEPT! any hidden files.
this should fix the problem if not. in your /home/your_user/ ./kde folder check the auto start. but I am pretty shure it is your tmp. also in kde 3 you may have to when logging out check the save as is now. because when you forced a power down kde kept the running settings.
It looks to the /tmp cache to see what was running last.

last resort caveman style as root delete that users ./kde folder and then log in as the user. it will reconfigure the kdedesktop .or just rename the .kde folder to .kde.old

amani 01-09-2010 12:17 PM

auto start is in settings --> advanced (kde-4.xx)

Woodsman 01-09-2010 02:04 PM

Sounds as though you have saving sessions enabled. Open KControl, then proceed to KDE Components, then to Session Manager. In the In Login section select the Start with an empty session button. Save the settings and then restart KDE.

pimy 01-09-2010 10:20 PM

Thank you all for the feedback. Woodsman, your instructions worked. All is well again.

WSmart 04-01-2012 12:50 AM

It's the little things in Linux
 
Also helped me find this on 4.4.5 KDE, in the system settings gui, session manager. Giving you a point on that Woodsman.

Thanks all. Be real, be sober.


All times are GMT -5. The time now is 01:32 PM.