LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2005, 12:49 PM   #1
Urkburk
LQ Newbie
 
Registered: Mar 2005
Location: Sweden
Distribution: Slackware 10.1
Posts: 11

Rep: Reputation: 0
unload ub-module at boot?


Hi!

I am having a bit of a problem unloading the module called "ub" at boot.. I tried to add
"modprobe -r ub" in my /etc/rc.d/rc.modules-file.. but it's still there when I boot next time!!

Where can I change so that my ub-module don't get loaded at boot?
 
Old 03-24-2005, 01:15 PM   #2
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
The best way is to disable it in your kernel config and re-compile the kernel. Matter of fact, I THINK that's the only way to keep it from loading. I might be incorrect, as I disable the infernal thing when customizing my kernel config, and have never had to try to "unload" it. Have you tried just deleting the ub module from the /lib/modules/kernel number directory. Sorry but I'm not sure which directory it's in, maybe /lib/modules/kernel number/kernel/drivers/block .

Be warned, I've never done that, so I'm not sure what other "can of worms" it could open.

HTH,
MMYoung
 
Old 03-24-2005, 01:16 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Add it to /etc/hotplug/blacklist.
 
Old 03-24-2005, 01:29 PM   #4
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
Quote:
Originally posted by gbonvehi
Add it to /etc/hotplug/blacklist.
I thought about that but I noticed that usbcore is blacklisted as well because it is "called implicitly". So I wasn't sure if that might be the case with ub as well.

Later,
MMYoung
 
Old 03-24-2005, 01:31 PM   #5
Urkburk
LQ Newbie
 
Registered: Mar 2005
Location: Sweden
Distribution: Slackware 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by gbonvehi
Add it to /etc/hotplug/blacklist.
thanks alot! I'll try that one!
 
Old 03-24-2005, 01:42 PM   #6
Urkburk
LQ Newbie
 
Registered: Mar 2005
Location: Sweden
Distribution: Slackware 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
Code:
T:  Bus=03 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0dda ProdID=0102 Rev=52.7d
S:  Manufacturer=ICSI_1
S:  Product=1.1 Card Reader
S:  SerialNumber=001100024141
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
...this is what I get while reading my /proc/bus/usb/devices.... notice the "Driver=(none)" <-- it was before "Driver=ub"...
I want it to become "Driver=usb-storage"....

anyone had the same problem?

I am following this guide to get my 9in1 USB memory card reader to work:
http://www.cs.sfu.ca/~ggbaker/personal/cf-linux
I have all of the modules loaded as required...
 
Old 03-24-2005, 01:45 PM   #7
Urkburk
LQ Newbie
 
Registered: Mar 2005
Location: Sweden
Distribution: Slackware 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by MMYoung
The best way is to disable it in your kernel config and re-compile the kernel. Matter of fact, I THINK that's the only way to keep it from loading. I might be incorrect, as I disable the infernal thing when customizing my kernel config, and have never had to try to "unload" it. Have you tried just deleting the ub module from the /lib/modules/kernel number directory. Sorry but I'm not sure which directory it's in, maybe /lib/modules/kernel number/kernel/drivers/block .

Be warned, I've never done that, so I'm not sure what other "can of worms" it could open.

HTH,
MMYoung
What is the name of the module? I only know it as "ub"... what's the "long name", so I know what to deselect when I recompile my kernel?
 
Old 03-24-2005, 04:14 PM   #8
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
It's under "Block Devices" and the config option is CONFIG_BLK_DEV_UB.

EDIT
I was going to suggest that you select the PROBE_ALL_SCSI_LUNS as well but I noticed in your link that it was already suggested.
/EDIT

HTH,
MMYoung

Last edited by MMYoung; 03-24-2005 at 04:17 PM.
 
Old 03-24-2005, 06:14 PM   #9
Urkburk
LQ Newbie
 
Registered: Mar 2005
Location: Sweden
Distribution: Slackware 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by MMYoung
It's under "Block Devices" and the config option is CONFIG_BLK_DEV_UB.

EDIT
I was going to suggest that you select the PROBE_ALL_SCSI_LUNS as well but I noticed in your link that it was already suggested.
/EDIT

HTH,
MMYoung
Thank you, I solved the problem
 
Old 03-24-2005, 06:39 PM   #10
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
Quote:
Originally posted by Urkburk
Thank you, I solved the problem
How did you solve the problem? Did you have to re-compile the kernel, or what?

Thanks for the info,
MMYoung
 
Old 03-25-2005, 05:35 AM   #11
Urkburk
LQ Newbie
 
Registered: Mar 2005
Location: Sweden
Distribution: Slackware 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by MMYoung
How did you solve the problem? Did you have to re-compile the kernel, or what?

Thanks for the info,
MMYoung
If I tell you... I will have to kill you....

No, I solved it temporarily, by using the ub-module instead.. it worked the way I wanted it to work anyways

Next time I will recompile the kernel, I'll try to disable that module!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to unload kernel module dynamically kushneeraj Programming 1 10-26-2005 11:46 PM
Unload a module without rebooting? Phaethar Linux - Software 4 04-27-2005 12:42 PM
How can i force unload a module that is busy Doomhammer Linux - Software 1 03-23-2005 01:25 PM
What module would I unload to disable pcmcia? elempoimen Linux - Laptop and Netbook 10 12-22-2004 09:51 AM
Unload module to swap drives? RandomLinuxNewb Linux - Hardware 3 10-04-2004 07:25 PM


All times are GMT -5. The time now is 01:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration