LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-26-2003, 03:41 AM   #1
anadyr
Member
 
Registered: Mar 2003
Distribution: archlinux
Posts: 40

Rep: Reputation: 15
HELP! unicode characters don.t work!


hello people,
I have a problem here...

I don.t seem to have Unicode Support (I need to see Arabic characters in Mozilla) but instead of characters I get this: (not sure if you can see it)

الأه

I installed slackware 9 from the iso on an empty HD. Before that I used slackware 8.1 and I didn.t have any problems... Could someone tell me what I have to install or configure?

thanks!
rogier

Last edited by anadyr; 03-26-2003 at 09:43 AM.
 
Old 03-27-2003, 08:25 AM   #2
anadyr
Member
 
Registered: Mar 2003
Distribution: archlinux
Posts: 40

Original Poster
Rep: Reputation: 15
could someone please help me, because this is very important for my study!

I have absolutely no idea what is going on... it seems that unicode doesn.t work at all on my system. even tho I run the latest version of glibc... I do have correct fonts to display arabic, but they just don.t show up, neither in OpenOffice, nor in Mozilla...

on this test page:
http://www.muth.org/Robert/unicode.html
I can only see the first 1.5 blocks... the rest is unreadable (strange squares sort of)

I didn.t have any problems with this in slackware 8.1... I downloaded libunicode, but that didn.t help either...

I have set the
$LC_ALL=POSIX
running slackware without kde or gnome...

I hope someone knows the answer, because this is really important...

thanks
rogier
 
Old 03-27-2003, 12:26 PM   #3
anadyr
Member
 
Registered: Mar 2003
Distribution: archlinux
Posts: 40

Original Poster
Rep: Reputation: 15
well, it seems that Mozilla is very poorly compiled in the slackware package, I replaced it with another pre-compiled version 1.3 from the homepage, and that one runs fine... every single weird character is displayed properly, and it looks even better as well (theanti-aliased font in the slackware package is pretty ugly)

I still have the problem with OpenOffice, but I am sure I can figure that one out...
 
Old 03-27-2003, 12:53 PM   #4
otbibb
Member
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 33

Rep: Reputation: 15
I'm glad you fixed your mozilla problem. I've heard all kinds of problems with the stock mozilla in Slack 9.

My question is about your Arabic. Do you ever use Arabic in word processing? I do academic writing that requires english, hebrew and transliteration, and have struggled to get everything working right. OpenOffice doesn't support right-to-left entry, I don't think. I've been learning about Latex and Lyx, but font issues and dealing with the packages necessary to do this is quite complex.

Just wondering...
 
Old 03-28-2003, 08:52 AM   #5
anadyr
Member
 
Registered: Mar 2003
Distribution: archlinux
Posts: 40

Original Poster
Rep: Reputation: 15
hmm, I was working on this paper I made, in OpenOffice, but I only used transcription, not actual arabic characters... but then I couldn.t view arabic websites either, and I thought it was a unicode problem or something.

I tried to get arabic texts in OO, but it didn.t work no... I do seem to have fonts, because I can get like, all transcriptions in Mozilla now. Maybe it requires a recompile of OpenOffice (oh noo...)

Otbibb, this seems a very interesting site... I will work on this now...
http://www.mail-archive.com/hebrew@o.../msg00002.html
and you can check this site: http://openoffice.org.il

Last edited by anadyr; 03-28-2003 at 09:03 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unicode(UTF8) support in linux shell uiqbal Linux - General 0 10-20-2005 03:21 AM
Hard to install unicode support? newlinuxnewbie Linux - General 5 10-12-2005 11:12 PM
How do I configure/enable Unicode on Slackware 10 nosaku Slackware 1 12-16-2004 04:33 AM
How to detect non ascii filenames from an application which doesn't support UNICODE pankajtakawale Solaris / OpenSolaris 0 02-05-2004 06:31 AM
How to detect non ascii filenames from an application which doesn't support UNICODE ( pankajtakawale Solaris / OpenSolaris 0 02-05-2004 06:28 AM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration