LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-07-2006, 10:34 PM   #1
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Uneven bold fonts in Firefox


I am having some trouble with my fonts in Firefox. For some reason, bold fonts end up uneven on top. I'm not sure how else to describe it so here is a link to a picture:

http://www.ilstu.edu/~pjdraud/fonts.png

As you can see, the links in bold are not displaying correctly. How can I fix this?
 
Old 11-08-2006, 06:45 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Try uselpa's Beautiful Linux tutorial.

Here's a screenshot to what my fonts look like on that page you shot.
 
Old 11-08-2006, 10:37 AM   #3
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
I know my fonts themselves look fine, it's just the way Mozilla handles them.

This is the same page in Konqueror:

http://www.ilstu.edu/~pjdraud/fonts-good.png
 
Old 11-08-2006, 03:57 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
They don't look so good to me in either screenshot, but whatever you like.

You also don't list which Firefox you're running, or Slackware version.

Compare the fonts selection in both browsers to see what's different.
 
Old 11-08-2006, 04:52 PM   #5
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Well, your fonts don't look good to me! Like you said, it's preference

Anyway. Look at the links to the sub-forums in both pictures. In the Firefox picture, the text looks like "LinuXQueStiOnS.Org Member SucceSS StOrieS". In the Konqueror picture it looks fine.

I'm using Slackware 11 with Firefox 1.5.0.7.
 
Old 11-08-2006, 05:36 PM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
By default the Slackware fonts look bad to me. Therefore,
before doing anything else I setup my fonts very similar
to the Beautiful Linux link I gave you. On the next Slack
install I'll check before fixing the fonts. Do you use a LCD
or CRT monitor? Did you compare the fonts used in those
two browsers?
 
Old 11-08-2006, 07:58 PM   #7
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 924

Rep: Reputation: 94
Does Konqueror work well with the same fonts, is it using another one? We need to find out whether it's an X/font problem or Firefox problem.

You can try updating to FF 2.0, just download it from the patches/ directory of the 11.0 tree.
 
Old 02-06-2007, 04:50 PM   #8
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by Ilgar
Does Konqueror work well with the same fonts, is it using another one? We need to find out whether it's an X/font problem or Firefox problem.

You can try updating to FF 2.0, just download it from the patches/ directory of the 11.0 tree.
Sorry for the long delay, I kind of forgot about this thread. Yes, it's only Firefox. All other X apps work fine.
 
Old 02-08-2007, 04:52 AM   #9
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
How did you forget about this thread? You started it, you should be automatically subscribed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Konsole showing regular and bold fonts as the same mcpchandra Fedora 0 09-13-2006 02:24 PM
No bold fonts on firefox 1.5.0.1 mushk45 Linux - Software 2 03-13-2006 11:09 AM
Can not display bold font in Mozilla firefox can not be displayed! septanla Ubuntu 1 04-24-2005 11:01 AM
Fonts in X big and bold when not using gdm LSA Linux - General 0 03-16-2004 05:56 PM
uneven msg orko Linux - Networking 0 11-24-2003 02:42 PM


All times are GMT -5. The time now is 12:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration