LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2012, 10:44 AM   #1
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Underline "_" in Xterm invisible


Hi,

in my .Xresources file I have the following line
Code:
XTerm.*.faceName: Deja Vu Sans Mono:pixelsize=14:spacing=mono
which configures the font for my xterm. Unfortunately the "_" (underline) is only visible when the text is bold.

In fact I like this font, but it is very inconvenient when programming because one cannot see if for example "my_variable" is one or two words.

Is there a workaround?

Markus
 
Old 10-27-2012, 11:32 AM   #2
dickey
Member
 
Registered: Jun 2009
Posts: 43

Rep: Reputation: 18
Quote:
Originally Posted by markush View Post
Hi,

in my .Xresources file I have the following line
Code:
XTerm.*.faceName: Deja Vu Sans Mono:pixelsize=14:spacing=mono
which configures the font for my xterm. Unfortunately the "_" (underline) is only visible when the text is bold.
The scaleHeight resource, as mentioned here: http://invisible-island.net/xterm/xt...html#xterm_276
 
1 members found this post helpful.
Old 10-27-2012, 12:52 PM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello, thanks for the answer, the sh-option seems to work, but when I use
Code:
xterm -sh 2
I get double linespace and values of 1.1 or 1.2 up to 1.9 make no difference.

Markus
 
Old 10-30-2012, 06:53 AM   #4
dickey
Member
 
Registered: Jun 2009
Posts: 43

Rep: Reputation: 18
Quote:
Originally Posted by markush View Post
Hello, thanks for the answer, the sh-option seems to work, but when I use
Code:
xterm -sh 2
I get double linespace and values of 1.1 or 1.2 up to 1.9 make no difference.

Markus
hmm - if I can reproduce this, I can investigate. At the moment I'm not seeing this (with
Debian 6.0). On that, fc-list says I have "DejaVu Sans Mono:Bold Oblique". Running xterm
with/without the space makes no difference (underlines always show up).
 
1 members found this post helpful.
Old 10-30-2012, 08:10 AM   #5
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
dickey, your help is very welcome, but the problem's still present.

I could now verify that this problem occurs for pixelsizes from 14 upwards.

I think I'll have to try another font.

Markus

Last edited by markush; 10-30-2012 at 08:11 AM.
 
Old 10-30-2012, 08:17 AM   #6
GazL
Senior Member
 
Registered: May 2008
Posts: 3,501

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Deja Vu sans mono works fine here and is my preferred font.
hinting can make a significant effect on this font though.

Code:
cd /etc/fonts/conf.d && ln -s ../conf.avail/10-autohint.conf
.Xresources:
Code:
gazl@ws1:~$ cat .Xresources 
xft.antialias: true
XTerm.*.background: black
XTerm.*.foreground: lightblue
XTerm.*.faceName: Deja Vu Sans Mono
XTerm.*.metaSendsEscape: true
XTerm.*.backarrowKey: false
! Tango Color Scheme 
*color0: #2e3436
*color1: #cc0000
*color2: #4e9a06
*color3: #c4a000
*color4: #3465a4
*color5: #75507b
*color6: #0b939b
*color7: #d3d7cf
*color8: #555753
*color9: #ef2929
*color10: #8ae234
*color11: #fce94f
*color12: #729fcf
*color13: #ad7fa8
*color14: #00f5e9
*color15: #eeeeec
 
Old 10-30-2012, 08:54 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
No difference. Gazl, it seems my .Xresources file is very similar to your's.

Where is a detailed documentation about the fonts in X?

Markus
 
Old 10-30-2012, 09:29 AM   #8
fgcl2k
Member
 
Registered: Jan 2011
Distribution: Slackware 14.1
Posts: 108

Rep: Reputation: 29
Quote:
Originally Posted by markush View Post
Hello, thanks for the answer, the sh-option seems to work, but when I use
Code:
xterm -sh 2
I get double linespace and values of 1.1 or 1.2 up to 1.9 make no difference.
When you get double linespace can you see the "_" character?
 
1 members found this post helpful.
Old 10-30-2012, 09:30 AM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,501

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
I don't think there is one source of information for this stuff. It's all rather messy and certain bits have evolved or been obsoleted over time. Best just to google for 'X' and 'fonts' and start there.


The desktop environments such as kde/xfce have their own hinting settings which can have a major effect. if you're using one of those desktops then perhaps try playing with the settings. You may also want to try using a minimal window-manager based desktop (which is what I use) which won't interfere with the font rendering.

Other than that, the only other thing I can think of that might cause your underscore to go missing would be if your X display is not running at the native resolution of your screen (assuming lcd panel).

Other than the above, I can't think of any other suggestions.

Last edited by GazL; 10-30-2012 at 09:47 AM. Reason: spelling/typos
 
1 members found this post helpful.
Old 10-30-2012, 09:30 AM   #10
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by fgcl2k View Post
When you get double linespace can you see the "_" character?
Yes, then it is visible.

Markus
 
Old 10-30-2012, 09:48 AM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Gazl, I had an idea and tried other WMs, normally I use Xmonad. The problem with xterm is the same with fluxbox and blackbox, XFCE has completely other settings for xterm.

Now I am using Terminal from XFCE and this works fine.

Markus
 
Old 10-30-2012, 10:05 AM   #12
GazL
Senior Member
 
Registered: May 2008
Posts: 3,501

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Very odd that we get different results. I've tried xterm with font sizes from tiny->huge and they all display just fine (though when I use xmag it does look like the underscore is only a single pixel high when rendered so it would be susceptible to obliteration by any errant rendering.

Just out of interest. If you run xmag -mag 16 and select the area where the missing underscore is, do you see it in the magnification
 
1 members found this post helpful.
Old 10-30-2012, 10:09 AM   #13
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by GazL View Post
...

Just out of interest. If you run xmag -mag 16 and select the area where the missing underscore is, do you see it in the magnification
No, even in the magnification it is invisible.

Markus
 
Old 10-31-2012, 05:47 AM   #14
dickey
Member
 
Registered: Jun 2009
Posts: 43

Rep: Reputation: 18
Quote:
Originally Posted by GazL View Post
Very odd that we get different results.
Not so odd, considering that a lot of the hinting configuration is installed automatically (and not consistently from one platform to another). Given a specific version and configuration, it's (usually...) possible to isolate the problem.
 
Old 12-12-2012, 07:06 PM   #15
GazL
Senior Member
 
Registered: May 2008
Posts: 3,501

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Don't know whether you got anywhere with this Markus, but I just thought you'd be interested to know that when I just tried the latest nouveau and libdrm version from git on my system, my underscores disappeared too, so you're not alone in this. I swapped back to using the nvidia blob.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xterm: cannot match normal font "Monospace" on xterm 282, X11R7.7 ebol4 Linux - Software 2 10-07-2012 09:59 PM
How to set the font-size for "xterm" terminal-emulator (running "bash" shell) ajaygarg Linux - Desktop 1 03-09-2012 01:38 PM
Fedora 15 Grub2 Graphical Menu "Invisible" yet there Remore Linux - Newbie 2 08-21-2011 10:36 AM
a "filename~" type file invisible in nautilus cad Linux - General 5 01-03-2007 05:11 AM
LXer: Linuxworld Boston mulls "invisible Linux" pavilion LXer Syndicated Linux News 0 12-12-2005 11:01 PM


All times are GMT -5. The time now is 05:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration