LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Unable to unlock session with KDE 3.5.4 (http://www.linuxquestions.org/questions/slackware-14/unable-to-unlock-session-with-kde-3-5-4-a-480938/)

swampdog2002 09-06-2006 11:02 AM

Unable to unlock session with KDE 3.5.4
 
Hello,

As a regular user, when I attempt to lock the session from the KDE menu, I can lock the computer, but when I attempt to unlock the session I am prompted that the password is invalid. I am using the correct password, but nonetheless, I am unable to unlock a session as a regular user. This problem is not apparent as root, as I have verified this. Are there permissions somewhere to set, either in KDE or /etc/group, that allow users to lock and unlock their sessions? Any help is appreciated. Thanks.

KeithE 09-06-2006 11:29 AM

KDE 3.5.4 seems to be rather unstable
 
I've never seen that problem, but I had my KDE screensaver totally hang up (read: it crashed the kernel) two machines (one Fedora 5, one Slackware-current) after about 8 hours of operation. Between that and some applets crashing Kicker, I removed KDE from all my machines regardless of distro. Enough is enough.

masonm 09-06-2006 11:30 AM

The easiest solution would be to delete the ~/.kde file. Of course you'll lose any settings and you'll have to set it up like you want it again, but at least you should have your session access again.

avheretic 09-07-2006 12:01 AM

The problem lies with the kcheckpass binary in the kde/bin directory. Make sure it is owned by root and it has its suid bit set ie.

Code:


chown root:root kcheckpass
chmod 4755 kcheckpass

Worked for me.

Woodsman 09-07-2006 12:41 AM

Quote:

The easiest solution would be to delete the ~/.kde file.
No need to delete all of your configuration files. As a brute force test, just exit X/KDE and rename the ~/.kde directory.

I'll take a wild first guess the problem is a corrupted saved session. Exit X/KDE and then delete your user sessions. They are stored in $HOME/.kde/share/config/session. When you exit KDE, do not save the current session.

Quote:

The problem lies with the kcheckpass . . .
There are also kcheckpass files located in /var/run and will have a file extension of the user ID (UID): /var/run/kcheckpass.UID. You might want to delete those files too.


All times are GMT -5. The time now is 01:53 PM.