LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-11-2008, 06:37 AM   #1
acheong87
LQ Newbie
 
Registered: Jul 2008
Posts: 7

Rep: Reputation: 0
Unable to start X after installing FGLRX


Hello. I've spent several hours on this problem. I've searched Google and looked through Phoronix, ATI CCHTML, UbuntuForums, as well as LinuxQuestions, but to no avail. The problem is simple - I can't start X.

I did a clean install of Slackware 12.1. At that time, I could startx just fine.

Afterward, I obtained the latest ATI proprietary drivers, built the *.tgz packages, and used installpkg to install fglrx. (I followed the guide at http://wiki.cchtml.com/index.php/ATI...uild_%28ENG%29 exactly.) Once I rebooted, I was no longer able to startx - the screen turns black, then returns, saying that it failed to start X. I tried various modifications to xorg.conf but nothing helped. The end of my /var/log/Xorg.0.log is as follows:

Code:
(EE) fglrx(0): Invalid video BIOS signature!
(EE) fglrx(0): GetBIOSParameter failed
(EE) fglrx(0): PreInitConfig failed

Backtrace:
0: X(xf86SigHandler+0x80) [0x80dbde0]
1: [0xffffe420]
2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(amdPcsFree+0x36) [0xb787f356]
3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x2c6) [0xb7858d16]
4: X(InitOutput+0x9be) [0x80a2443e]
5: X(main+0x286) [0x806dba6]
6: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7d26390]
7: X(FontFileCompleteXLFD+0x20d) [0x806d0e1]
Can anyone provide any hints or thoughts? Thank you. By the way, I backed up my original xorg.conf (right after the clean install); when I restore that original, I can startx just fine.

(I am running Slackware 12.1 on a Lenovo ThinkPad T500. The graphics card is ATI Mobility Radeon 3650 with 256MB. Please ask for my xorg.conf file if you would like to see it. Also, if you think a stack trace may help, please let me know as well.)
 
Old 09-11-2008, 06:46 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,384

Rep: Reputation: Disabled
Quote:
(EE) fglrx(0): Invalid video BIOS signature
Sounds like your card is not yet supported by the fglrx driver? Just guessing here.

Eric
 
Old 09-11-2008, 09:00 AM   #3
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
I don't see that series listed in the 8.8 supported list. Have you tried adjusting some of your bios settings. ie( the pre-init vga settings). Most likely it will say something like pci, agp/pci and agp. I would try switching those around and see if that does the trick.

Well, good luck.
 
Old 09-11-2008, 06:47 PM   #4
acheong87
LQ Newbie
 
Registered: Jul 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Problem Solved!

In the BIOS settings, I went to [Config], [Display], [Graphics Device], where the options were "Integrated", "Discrete", or "Switchable". I had it on "Switchable", which uses Discrete for maximum performance and Integrated for battery-saving. I switched this option to "Discrete", and everything started working fine! Also, for those others having the same problem, make sure to disable [OS Detection for Switchable Graphics] in your BIOS, else BIOS will revert to "Switchable" every time you reboot.

I am now running at 1680x1050 resolution. If anyone wants me to post/send them my xorg.conf or would like assistance, please send me a message or email. I'm going to try Compiz/Beryl now.

Code:
bash-3.1# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3650
OpenGL version string: 2.1.7873 Release
Thank you!
 
Old 09-11-2008, 08:46 PM   #5
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
Good to hear..

You should add to the wiki under trouble shooting. The fglrx driver seems to be a pain for many people.
 
Old 02-01-2009, 05:18 AM   #6
nedyar
LQ Newbie
 
Registered: Jan 2009
Posts: 2

Rep: Reputation: 0
I have the same problem but i cannot modify the bios settoing, what can i do? The driver work perfectly with ubuntu 8.04 but it doesn't work with Ubuntu 8.10 and i need the last one because it support linux kernel 2.27 that is usefull to use wireless
 
Old 02-01-2009, 06:08 AM   #7
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,226

Rep: Reputation: 187Reputation: 187
Quote:
Originally Posted by nedyar View Post
I have the same problem but i cannot modify the bios settoing, what can i do? The driver work perfectly with ubuntu 8.04 but it doesn't work with Ubuntu 8.10 and i need the last one because it support linux kernel 2.27 that is usefull to use wireless
I also had this problem and like you my bios on my laptop has extremely limited options, the only fix I found was to downgrade to ATI catalyst 8.11 for now.
 
Old 02-02-2009, 09:17 AM   #8
nedyar
LQ Newbie
 
Registered: Jan 2009
Posts: 2

Rep: Reputation: 0
I have found support for my wireless card with Ubuntu 8.04 so i not urge to solve this problem with new xorg. However to downgrade to ati catalyst 8.11 need only to remove the newest, download and install precedent version?
 
Old 02-03-2009, 02:03 AM   #9
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
Yep, there's an uninstall.sh somewhere (that, as root, I ran it).

Forgot exactly where, /lib/something_or_other (ati?)

Then DL the 8.12 Catalyst (9.1 wouldn't work for me).

I started another thread, shared my success with fglrx and also IRQ (plug and play)

http://www.linuxquestions.org/questi...el-p45-701821/

Alan.
 
Old 02-03-2009, 02:53 AM   #10
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,226

Rep: Reputation: 187Reputation: 187
the uninstall script is in /usr/share/ati
 
Old 08-07-2009, 03:43 PM   #11
trent1980
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by acheong87 View Post
In the BIOS settings, I went to [Config], [Display], [Graphics Device], where the options were "Integrated", "Discrete", or "Switchable". I had it on "Switchable", which uses Discrete for maximum performance and Integrated for battery-saving. I switched this option to "Discrete", and everything started working fine! Also, for those others having the same problem, make sure to disable [OS Detection for Switchable Graphics] in your BIOS, else BIOS will revert to "Switchable" every time you reboot.
I love you. This was driving me nuts. FIXED

trent@t-ubu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3650
OpenGL version string: 2.1.8787 FireGL


Running 1920x1200
 
  


Reply

Tags
ati, fglrx, slackware, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 7, fglrx, X doesn't start tpetri1807 Linux - Hardware 3 08-04-2007 02:20 PM
Unable to get 1440x900 resolution after install of fglrx drivers JRR883 Linux - Hardware 3 03-21-2007 09:59 PM
Unable to use ATI's fglrx (8.29.6) on sid's X.org (7.1.1) andreag Debian 2 10-28-2006 07:47 AM
after installing kernel 2.6.9 unable to start X. Kilahchris Linux - Newbie 3 07-21-2005 01:52 PM
unable to start apache after installing NIC driver bcarl314 Linux - Newbie 6 09-24-2003 07:43 AM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration